Faulty MiniRAMBo??

Hello all - I am in need of some assistance. I have constructed a low-rider 2 build and had it up and running for a day. Everything worked as it should. The next evening I made it out to my shop exited to start toying around with feeds & speeds only to find that my z axis has zero torque and could not raise the assembly at all. I was able to verify there is no issue with my wiring or steppers. (When the z axis is plugged into one of the other axis ports on my MiniRAMBo it works just fine and has plenty of torque). I have tried wiring the motors into the two separate z ports and that did not help at all. I did not change any settings whatsoever. This means there must be an issue with my MiniRAMBo correct? How is that even possible when all it did was sit in a case for a day…

Has anyone else had similar issues? My power supply is running at about 22 volts. Let me know if there is any more helpful information I can provide for feedback. Any help is greatly appreciated. Thanks, JH

Hmmm. Could be a broken driver or digipot on the Z axis. I’m not sure how it could have broken just sitting there powered off.

You could check the motor current with M907 and make sure that hasn’t changed:


Where did you get the board?

As a last workaround, if you can reprogram it, you can switch the pin assignments for Z and E0 and then the E0 port will act like Z and you can plug Z in there.

I haven’t seen this issue before with the mini rambos. They are built very tough.

1 Like

It’s worth checking that the grub screws are tight on the steppers. You may have covered this with your flip of the axis check but after cutting with mine for a bit I found all the grub screws had loosened out. This problem is a common one that manifests itself with lazy axis operations.

I’m sure you’ll figure it out the help resources here are great.

1 Like

Thank you both. The grub screws are not the issue and yes the power was off :slight_smile: thanks for clarifying.

I was able to check the motor current and it has not changed. I bought the board from this website with the firmware already flashed… Though I did go through the firmware steps using arduino just to get familliare with the process. That is the extent of my firmware/arduino experience. I like the idea of changing the pin configuration for the Z and the E0 ports and am trying to figure this out. After scrolling throgh the config tabs in arduino and browsing the marlin website it doesn’t apear very obvious :confused: Does anyone have any tutorials on this or am I better off buying a new board? Thanks,

In the pins file:


It’s possible it could be your jerk feedrate and acceleration settings... if it works connected to your extruder pin those values are probably configured much lower. I found I had to drastically lower my values from the stock settings to get the z axis to not miss any steps

Once you swap to your extruder, it will be using the same jerk, acc., and speed limits. It might have explained imwhy it worked with the x driver.

This makes the Z wired in parallel cutting the available torque in half. You need to be wired in series, or change the pins to allow for two drivers.


You mention your power supply voltage but not amperage or what steppers you are using.

Steppers are the nema 17’s from this website. Power supply is providing 15 amps… should be pleeeeenty.

Unfortunately I just don’t have enough firmware experience to make this easy. I am trying to learn but it is tough to find good resources for such specific questions :frowning: For example I have searched the marlin files in Arduino trying to find the pin assignments with no luck. I would also like to be able to provide you guys with my Z axis acceleration and jerk feed rate for comparison but cannot find these either :frowning: I believe this would be the best way to verify if the board was actually broken.

Ryan has informed me the board has a warranty and he would be nice enough to test it out and replace it… I just don’t want to ship something back to him that actually works and waste his time. On the other hand, I don’t know how long this will take me to figure out :frowning:

Are you using my firmware? Don’t change anything yet and just re-flash it and see if that works.

1 Like

I agree with Ryan. I would add resetting just the eeprom is:


That will restore the settings to what was flashed. In some cases, even if you reflash it, it will not clear the settings. So I would reflash Ryan’s firmware amd then do the M502 M500 before testing.

1 Like

Welp… still no luck and I am completely baffled. I was able to re-flash the firmware and reset the eeprom. This made no difference. I removed the router from the top minimizing the carriage weight. The Z steppers do not have enough power to move the routerless carriage up…

I have also purchased a new driver board from this website so I could compare boards and not waste Ryan’s time. I’m glad I did this because I’m getting the exact same results. I did not do anything with the new board except open the box and plug it in.

Finally, I took the whole carriage off of the cutting table so the lead screws for the Z axis were horizontal. I am able to pinch my fingers together gently near the grub screws and this is enough force to stop the motors from rotating… shouldn’t there be more resistance??

Soooooooo I guess I’ll try re-wiring AGAIN but I have no idea what the issue is. Help?




When you plugged the z axis into the x port, it worked, eliminating the wiring and motor and pointing to a board problem. Then you swapped the board and still had the problem, eliminating the board as the problem. So therefore your problem is fixed. Elementary. :slight_smile:

I think you are on the right track now with the z wiring and recognizing the problem is intermittent.

I would disconnect the z connector at the board and put an ohm meter across one of the pairs. Then wiggle the connectors and wiggle the wires to see if there is an area that is bad. The motor can lose torque from a broken connection or a short circuit. The ohm meter can detect both.

Another question - Greg mentioned he had to “drastically lower my values from the stock settings to get the z axis to not miss any steps”. Is this a typical step everyone has had to take??? If so, is there a tutorial for it anywhere?

With everything built per spec, everythin bought from this website, everything rewired 4 different times, and swaping out driver boards, I’m getting the same results - z steppers cannot move the carriage up (even without the router on it).

Josh it is not typical or I would change the instructions and default settings, the person is using allthread not leadscrews… There are many reasons this can happen please open a new thread and describe your hardware and settings so we can help you.

1 Like