File extensions in repetier

Hi, just got the machine together and have it connected and moving through repetier. Problem is loading the file saved from estlcam is a .nc and repetier won’t open it. In object placement or load file it just flashes the file up and then goes away… Running windows 7 pro on a new laptop just for this CNC… Have been through forums but found no solutions. I can load a stl file from tinkercad bit nothing from estlcam. tried changing it to a .stl as it saved but still nothing… Any ideas from someone smarter than me at this computer code stuff??

Just change it from .nc to .gcode. There is an option in estlcam to do this by default.

Hey thanks for youre help on this. Ok so I tried that and I either get the same thing ( looks like it flashes up for a second then gone) or on a different file it might say no layers were detected please repair the code… I’m not completely new at this but am still learning to read and modify a g code… I still consider myself as a new guy at this but do have my 3d printer experience. I use matter control on the printer which is very user friendly but never used repetier before a couple days ago… Cannot understand why the files from estlcam won’t load… Tis driving me nuts! over something stupid I’m sure…

Zip your file and put it up here. Did you try my test file did that work for you? I’m just about done for the day, so you might not here from me until the morning. Still have some things to do , just a heads up so I don’t seem rude.

Well I did get the test file to load and run by dragging the file over and dropping it (cant use the load button for some reason) but none of the ones for estelcam will yet… They save as gcode file like yours is so I don’t really know whats wrong with the others… Should I uninstall repetier and reinstall it???

here is one of them (6.44 KB)

here is another n sorry if its something stupid… btw this cnc is brilliant! especially the center section. you are a pro at this in my eyes. that would have taken me years to tinker up. (1.38 KB)

So 0103 opens for me in repetier, but it is super tiny maybe 1mmx1mm. Horse doesn’t open unless you change the extension to .gcode, then same thing way too small. so when you import your sketch import it as inches or centimeters maybe.

Your code looks fine just fix the extension to .gcode.

Thank you so much. Still can’t see them to resize in repeater but if I resize the snot out of it in estelcam and save it as a .gcode it will load to print preview… Any ideas as to why it won’t show up in object placement? It will switch to print preview and i can print or (write it with a pen)but Not able to resize in repeater. The board goes blank when you switch back to object placemant tab… Thoughts or suggestions? N thank you again for the help, I never would’ve seen it that small… I looked, it had to be under the dot…

You have to resize it in estlcam to get the tools paths correct. The other way is just to import it into estlcam in the correct units.

You can’t see it in object placement because it isn’t an atlas, that window if for 3d print slicing only.

Ok so I have managed to get both the files to print now n I think its gonna take some getting used to all the features of estlcam… Basicly the file needs to be ready to go in estlcam and just transfer to repeteir to run it. Is that correct? That’s the only way I see to change the size and placement of the object on the board… Question if you are gonna mill out something say cut a stencil out of plastic or acrylic. Do You just use etch at a slightly larger depth than the material? How are you previewing the path in repeteir? Looking for The side view that shows the negative z movement of the tool

yup, estlcam does all the programming, repetier just talks to the cnc.

Yes again, slightly through the material into the wasteboard.

There are programs to preview the path is you need more than the estlcam preview. The estlcam paths window can be rotated and usually shows what you want to see. preview programs are usually kinda cruddy.

Yet another question… Been messing with trying to make something in estlcam and I resize it after tracing lines in etchetch and move it where it should bebe on the board. Save CNC program and save as .gcode go to repetier and load that file and nothing… Print time is zero and there’s nothing there… Can you tell me what I’m doing wrong… Seriously ive Tried about everything I can think of to make it work. This should be simple!

Click the box that says show travel moves in repetier.

Did you follow my estlcam walk through, did that work for you?

yea I keep the show travel moves box checked but never see anything on the board… ill go through it again just to make sure I didn’t miss something. see if you can tell whats up with this one if you have time… don’t really know what im doing wrong or where. (181 Bytes)

I have no idea what that is, it is the wrong format. Did you select marlin in estlcam?

yes, its all set up like the walkthrough info says. I have so many files on here ive tried to make that wont open in repetier… when I load a file, to get it to show the ones i’ve made I have to click show all files to see them. its like there all the wrong format for what repetier is looking for. I set the estlcam default to .gcode under the cnc crogram generation. could that be the issue?

Ahhh, I think I have it. You should be saving file-“Save cnc program” not save project, is that it?

If not make sure you have it set like the pic.


hey sorry power went out here… anyways, I double checked everything and yes was saving it as cnc program. however I was able to make and open two of them after selecting the lower box the under resize tab in estlcam. not sure what all the function are in that program yet… does that make since? the kit I ordered yesterday is gonna be a 4x8 plasma cutter cnc. gonna read up on the pause before movement but I might be asking about that too… I think I can etch like with a pen but pause before movement. thank you again for you’re time and help… and an awesome project!

I would uninstall estlcam and re-install. You’ve got something fishy going on.
Never heard about pause before movement what do you need it for?