Firmware flashing

I have had the firmware flashed but I could not get the end stop to work so I erased the firmware and flashed again still no end stops. The third time I tried to flash I have blank screen and error when flashing. Please advise how to proceed. Also can you send me the correct firmware for using dual end stops.

Thank you,



You probably need to provide a bit more information such as

  1. What your motherboard is?
  2. How you are flashing the MB?
  3. How did you build the firmware?
  4. Where did you get the firmware from?

The latest firmware is here

Generally, the more information your provide, the easier it is to help. Don’t forget that nobody knows what system you have and what you have done so far.



Archim 1.0 and I downloaded the firmware off the V1 website. I am using the Arduino 1.8.13 to upload firmware.

This may sound like a dumb question, but did you download the Archim Dual Endstop firmware?

Second question, are you sure the flash was successful (the previous times) What version does it say on your LCD (if you have one)? It should say something like 425 D. (I am not certain what the latest version is, but most importantly the D indicates its dual end-stop firmware)

You say your screen is blank, I am going to assume you mean an LCD you have hooked up to the Archim. You also say you get an error now, but its unclear when you get this error, or where, or what the error is exactly.

As @rwillett said, you need more information if you want help.

To be clear, I have the Archim 1, with Dual End stops, and have gone through my fair share of debugging getting it to work, so I might have an idea what is going wrong with yours; but not without more detail.