first axis runs fine, second axis grinds

Hi all,

I had a Rambo running my machine and it started acting odd (seemed like the X axis was not working) I thought I fried a driver on it so I reflashed it with MM3DP software and wired it up on my MP3DPand it works fine. I replaced the Rambo with a RAMPS I had lying around on the MPCNC and ran some tests. No matter what axis I move first, it runs fine. The second axis I run rumbles and grinds like the motors are missing steps or turning opposite each other( they are not, I checked and double checked). The video give you an idea of what I am refering too. I moved the X axis, then the Y axis( grind, rumble) then the Z axis( grind, rumble).

https://drive.google.com/drive/u/0/folders/1JbrNJ5m5dL2vav2YBLYpCmsiVHBvVfbz

Sounds like the series wiring is not correct. Your video is private so I am just guessing.

Can you elaborate on the series wiring? I am using all 5 stepper drivers on the RAMPS board as shown on your website. I dont understand why the second axis always grinds. try this link for the video.

Series wiring the steppers gives you the same current through each stepper in lieu of the steppers sharing the current in a parallel arrangement. See https://www.v1engineering.com/assembly/wiring-the-steppers/ for what this looks like.

Yep, one of the 4 stepper wires isn’t making contact.

I dont have the steppers wired in series. I have them connected like this picture. Even so, why does the first axis I move behave normally and the second one (and the Z axis) always falter? It does not matter which one I move first, X, Y, or Z.

https://www.v1engineering.com/wp-content/uploads/2017/11/Ramps.jpg

Are you running the dual endstop firmware?

Yes, I re-downloaded it off Github and reflashed it to make sure I had the latest and greatest

I might have solved it. I had an old desktop power supply running the machine. I checked the voltage and it was only about 9.5 volts feeding the board. I changed it out to a different power supply(12 volts) and it is behaving normally again. I haven’t had a change to test it under load yet but so far so good. Do you think that would make it act so erratically?

1 Like

Yep. I was going to mention power, but got sidetracked.