First cursed project ;-) Milling/Gcode issues

Hi all,

Since 2 weeks i’ve got me a working Lowrider and i’m very happy with it. It runs stand alone using Marlin with GCode from an SD card. For Cad/Cam i’ve so far used Fusion 360. However on this project i’m running into issues.

First run Z kept comming down, turned out to be the bit sliding out of the collet, so that was my fault mounting it. However the second try on this project something weird happened when the gcode execution moved from curring an Adaptive 3D profile to a first parallel finishing pass. Instead of starting the wanted vertical arcs it started cutting lateral circles (destroying the workpiece in the process :-p).

also the motion of the machine was not smooth like normal but jerky. I tried to switch it off using the button on the controller, but it did not have any effect. Any clues on where to start digging?

Workpiece:[attachment file=112584]

What was supposed to happen at the point the bad stuff happened: [attachment file=112587]

Gcode: see attachment.

I’ve used the combination of 3D Adaptive clearing and parallel passes before without issues: [attachment file=“20190906_220450 (1).jpg”]

So the toolpath itself does not seem to be the problem. I’m trying to mill a bit faster every pass now to search for the limit’s but that does not seem to explain this problem.

ka-lot-shape.gcode (692 KB)

To be complete, i did a fastforward (250% that was fun) to the failure point in a dry run and recorded the behaviour.

You can see it making circular patterns instead of the parallel passes it should make, and clearly you hear the engines missing steps and moving irratically.

I saw cursed project and I was hoping for Halloween decorations.


Make sure you are completely in the positive workspace. Negative commands are funky with the current dual firmware.

I’m not at my computer to look at the gcode myself but I do know that marlin supports G2/G3 in the XY plane only, unless you enable extra options in the configuration. In principle these extra options enable switching modes to do arcs in the XZ or YZ planes but I’ve never used it. I suspect these are common in CNC land but rare for Marlin.

If fusion generates an XZ or YZ arc and Marlin can’t handle it, maybe it would create XY arcs instead.

Look in your gcode for arc plane switches G17 G18 or G19. Maybe you just need to enable CNC_WORKSPACE_PLANES.

And its also true that exceeding machine limits is bad.

1 Like

I think @Jamie is right. I checked the GCode at the problem location and it is running arcs in g2 with I and K, as far as i can see K is not supported by Marlin and is supported bij GRBL. No clue why it did not use arcs in the candle holder. ( Milling was done in positive workspace, exept for Z btw which is practically impossible).

So if this is the problem, how can i prevent it from using G0-G2 K arcs (in z plane)?

Wow, learn something new everyday.

The post processor might allow you to turn off arcs.

@Ryan, but how? I’m just using the Fusion360 Post operation and select GRBL as post processor (since Marlin is a fork of GRBL) as far as i know, right?

What option do you guys use in Fusion 360?

No, we are not GRBL, we have a post processor for Marlin. It is linked in the milling basics page at the bottom.

I do not know if it has the option or not, I use Estlcam.

@Ryan: thanks, changing the post processor to @Guffy’s Marlin implementation lifted the curse :-). All and all it is a miracle that so many other projects came out just fine with the GRBL post.

Also i like the spindle reminder and status updates it gives on the lcd now. Makes the LR with Marlin even more complete!

Result: [attachment file=112924]

Thanks all for helping out.

Cool, glad we figured it out.