Flashing MRambo Issue

Hi all,

I’m a bit new to this, and made a basic mistake that I thought others may make. So I wanted to post this simple issue.

I was trying to flash the Mrambo and was following the instructions here; https://www.v1engineering.com/marlin-firmware/

I got an error message “Error compilling for board RAMBo”. Pic below.

[attachment file=“arduino 1.9.0 Beta.jpg”]
I started using the current version 1.8.9 and then noticed the instruction “Right now flashing Marlin 2.0 requires the Arduino IDE 1.9 or higher (currently labeled beta)”. So I downloaded the beta version and received the same error message.

I went through the instructions, specifically in managing libraries etc. When instructed to “Sketch-Include Library-Manage Libraries” I searched for “U8glib” and was presented with the following choices;

[attachment file=93491]

So I installed U8g2 and tried to compile, but got the errors shown above. I went back to this screen and scrolled the screen down to reveal another library “U8glib” and installed this one.

[attachment file=93492]

Now when I compiled and uploaded, everything worked properly. and I now have a display with the “ZenXY Ready” in the lower left hand corner.

[attachment file=“MRAMBo pic.jpg”]

So hopefully, if someone else made this simple mistake, this will help them.

Now its time to put it all together. I’m sure I’ll be asking a bunch of questions.

Thanks for pulling all of this together.

Mark - Flagstaff, AZ