Flashing the board not successful

Hi All,

I am building MPC CNC and I am nearly at the end, but I was stopped by the issues with the electronics.

I wanted to reuse my 3d printer board. It is MKS 1.4 Board.

I flashed it with ramps 1.4 preconfigured file MPCNC511_GLCD and it just doesn’t work.

When I flash it, it seems to be OK, but unfortunately on the display I have strange garbage.

I do not get any error when flashing.

Normally when I flash my board for 3d printer, I use the ARDUINO Mega ADK in the board manager.

BUt here I follow the advice to flash it with Arduino mega settings.

Do you know what should I flash my board with?


I disconnected endstops. I use PC,

Firmware MPCNC511_GLCD.

I’d be grateful for any help.



Tha is an mks base 1.4, there are a few kinds and it gets confusing.

I think the Ramps firmware will work, with the ug8lib installed, but the issue you’re having is the lcd plugs are backwards I think, you need to pull the plastic part off the board to be able to turn the cables around.

You can test the board by using repetier host over usb to make sure it works. Then figure out the LCD thing.


Thanks a lot for your help. I followed your advice and it really works in Repetier host.

However what surprises me is how come the LCD works on Marlin for 3d printer but doesn’t work for Marlin for MPC CNC.

I even compared those firmwares and they are 100% the same in LCD sections.

If the cables were backwards, it wound not work for my 3d printer also, but it works.

Any idea here, please?



I see the issue now, the picture was dark. That is not the screen I sell or the firmware is pre configured for. You need to edit the firmware for that other LCD.

OK I see,

But the issue is that on your firmware it is the same as on my 3d printer firmware.

#define DISPLAY_CHARSET_HD44780 JAPANESE and it works with rep rap printer but doesn’t your your firmware.

In both cases I have the same setting but different results.

That is what puzzles me.

That is not the screen edit, further down in the file.

Man, thanks a lot, I missed that.


Now it works !!!