OK, so I finally got Repetier to recognize my RAMBO 1.3 and can move the gantry through the software. Now I can not get the Full Graphic Smart Controller to work. When I power it on, it flashes faintly and beeps. Anyone had this happen before, and what did you d to resolve the issue? Thanks for the assistance. Once I get that resolved, endstops will be the next item to resolve.



Sounds like you might have it plugged in backwards. Look at the pics I have in the UltiMachine page to compare.

Thank you! I had looked at an image from reprap to start with and it had those cables backwards. I may have been premature in stating that I can move the gantry through the software. It appears that it will only move in the positive direction. I am sure this has something to do with the end stops, but they are plugged in and I have tried both the Normally open and closed positions and can’t seem to hold my mouth correct to get them to work correctly. Do you have any advice on what might be happening with that? Is there a way to turn off end stops and still use the same wiring?

These things should all be included in your post. It makes it much faster to diagnose problems.

  1. Did you buy everything from here?
    a)If you did not or changed some things please don’t leave out any details and include what firmware you flashed. Include links so we know what you are using. A “No” answer does not help at all.

b)What board do you have?

c)What firmware is on it or which did you buy it with?

  1. Are you using end stops?
    a)If so how are they wired, NC or NO.

  2. Mac or PC (windows xp, 7, 8, 10?), linux?

  3. Include a picture so obvious errors might be spotted.

Yes, I bought everything from V1.

RAMBO Dual firmware and wire kit.

I do have the end stops and they are wired NC

Using a MAC

Try homing the the Y and X axis individually. Without that the axis is only going to move away from zero.

That worked! Should the end stops be located at the far end away from zero? Now I guess the question is where do I find the cool “crown” everyone is drawing as a test file?

No, they are min endstop in my firmware. The way homing works is it has no idea where it is until it is homed, so it only moves positive (away from the endstop) until you tell it where zero is. This is part of the reason, it shouldn’t be used unless it is necessary.


This morning I tried to lead up the test file and run it, however I ran into a problem. When I attempted to set my home positions things got wonky. It tried to drive my sharpie on the z axis straight down through the work surface although Z Home was already set. I noticed that when I attempt to set home on X and Y it raises Z and shifts in the direction of the axis I am setting. It is doing the same thing in both Repetier and Prints. Suggestions or thoughts as to what may cause this.

Homing X or Y will raise the Z before it starts moving so that is normal. Without some type of Z touchplate or axis switch though, don’t try to home all three axis at once it won’t know when to stop the Z (By home I mean G28). You have to home X, then Y (or Y then X). This will set those to their home positions. To home Z you will have to manually position it and issue a G92 Z0 command either though the command line of repetier or as a line in your gcode program.

I tried what you suggested and it is still acting funky.

This is the log from where I try to zero X. It moves in the x direction when I zero the machine? I would have thought it should stay still at that point since it is the home position.

Y axis does the same thing?

10:34:00 AM: N39 G28 Y0.00 *110 < 10:34:00 AM: X:0.00 Y:0.00 Z:10.00 E:0.00 Count X:0 Y:0 Z:4000 < 10:34:00 AM: ok
Z response is this:
10:34:44 AM: N40 G28 Z0.000 *83 < 10:34:46 AM: echo:busy: processing 10:34:46 AM: Send emergency stop to printer. You may need to reset the printer for a restart!
Had to Emergency stop before it bottoms out the tool head. Any thoughts are helpful. I am using Repetier 1.1.0 if that makes a difference.


Thank you for the assistance. Hopefully it is something easy to figure out.


You are trying to home your Z axis, do you have an endstop or touchplate on that axis?

Just home the X and Y like I said before. Your starting gcode should only contain “G28 X Y”

Or if this is your first movements, do not home anything just learn the machine and how CAM works. Dual endstops is a very hard way to try and learn things.


Is it possible to disable the dual endstops and go to the easy way?


Just don’t use g28.

Ok so took your advice to use just “G28 X Y” and was able to get the crown to print as desired.


Work offsets is next, explained here at the bottom.