G30 command failed --could use some input

Lowrider with dual endstop on Y and Z–Probe is configured to “probe” port on the SKRv1.4 board. a M119 command shows the probe as open and triggered (when the bit touches the plate).

That said, if I manually type in a G30 command, it fails instantly with an error showing its position.

I thought maybe I was outside the probe area so I moved it in 20mm from each axis to clear edge boundary, same result.

Any ideas? I’m sure its buried in the Marlin code somewhere…

G38.2 Z0 is the probe command, IIRC. I have used G30 on my printer. I’m not sure why that wouldn’t work.

Hmm–tried that as well–no error but it doesn’t do anything either–I’ve read in other places that if G28 works (which it does) G38.2 does not. The same threads suggesting a simple G30 to probe, but then I get errors.

What command are you entering exactly? G38.2 requires a destination, like for example G38.2 Z1 will move toward Z=1 and stop when it is triggered. It’s definitely possible to have G28 and G38.2 both working, especially since you are using a separate probe port.

(Marlin plays some games in some circumstances where homing inputs are overloaded as probes. The code is very sloppy with the semantics, and bugs are the result. It is possible but tricky to use zmin as a probe port.)

After I Home, my coordinates are x0 Y0 z117 (homes to max)

When I type G30, Gantry moves up about 2-5mm (assuming I’m not at Zmax) and errors out, G38.2 Z0 (and various other Z values) does nothing.

Yeah. The PR firmware is a bit non standard because it homes up and probes down.

The way we were doing the script was to use G38 along with G92. It would probe down and then you can set the height to zero (or the thickness of your probe, actually). These work instantly in a gcode script or macro.

Well if anyone else has the issue and finds the root cause I would love to know. The machine works great in all other respects–its just a shame that I can’t figure out why it does what it does…

I don’t think it is a problem though?

The dual LR firmware was made through perseverance of some kind users. I just put the changes into our builder. It maybe isn’t what you’re used to, but it is possible to home up and probe the touch plate down. That seems like it has what we need for the LR. I don’t know if any other machines do that.

I know I love the dual Y and dual Z endstop features–was just hoping I could figure how/why my probe commands aren’t working. So yes I know its possible, just don’t know why its not working in my setup. when I enter G30 I get an error, and when I use G38.2 z0, it doesn’t do anything–just sits there (mocking me lol)

Oh, ok. G38 doesn’t even move. Are you sure you have the right firmware? It should be 513DL.

This is the doc I wrote about G38. I am pretty sure this should work:


So any clues you can see as to why it isn’t would be great. M119 should show the Z_probe and you need to confirm it shows triggered and open when it should.

This is my base marlin file: “Marlin_V1CNC_SkrTurbo_DualLR_2209_2.0.9.2_513-src”

everything works as it should (home, cuts, etc.) M119 shows all open when not on endstops and triggered when endstops are reached–same for probe–open when not shorted, and triggered when touched…probe is connected to “probe” port of the SKR board and is setup as z_min_probe p0_10 on the pins file.

I also have these lines at the end of the configuration.h file:




#define Z_MIN_PIN P0_10

#define Z_MAX_PIN P1_00

#define USER_DESC_4 “Probe Z min”

#define USER_GCODE_4 "G38.2 Z0

I don’t use the Y-max or Xmax pins but instead use software endstops…

Oh. I missed that this was a V1.4. I hate those names. Hmm. I don’t think that has been tested. The skr Turbo was added, and we made a dualLR version, but it isn’t in many machines.

This is the skr not turbo and not pro board?

I have an skr Turbo on my LR right now, but I haven’t ever attached endstops and I haven’t tried the probe since I installed that board (I do a lot of control board swaps).

Sorry for taking so long to understand.

Check if you are using Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN

If you are using the same zmin and probe, you must disable it (which seems backwards).

I searched some of my older posts when I knew more, which I have since forgotten:

1 Like

I accidentally figured this out…Turns out my multimeter wasn’t reading continuity between the bit in the router and the SKR board so assumed there was none. Turns out there is a full ground loop connection and as a result I was in effective touching ground to ground with my probe. Once I switched the wires and put the touch plate on the signal side, Marlin could then see a closed loop when the bit touched the plate.

Now a G38.2 z2 command does whit it is supposed to–thanks for all the feedback!


Nice find. You are not the first to be big by that bug.