G38 probe issues

It seems that marlin has an issue with negative X or Y probing. For Z all is ok.

As example:

The sequence
G38.3 X10
Works properly.

But the sequence
G38.3 X-10
In most cases didn’t make second touch. Stop somewhere in the middle in a random position. Sometime it stops even without making first touch.

Same behavior for Y.

Disabling software endstops doesn’t help.

Firmware - latest dual endstops mpcnc Marlin for ramps. + merged marlin release

I have added a lot of debug messages into g38.cpp and it seems that all destinations calculating properly.
So it looks like some external reason exist that inspire stop of movement.

Hi Guffy… I found something similar I wrote up a marlin issue on it but it was for bed levelling… if you are having the same issue as me I list a line that does the sanity check I commented out to get my probes working.

I have a vague recollection of seeing the same thing. It was a while ago and I shrugged and figured maybe G38 only worked in the +X and +Y directions. Although it really should work both ways so I would call it a bug.

I also vaguely recall such issues, except that I used absolute coordinates (G90). I just made sure that I set the origin (with G92) before probing in such a way that all probing coordinates I’m going to use are positive.

When the position is not zero, as example, X=30 - probing to negative direction (actually to X=20) has absolutely same issue

So I made the ticket
lets see what guys will say

1 Like

So they closed the ticket because I just didn’t answer in 3 days.
(Honestly why to ask is it fixed if was no newer Marlin releases?? How it should be fixed?? magically? but ok)

Moreover, I can’t add a comment because "An owner of this repository has limited the ability to comment to users that have contributed to this repository in the past. "
nor create new bug ticket because "An owner of this repository has limited the ability to open an issue to users that have contributed to this repository in the past. "


I think they are closing issues for 72 hours or something. They are trying to get a handle on it. If you can’t get back to it in a few days, remind me and I will raise a flag where I can.

They must get just an enormous amount of BS issues from people reporting bugs that are just user error or hardware problems. I don’t envy them. Hopefully whatever they are doing will make it easier to get good issues attention, and make common issues get solved automatically.

How to explain him?)

Is commenting disallowed only because it’s closed? It would be pretty silly (but not inconceivable) if they refused comments while it was open and then closed it for lack of comments.

Could this issue be the cause for dual end stops not working? I’m still struggling wit them
( actually ignoring them for a while).

Very unlikely that this is related to dual endstops not working. Best to open a new thread and describe what you are seeing.

I’ve given myself a temporary time out from them. I have a thread going this just looked like it could be related. I’ll get back to my thread when I get tired of using the machine or need the endstops. Thanks.

I just remember seeing a tweet saying they were disabling issues for 72 hours, unrelated to your pr. They said it was for some kind of maintenance. I have no idea beyond that.

Here is the tweet. Looks like it was two days ago:

I see. Thanks

Open again.