gcode from Repetier-Host to MKS SBASE failing

I am connecting to this MKS SBASE board using a network cable from the computer to the MPCNC machine. It also does the same thing using the USB connection. I am able to manually move the motors with Repetier in the X, Y & Z. The problem comes in when I try to send a gcode file to it. It seems to start out ok, but then the Z motor seems to make a pulsing noise after it moves the Z-axis initially. Here is video I took showing that. You may have to turn your volume up near the end of the video to hear the noise. https://youtu.be/6k-c_yW2t18

Here is the simple gcode. It just draws a rectangle for the limits of the maze I am going to cut.
;Project 10x20_Outline_mm
;Created by Estlcam version 10 build 10.021
;Machining time about 01:14:42 hours

G90
G00 X0.0000 Y0.0000 Z0.0000
G00 Z2.0000

;No. 1: Engraving 1
G00 Z0.5000
G01 Z-1.0000 F6 S24000
G01 Y254.0000 F15
G01 X114.3000
G01 Y0.0000
G01 X0.0000
G00 Z2.0000

In Estlcam I used Marlin as the CNC program preset. I attached screen captures from the settings I used with Repetier-Host. I also tried using the Ping-Pong Communication method with the same result.

I am essentially using the config.txt file that Ryan created. I am not using limit switches for my testing to keep it simple.
Here are the only changes from Ryan’s file that I changed:

alpha_dir_pin 0.5!
beta_dir_pin 0.11!
gamma_dir_pin 0.20!

network.enable true
network.ip_address 192.168.1.100
network.ip_mask 255.255.255.0
network.ip_gateway 192.168.1.1 # the gateway address (address of laptop network card)

Anyone have any ideas as to what I am doing wrong?

With some further research, I came across this page.
http://smoothieware.org/grbl-mode

I will try this tomorrow.

That is interesting, I wish that page gave more detail what exactly changes.

I finally found my problem. It was in the Gcode I was sending. I was not paying attention to the Feed speed & had it way too slow. After sending this MKS SBASE board back, I bought the Ramps board from Ryan & had the exact same problem. So I restored my laptop from a previous image backup that I knew had all the settings in Repetier that worked. I still had the same problem, so I found a Gcode file I had created last year & that worked. I then looked at the difference in the files & then it finally popped out at me.

This is the line that was failing.

G01 Y254.0000 F15 ;Did not work. 15mm per minute was apparently too slow to calculate
G01 Y254.0000 F900 ;Should have been what I used

I was using mm/min when I should have been using 15mm/sec when creating that tool in EstlCam. I need to go back to the basic tutorial, so it sinks into my head this time. I did sure learn a lot from this mistake though. Now I know that when I hear those motors just pulsing with a noise & not moving, it must be too slow a motor movement.

Mine is doing the same thing!!!

My problem was in the gcode. I had mm/sec & mm/Min confused. I now have it set to:

mm/Min for the CNC program
mm/Sec for Estlcam Feed unit & my 1st cuts work fine.

I am back to using the Arduino/Ramps, but that seems to have been my problem with the MKS SBASE board also.