gcode not matching simulation

Hey guys, I’m trying to use this function of Estlcam “Carve Pocketing Tool” to set a separate tool for wide, flat areas inside carved areas. I chose the Carve function because the thing I’m trying to v-groove has pointed ends, and that seems best for those. So I set it to carve, select my 60deg v-bit, and I choose my flat 1/4" router bit to do the pocketing… Here’s where I’m having issues… All that seems to be fine, and when I run the simulation, it shows the tool changes in the proper places. I set the tool changes to happen in a certain place, and to raise up a bit to make tool changing easier, etc. So it does this when the gcode first starts, as though I’m changing to my 1/4" bit first, but then after it has run all the pocketing, when it SHOULD run a tool change, and when the simulation shows it apparently does, in real life it does not… And the M00 code which runs at the beginning and requires me to click the button, also only shows up once in the gcode… Is this a normal thing in Estlcam? Is there another way to achieve what I’m trying to do? If I use the other options in Estlcam, like “Hole” I’m afraid my straight 1/4" bit will go right to the edges of the outline, and there won’t be anything left to put a 60deg chamfer onto…

I just used this exact feature a few days ago and it worked as planned. Try uninstalling and reinstalling estlcam maybe, make sure your tool change script is in the correct place.


I have never had a tool change happen first thing. This leads me to believe you have your script in the wrong place. The machine assumes you have the correct starting tool. Sounds like you put your tool change in “starting gcode” not “tool change”.

1 Like

Sorry, I’m an idiot… So the reason it seemed like it was doing a tool change before anything else, was that there were no areas that Estlcam deemed necessary to clear out using my larger bit… I used this function quite a bit lately, and it worked quite well…

1 Like