Getting baby steps when send file RAMPS

when i play with the buttons or the nub on the LCD the machine moves just fine when i hit the key lets say X+/- or Y+/- 1 inch or 2 or whatever i set it to it moves just fine the problem is when i send the file to the machine.

See the red line, the machines suppose to move around it 43x88mm but when i send the file to the ramps 1.4 the machine only moves in an area of like 3x5mm is like is doing baby steps its doing the same thing with Marlin or GRBL right now am making the gcode files with makercam but those files works just fine with my CNC Shield+GRBL, do i need to modified something on the Ramps?

Make sure you have the proper post processor for Marlin/reprap. That is as much help as I can give with grbl or mastercam. Might want to the recommended stuff to make sure it all works as it should. If you follow the instructions you will come upon the crown demo, and my verified gcode to test. Then try and transition to other software and systems if you feel the need.

1 Like

Do you think am getting that problem be cause am using 2 stepper motors in one driver? am using 2 motors for X and 2 for the Y axis with just one DRV8825 and using 3 jumpers under drivers?

Nope, my mpcnc uses one driver per two steppers as well. Like Ryan said, download the crown gcode from the getting started instructions and see if that moves correctly.

1 Like

Ok you guys i tried the crown gcode and it works now its making regular steps instead of baby steps, but now my question is why? heres a peace of Gcode that i get from makercam like i said makercam works just fine with my other machine running CNC shield+GRBL, do i need to erase some code at the beginning?


G20 G90 G40

G0 Z0.5
T0 M6
G0 X1.7334 Y0.794
G1 Z-0.0416 F20
G1 X2.1619 Y1.2117 F20
G3 X2.1996 Y1.3012 I-0.0873 J0.0895
G3 X2.0926 Y1.4249 I-0.125 J0
G1 X1.5005 Y1.511
G1 X1.2357 Y2.0475
G3 X1.0115 Y2.0475 I-0.1121 J-0.0553
G1 X0.7467 Y1.511
G1 X0.1545 Y1.4249
G3 X0.0475 Y1.3012 I0.018 J-0.1237
G3 X0.0853 Y1.2117 I0.125 J0
G1 X0.5137 Y0.794
G1 X0.4126 Y0.2043
G3 X0.4108 Y0.1832 I0.1232 J-0.0211
G3 X0.594 Y0.0725 I0.125 J0
G1 X1.1236 Y0.351
G1 X1.6532 Y0.0725
G3 X1.8364 Y0.1832 I0.0582 J0.1106
G3 X1.8346 Y0.2043 I-0.125 J0
G1 X1.7334 Y0.794
G1 Z-0.0832 F20


Whatever post processor you are using is not the right one, that is not marlin compatible gcode. Your speeds are also way off.

= 0.33mm/s and it should be formatted differently or on each line.

What Post processor are you using exactly?

AM not sure what you mean by ‘Post processor’, but i use to create the gcode i found it easy to make gcode also free you can use it online or offline, and using Marlin+Ramps 1.4+DRV8825+nema 17 84oz. you see on the picture maybe i need to change something to make my gcode marlin comparable?

You 100% need the right post processor or it is like giving someone directions to your house in klingon, it will not work. The post processor translates that software’s program to work with specific firmware. That one you chose is not a very common one to use so I think you should stick with estlcam until you have the basics down. From there there do seem to be more common options with the correct post processors for Marlin.

For more info look at the milling basics page.

For other cam programs, like fusion 360, the post processor writes the gcode from the dimensions. Grbl and Marlin are similar, but not the same. You need to configure the cam to be compatible with marlin.

The problem is, most likely, that your gcode is in inches. Marlin uses mm for x,y and mm/min for feederates. You might get close if you set your px/inch to 72/25.4 or 2.835. your gcode has a G20 to start it, which is asking for inches, but Marlin doesn’t do inches.

I’ve never seen G40 and I’ve never seen T0. I bet Marlin is just ignoring all that. Possibly sending error messages to the serial port, for no one to listen…

that did the trick when making the Gcode set the program to mm and not inches, Thanks guys!