Grbl/M4 and Lightburn -- closed-shapes... NOT!

Since we have a number of VERY-TALENTED Grbl and/or Lightburn users here… I have a question:

I have a small 2.5 watt laser engraver, Grbl 1.1h laser-mode and M4/M5 control, Lightburn (love it… powerful and runs on Linux!), V1Pi/CNCjs, etc. I’m trying to cut/engrave small, closed, shapes (earrings, pendants, etc)… that don’t close. I’m sure M4 (dynamic power) is the culprit but don’t seem to be having much luck with M3 either… probably me not understanding the myriad settings in Lightburn.

Problem: the engraved/cut shapes not closing leaves the shape attached to the waste with a small, unwanted/unsightly “tab” that has to be cut/broken. It’s ugly, inconvenient, and unnecessary.

Any “special” Lightburn settings, workarounds, alternatives (would like to stay with Grbl) someone might point me to to get the shapes to completely cut/engrave? I’ve searched quite a bit but not yet found/recognized my answer… and thought I would ask all my buddies here. Seems this would have to be a problem that’s already been dealt with… long ago.

[attachment file=119900]

[attachment file=119899]

Starts at bottom-left and goes CW… seems to finish the cut fine, it’s the start of cut (during acceleration) that seems the issue…

[attachment file=119898]

– David

Oh is that the acceleration/laser power that we are trying to get on Marlin!?

I have never used it but my best guess is you are ramping down your power to fast on decel or maybe do not ramp it at all on a through cut? I think it is best on raster and etching.

Yeah, it is…

With Grbl 1.1f and later, there is a Laser Mode setting ($32=1) which enables use of M4 to turn on the laser and dynamically adjust the power as it accelerates/decelerates. With M3, on the other hand, you get the constant power burn we’re all familiar with. M4 avoids the darker burns on line end/corner points so is good for raster and etching, as you say. I think I’ve just not figured out yet how to set the min/max and slope of the ramp in Lightburn… which seems BTW a very polished/powerful piece of software that runs very nicely with Linux (Mac and Win, also) and is reasonably inexpensive. You get a 30-day unfettered trial period to try it out on your hardware… and I liked it enough to plunk down my $40 in pretty short order.

I’ve successfully cut these shapes with Marlin and M106/M107 control before… so I think M3 is the more appropriate command to use for what I am doing here. But, even with it, I’m getting a small “tab” left where the closed figure starts and stops… that’s what has me bumfuzzled at the moment. My workaround – so far – is to do 2 passes on the hole and profile cuts. But, while the 2nd pass cuts the tab alright, it also greatly increases the likelihood of starting a fire on this thin material. Ask me how I know… :wink:

Need to go find the small external fan I’ve packed away somewhere…

– David

What if lightburn is also altering the power when slowing down? Can you turn off laser mode in grbl?

Is there an acceleration setting in LB? You could just set that super high.

Looking at the chipboard photo above… the toolpath starts in bottom-left and goes clock-wise. So, it’s during the first part of the cut, when accelerating, that the laser power isn’t great enough to etch the material. Coming on around to the finish, it appears it was fine all the way to the start/end point. I would have expected a bit more “symmetry” to the ramps on either end…

Yeah… But it could still explain the behavior on the ramp up. I don’t know lightburn, but if it’s used to using controllers like Marlin or grbl pre-laser mode, then it might be ramping up/down the power at the start and end, but grbl should be too.

How fast is it going? It should be going pretty slow when cutting through, right? So maybe this ramp stuff isn’t even coming into play?

Yeah, it’s a slow cut with a 2.5 watt laser… 80mm/min in the wood, 800mm/min in the chipboard IIRC. So, exactly that same… but different.

I’m positive both Lightburn and Grbl are doing exactly what they are being told to do… they’ve been around long enough to have had most of these basic things worked out. So, I’m sure it’s just my unfamiliarity with them that is the problem. I just need to “keep reading”…

You really ought to take a look at Lightburn IMO… it really looks and runs nicely on my Mint box. Tons of features… kinda like Inkscape with laser CAM and Marlin/Grbl/other gcode generators, plus machine control (which I haven’t used yet). I’m simply using it to generate the gcode files… using V1Pi and Grbl. Trying to get it “user-friendly” enough that my daughter and hubby can use it :slight_smile:


I will, but I haven’t got my laser set up and I haven’t had much time to work on it.

You can increase the percentage of overscan on both the start of cut and end of cut. I had one project I was playing with that I was using almost a 10% overscan. Personally, I stopped using Lightburn. I liked the software, but I never got the results I was really looking for. I ended up playing with different plugins for Inkscape to generate my gcode to send to CNCjs.


Finally, someonr who knows what they are doing!

I appreciate this but am trying to salvage my Lightburn “investment” by getting the desired result… that it should be fully capable of. And since I’m still in the “pursuit of knowledge” stage with it… I’ll just “keep reading”. Like you, I “like” Lightburn in all other aspects (so far) and feel I should be able to get the results I’m looking for… so I’ll just keep getting more familiar with it and Grbl. At this point, I’m sure the problem is with me and my [lack of] understanding of it…

I know I can get a good result using Inkscape and the JTech plugin… but, as I said, I’m trying to make this project as “user friendly” as I can so that my daughter and her hubby can use it without shuffling files around or calling up any more programs than necessary. Lightburn and a browser fits the bill if I can just get past this one pesky little problem… burning a truly closed figure, as shown in the preview.

Dkj, did you try the overscan like David posted? That seems good to me.

Pretty sure that’s not it, so I checked again to be sure. All the defined cuts (engraving, holes, profile) in my project file are of type “Line” (vector)… not “Fill” (raster scan) or “Fill+Line” (raster scan + vector outline). The “overscan” option is only available for the “Fill” options… and that makes sense to me, remembering from my old TV raster image days… :wink:


I’ve dropped back to Grbl 0.9j (switched out the Nano on the controller), where the laser mode stuff is not available and M3/M5 is for laser control. Even that still shows the same problem… dangit…

[attachment file=120128]


Weird. Can you make a simple example, like just a square or one circle and post the gcode?

There ya’ go… the voice of reason. Back to basics… I apparently had graduated to something “beyond” that.

Here’s 2 files… both “preview” correctly in a couple of difference viewers. I must admit the headers and footers have codes in them I am unfamiliar with… and hadn’t gotten around to chasing down. But the actual burns (one on top of the other but separate runs) show the problem I think… and the darkened corners definitely demonstrate the M3’s constant power characteristic…

[attachment file=120140]

– David




circle-M3.gcode (1.95 KB)

square-M3.gcode (247 Bytes)

Alright! No clue WHY it’s necessary but accidentally hovered over a field in the Cut Settings editor called “Overcut (mm)” and the popup caught my eye… mentioned something about “closed shapes”. Turns out this specifies some amount to cut past the end on the final pass for closed shapes. Go figure…

[attachment file=“Screenshot at 2019-11-05 23-39-59.png”]

Sure enough… added 1mm to “overcut” and there they are… laying exactly where they were cut out – in a single pass PLUS OVERCUT – from the craft stick…

[attachment file=120153]

Another glass of Merlot for the win! :slight_smile:

– David



1 Like

Good Job!

I forgot about those settings. I only spent about a week with LightBurn. I may go back and take another look at it.

I’ve been trying to get better raster images. I seem to do ok with vector line art, but anything raster is coming out with dark edges and light centers. I know it’s just a matter of playing with it more, but I haven’t had the time. I’m hoping to get some more time with it this weekend. My laser is one of the cheap 60x56cm “5.5” watt engravers from banggood.

Glad it’s working

Rubber ducky debugging FTW