GRBL + MKS Gen L V2.0

I have a working Primo build with dual endstop. Everything is working perfectly with Marlin firmware on my MKS Gen L v2.0 (with TMC2209 drivers).

I’d like to give GRBL a try. I did manage to flash the firmware to my board but I only have one stepper per axis moving. Z is moving Up/down. I did try a couple of forks mentionned here and there on this forum but always the same issue.

My guess is that I don’t have the correct pins mapped out for those two steppers but I have no idea where to start looking exactly.

Any help appreciated!

So I’ve managed to get this thing working, almost.
My issue was with the wrong estep settings, X2/Y2 were energized but not moving.

I finally figured out the correct mapping for my steppers directions, I can move X/Y/Z in the right direction (both motors move at the same time for X1,X2/Y1,Y2) but I’m having issues with my Z probing…

I have my aligator and touch plate connected to the Zmin - and signal pins but when I home Z it’s like inverted, touch plate has to make contact for Z to move and start the homing process. I have tried the $6=1 (and 0), same thing.

For now I have disabled the Z homing in the firmware (so only homing XY and homing Z by hand)

2 Likes

I figured out my issue with Z probe.

Z min/max pins are used for Z endstop in GRBL firmware.
Z probe pin is A15 -> TH2 on my MKS Gen L v2.0.
I couldn’t figure out to invert the pins in the firmware so I just connected the probe there instead, everything works now!

image

3 Likes

Is it possible, that you post a short description on how you got GRBL running?
Do you use seperate drivers for each motor on your board?

Your input is highly appreciated

Hello
Can you leave your compiled grbl to test it on my mks gen L?

You didn’t get much help, but it looks like you figured it out on your own!

Yesterday I burned the mks dlc 32 and I have a mks gen l that I want to use but I can’t find any grbl that works on this board

Have you tried any of these?
Grbl-Mega
Grbl Mega 5X
There is also an alternative you can try
µCNC this one is developed and maintained by me. Uses the same protocol as Grbl.

2 Likes

Hello again None didn’t work for me
I hope the mate lets me try his modified Marlin for the laser.

Ok. Sorry for the late reply. I did a very quick test on µCNC on my MKS Gen L v1.0 with TMC2208 and at least I was getting motion on X and Y. Z was not moving but I did not had time to check if it was something that I configured wrong or any other problem. Maybe I’ll be able to check it later tonight.

EDIT: Actually Z is moving. The problem is that I was doing 1mm motions and it’s all so silent that I didn’t even noticed the motion.