Have a problem with XLoader

hi, my name is alejandro, I need to ask you same about my mpcnc, the machine is working but when I want to upload the XLoader, the program show me a bug, and I be stock for a mounth on it, could you tell me what I doing wrong?, please and thanks!

Can you show us the error it’s giving you?


Do you have the right com port? Do you have 12V power to the board as well as USB?

1 Like

Ummm…I thought there was something about the baud rate that was different between the Uno and the Mega2560, although that could be the Uno and the Nano. :confounded:I tried uploading to a 2560 pro board and none of the normal baud rates seemed to work…until I tried 250000, that failed but after when I tried 115200 it accepted the flash. Not sure why… also you should really be flashing the Mega when it is out of circuit.
AFAIK you don’t need the 12V Jeff.

Depends on the board. The rambos need power from 12V

hi I´m using the ramps 1.4, everything is conected, the port is working well and even I desconect windows defender for upload xload and the error still there.
I uninstall everything and flash the marlin several times on diferents arduinos but doesn´t work