Help I don't know what I am doing.

Hello all. I am new here and have never done anything of this nature before. I have done my best to follow all the guides provided as well as searching for similar issues in the forums. I am having several problems.
1: When I push home in repetier my MPCNC will move until it hits the edge and grind on the belt till I hit E-stop.
2: I can’t seem to figure out how to set the max travel distances on my MPCNC. I currently have no limiter switches.
3: I am having a temp error that claims I must reset with M999. I bought the ramps from Vicious and have placed the small resistor on 11.
4: Currently the only movement I able to achieve is by clicking the home button in repetier.

My questions:
1: How do I set the mins and maxs on the MPCNC without limit switches?
2: How do fix the temp error?
3: How do I get more movement such as using the buttons to move 0.1mm, 1mm, 10mm…?

Thank you in advance and merry christmas/happy new year.
Also If I am violating any sort of forum rules please inform me. This is the first time I have ever posted in forum and would like to make sure I am following the rules.

  1. You don’t the gcode dictates all moves, as long as your work fits your machine no limit switches are needed.
  2. pin T0 near the z axis port? did you get it from me? what firmware?
    3)it will work when the temp error goes away.

If you have no limit switches, you can’t use home, limit switches tell it when it’s ‘home.’ I use limit switches to square the long axis of my big machine, but I don’t recommend starting with them. You likely don’t need them yet. Just keep your projects sized under your cutting area.

To define a home, you can hit the reset button on your RAMPS set, or type G92 X0 Y0 Z0 in your terminal when the carriage is where you call home. To make Repetier read out correctly, you can also type @isathome at that time to reset Repetiers meaningless coordinates. I’ve made one of rep’s five script buttons to set home coordinates, I use it a lot.

You might have your resistor hooked up to the wrong spot, or maybe it got pulled out after your initial moves. Double check it and issue the M999 to reset. Good Luck!

I received the Ramps board from Vicious website with firmware already downloaded. The kit included the resistor.

What happens when you reset it with M999? Does it come back to life, or experience a temp error again?\

When I type M999 into G code line the error comes back right away. I have tried placing the resistor T0, T1, T2 and I still get the error.

You can re-upload the firmware with the temp sensor as 998 instead of 11.

When I put the resister on T0 it drops extruder Temp from 499 degrees C to 478 degrees C

The error can viewed in the picture below

Where do I find value 11 to change to 998

I am guessing you didn’t buy it from me. I test all my boards, for this to happen it seems like you have a thermistor pin short. You might want to check the underside of your ramps shield for anything obviously shorted on that pin.

In the firmware, under the configuration.h tab, there is a setting that says

#define TEMP_SENSOR_0 11 //MPCNC

change that to 998 and re-upload.

I could have possibly screwed it up. When I initially received the bundle I was unaware that the firm where was already on the board so i attempted to upload it. I must have messed something up then. I will re-upload it and try again. Thank you for all your help :slight_smile: .

Re uploading the firmware fixed it. I am now trying some files with a pen. I am running into a new error now
Error: Printer halted. kill() called!

Use the newest beta version of estlcam or fusion 360 with the newest post processor.

Thanks. Everything is working you guys are the best :slight_smile:

High five!!!

How do you do a tool change using ESTLCAM and Repetier? I know I can select a two different tools in ESTLCAM but can’t figure out how to restart repetier once it pauses for the tool change.