Help needed

First, let me start with this has been the funnest project I’ve done. Without me needing to post anything, this forum has answered the millions of questions I have had, so thank you to everyone for all the trouble shooting post! I’ve successfully cut numerous things now but I’m having an issue with one in particular. I use Fusion and have Guffy’s Marlin PP and was using the previous v10 PP. I’ve attached a picture of what I’m trying to cut and what is happening when I do it. I thought maybe I messed something up with the PP cause I’m pretty computer dumb, but it’s happening with both PP’s. The toolpath’s in fusion looks correct and the simulation shows it cutting correctly. I’ve also attached the G-code its generating (I have no clue how to read this but I see other people do it and it seems to sometimes help).


Thanks again guys for an amazing machine and forum!

fire.gcode (374 KB)

Not sure if it helps with diagnosis, but I just tried cutting an “o” and it is no where close to that (I attached a picture).

Looks like it’s probably skipping steps.

Are you starting this gcode with the bit just on the top of the workpiece? If so, then it looks like it’s cutting just 2.7mm and 8mm/s. That seems pretty nominal or even tame to me. Have you tried just doing an air cut, above the workpiece?

Which way is X and Y?

You said you’ve successfully cut several things. What changed?

Which controller do you have?

1 Like


I did an air cut and it looked like it was doing it correctly. I did however notice when I did it I placed light resistance on the side of the router and it would skip so guessing a belt tension issue? I just tightened it and did the air cut again and it worked through some resistance so hoping that is it. I ran out of time today and having a kid tomorrow so next chance I get I’ll give it a shot.

As far a x axis, looking at my table left and right (shortest length)

Controller is Mini rambo.

Reference cutting 2.7mm and 8mm/s, I started out with the recommendations from the milling page. Only thing I’ve had the courage to change was the depth of cut, nervous I’ll start break/snapping things. Would love to speed things up but after reading all different things on feeds and speeds, I’m still where I started, square one :stuck_out_tongue:


Thank for the help and when I get a chance I’ll see what happens and post back.


As far as what changed, I don’t think I changed anything. Had a successful large cut of 2 hrs, went back inside, loaded what I’m trying to cut now and it didn’t work.

I bet your pulleys are loose on the motor shafts. The mini rambo configures the torque in the firmware, so that’s all good.

I have checked the pulley. It looked okay but I stripped the hex head trying to tighten further so I replaced it.

Not sure what happened, or if its a continuation of my same issue, but I cannot get the router to move smoothly along the x axis (in the air, not cutting). I slowly tighten the belt each notch of the ziptie and its either too loose that its slipping, too tight that it doesnt try and move at all, or grinds like its trying to spin but is not. I can see the shaft of the stepper motor when its happening so I know its not slipping on the pulley.

Not sure if its possible but it seems like the motor is not strong enough to be moving it? I replaced the motor and it does the same thing. When I can get it to move, the slightest of pressure from my finger on the router stops it. I disconnected the belt and verified it rolls freely along the tubes so I dont think its a binding issue with the bearing.

I also visually inspected the belt, it appears fine (all teeth are still there and no cracking).

Any idea’s? Im at a loss :confused:

Something quick to check: unplug the motor connector at the board and measure the resistance of each of the two motor phases. If the values are much different from the spec sheet, then you have a wiring issue. Given the symptoms, I think wiring is a strong possibility, so it’s worth a check.

Are you using any stepper extensions? Sometimes the pins get pushed out when you plug them together.

1 Like

So I measured resistance and it was within spec. I am using a wiring extention so just to be certain I removed it and plugged the motor directly into the board and I have the same issue. I swapped x and y axis plugs on the board and I have the same issue (moving left and right still has issue regardless of what axis I designate it on the board).

My y access moves no issue and is strong enough that it can push through some hand applied resistance. My x axis, if I can even get it to move, breathing on it stops it (kind of an exaggeration, kinda not)

Is it possible there is a belt issue internal that I cannot see causing too much stretch? Not even sure if thats possible but mechanically I’m not seeing anything and electronically I feel like I ruled everything out when I ohm’d the wires, replaced motor and swapped axis connectors and the problem stayed put??

Thanks again to everyone who’s offered help!


It sounds like the only thing left is a problem with the mini rambo. I’m not sure if it uses a digipot or pwm+RC to set the voltage to the stepper driver. Depending how deep you want to get into it, you could try to find that pin and measure the voltage, and measure the output current and see if they bear the proper relationship.

If the voltage is good but the current is low, then something is wrong with the driver. If the current is low and the voltage is low, then something is wrong with the digipot/RC (or software but at this point I think that’s unlikely).

Or quicker would be to skip the diagnosis and go into the pins definition in the firmware and swap the x stepper pins with the extruder stepper pins and use E0 as your x axis.

Unfortunately I have no idea how to do that, I am completely computer illiterate, lol. I wasn’t sure if it was a computer related thing, thats why I swapped the x and y at the computer hoping to effectively eliminate that. When I did that the problem still existed at the same place. Did I eliminate the computer as the problem when I did that or could it have followed the stepper when I switched its location on the board?

Wait, you swapped the stepper motor wires on the board and the same stepper is still weak?


Wait, I missed that. Sorry. You swap X and Y connections and the same motor (now attached to Y) still has the issue? Then that would suggest it’s not the driver on the board.

But you also tried replacing the motor and it made no difference, so it’s not the motor. And you also tried plugging directly into the board, so it’s not the wiring (or at least very unlikely).

Something is not adding up. Or you have two bad motors so when you did the replacement it didn’t help. And by “bad” I mean perhaps a uni-polar motor from ebay or a “12V motor” or something that’s not appropriate for the task. What motors are you using? Are they all the same?

Ya, so even when it became y it still actes the same.

I attached a picture of the motor I bought. I couldnt find the 76oz so went with 84oz. I didnt get it from here cause Im off of work the next week and wanted to make something for work so shipping wise I was in a rush.

Sorry, I lied, here’s the pic

Okay, I’ve re-read everything and I think it’s a mechanical problem, not electrical or software. I think you were on the right track to begin with. Sorry for the diversion.

You have said that with the belt removed you can move it by hand easily, and as you tighten the belt the motor has more and more difficulty moving it. When you have the belt “reasonably” tight, and the stepper is off, can you move it by hand? How difficult is it?

With the belt reasonably tight and motor off, if you can move it easily by hand but the motor can’t move it, then I’m out of ideas. Everything on the electronics and software side seems to have been eliminated.

With the belt reasonably tight and motor off, if it’s difficult to move by hand, then it is binding somewhere. Maybe the idler rollers are too tight and not rolling (wild guess)? You’ll have to feel around to see where and why the belt is binding.

1 Like


I was defeated by a damn idler pulley!!! They were the first thing I loosend and, BAMN, it has life again!! I havent cut anything with it yet but it actually requires resistance to stop it and moves smoothly along the axis!

Now it begs the question did I need a new motor and I over tighten them putting it back together or did it somehow tighten and I didn’t realize it originally. Maybe some day I’ll try that motor again but not anytime soon!

Thank u to everyone that helped! Hopefully I can get proficient with this in the future and help others with issues. Or hopefully someone reads this posts that was having the same issue and it fixes it for them. I had numerous questions and this forum answered them so I didnt have to post.

Back to cutting!!

Awesome! Fifth time is the charm!

Sometimes it’s just throw shit at the wall and see what sticks.

[attachment file=110035]