Help setting up the drivers/motors

Hi! I need to ask, because I fried 3 drivers, and I have to be very carefull with the others 3 I have (lucky of me xD). So:

-I flashed marlin without ramps conected to arduino. Then plugged ramps, drivers and lcd. Conected the power supply and nothing happened (I cheked that it was at 12V)
-Then i realized that I needed to flash marlin with ramps connected, so unplugged everything except ramps, and reflashed. Ok till here.
-When I connected with USB (only) computer recognized it, but when I started to add the drivers(disconecting the USB between each one), a “desconnected sound loop” started on the computer. After researching, I found that maybe the drivers where fried. So I tried again with the new ones, and thats it, now I can connect arduino with ramps and the 3 drivers all together, and the computer recognizes it (hurray!!)

And now im afraid of repeating the mess. My doubts are:
1-The drivers got fried because of the falsh without ramps? or maybe because I turned on the PSU without the motors connected? (im afraid of turning on the power with the good drivers installed)
2-Also, I want to adjust the voltage of the sttepers for avoiding more injuries before anything, Can I don this with ramps connected to the computer? I think I need to turn the psu on, but there we go to point one :frowning:
3-And finaly, Im using Chinese A4988 drivers with Nema 17 motors (2,5A), if im not wrong, the correct Voltage would be 0,5V for each stteper??

Thnaks in advice, electronic part of the build is the hardest for me, and im so close to get it running :slight_smile:

PS:Sorry for my english, i do my best.

We generally use different drivers around here so I can’t help you with the correct voltage.

Make sure they are facing the right way on your board, quick image search will help.

The drivers and ramps do not need to be connected when the firmware is flashed, be they can be.

Make sure your power is only coming into the green plug on the ramps board.

To adjust the driver pots, the ramps has to be powered up, but it does not matter if the usb is connected or not.

Thanks for the answer, you were right, I was noobing so hard facing the driver to the other side cause I got confused with the assembly instuctions :frowning:
I could turn on the power supply without damaging it, and repetier-host also detects the “printer”. But im not able to move the motors from there. As I am using your marlin code, should I change something because my drivers are different from the ones that you use?

As I saw on the ramps wiki, I changed the jumpers, cause Polulu use no/yes/yes for microsteping, but still cant move them.
Is there something I am missing? I am doing this with the power supply and the USB connected. Baudrate set at 250000, like the code.

You need to cut all the steps in half in the firmware and use all three jumpers.

Infinite thanks for your support, but still the same, nothing moves, even from the LCD controller. Maybe im missing something important and my brain is swamped today.

Tomorrow will be another day, and I will recheck everything again.

Lot of thanks!! You are a genius and a very attentive man!! Tomorrow I will post what i found :slight_smile:

Make sure you have the resistor plugged in.

Resistor is ok, i corrected the first temperature error that repetier had. This is the response repetier gives to me. I think everything is ok, but maybe im missing something. I tred with 2 different motors and is the same. Also tried on different axis, and nothing again. I also post a picture of my build, but I think that everything is well connected.

19:45:58.026 : OpenGL version:4.2.0 - Build
19:45:58.028 : OpenGL extensions:GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_ARB_map_buffer_alignment GL_ARB_conservative_depth GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_SUN_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_ARB_fragment_program_shadow GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_occlusion_query2 GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_ARB_multisample GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_ARB_texture_swizzle GL_EXT_texture_swizzle GL_ARB_texture_gather GL_ARB_sync GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_ARB_transform_feedback2 GL_ARB_draw_indirect GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_ARB_framebuffer_object GL_EXT_texture_array GL_EXT_texture_integer GL_ARB_map_buffer_range GL_ARB_texture_buffer_range GL_EXT_texture_snorm GL_ARB_blend_func_extended GL_INTEL_performance_queries GL_ARB_copy_buffer GL_ARB_sampler_objects GL_NV_primitive_restart GL_ARB_seamless_cube_map GL_ARB_uniform_buffer_object GL_ARB_depth_clamp GL_ARB_vertex_array_bgra GL_ARB_shader_bit_encoding GL_ARB_draw_buffers_blend GL_ARB_geometry_shader4 GL_EXT_geometry_shader4 GL_ARB_texture_query_lod GL_ARB_explicit_attrib_location GL_ARB_draw_elements_base_vertex GL_ARB_instanced_arrays GL_ARB_base_instance GL_ARB_fragment_coord_conventions GL_EXT_gpu_program_parameters GL_ARB_texture_buffer_object_rgb32 GL_ARB_compatibility GL_ARB_texture_rgb10_a2ui GL_ARB_texture_multisample GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_timer_query GL_ARB_tessellation_shader GL_ARB_vertex_array_object GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_texture_cube_map_array GL_EXT_gpu_shader4 GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_INTEL_fragment_shader_ordering GL_ARB_shader_subroutine GL_ARB_transform_feedback3 GL_ARB_get_program_binary GL_ARB_separate_shader_objects GL_ARB_shader_precision GL_ARB_vertex_attrib_64bit GL_ARB_viewport_array GL_ARB_transform_feedback_instanced GL_ARB_compressed_texture_pixel_storage GL_ARB_shader_atomic_counters GL_ARB_shading_language_packing GL_ARB_shader_image_load_store GL_ARB_shading_language_420pack GL_ARB_texture_storage GL_EXT_texture_storage GL_ARB_compute_shader GL_ARB_multi_draw_indirect GL_ARB_program_interface_query GL_ARB_shader_storage_buffer_object GL_ARB_debug_output GL_KHR_debug GL_ARB_arrays_of_arrays GL_INTEL_map_texture GL_ARB_texture_compression_bptc GL_ARB_ES2_compatibility GL_ARB_robustness GL_EXT_texture_sRGB_decode
19:45:58.029 : OpenGL renderer:Intel(R) HD Graphics 4600
19:45:58.029 : Using fast VBOs for rendering is possible
19:46:04.377 : Printer reset detected - initalizing
19:46:04.406 : start
19:46:04.407 : echo:Marlin1.0.2
19:46:04.407 : echo: Last Updated: Aug 18 2016 11_25_1520:52:13 | Author: PID, ALLTED
19:46:04.407 : Compiled: Aug 18 2016
19:46:04.407 : echo: Free Memory: 3188 PlannerBufferBytes: 1232
19:46:04.407 : echo:Hardcoded Default Settings Loaded
19:46:04.407 : echo:Steps per unit:
19:46:04.407 : echo: M92 X100.00 Y100.00 Z2560.00 E100.00
19:46:04.407 : echo:Maximum feedrates (mm/s):
19:46:04.407 : echo: M203 X195.00 Y195.00 Z7.80 E25.00
19:46:04.407 : echo:Maximum Acceleration (mm/s2):
19:46:04.407 : echo: M201 X400 Y400 Z55 E800
19:46:04.408 : echo:Acceleration: S=acceleration, T=retract acceleration
19:46:04.408 : echo: M204 S400.00 T800.00
19:46:04.408 : echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
19:46:04.408 : echo: M205 S0.00 T0.00 B20000 X4.00 Z0.40 E5.00
19:46:04.408 : echo:Home offset (mm):
19:46:04.408 : echo: M206 X0.00 Y0.00 Z0.00
19:46:04.408 : echo:PID settings:
19:46:04.408 : echo: M301 P12.03 I0.60 D60.60
19:46:04.408 : echo:Filament settings: Disabled
19:46:04.408 : echo:Z-Probe Offset (mm):
19:46:04.410 : echo: M851 Z0.00
19:46:08.086 : echo:SD init fail
19:46:08.185 : FIRMWARE_NAME:Marlin V1; Sprinter/grbl mashup for gen6 FIRMWARE_URL:GitHub - MarlinFirmware/Marlin: Marlin is an optimized firmware for RepRap 3D printers based on the Arduino platform. | Many commercial 3D printers come with Marlin installed. Check with your vendor if you need source code for your specific machine. PROTOCOL_VERSION:1.0 MACHINE_TYPE:MPCNC EXTRUDER_COUNT:1 UUID:00000000-0000-0000-0000-000000000000
19:46:08.210 : X:0.00 Y:0.00 Z:0.00 E:0.00 Count X: 0.00 Y:0.00 Z:0.00
19:46:08.210 : echo:Active Extruder: 0
19:46:08.210 : Begin file list
19:46:08.212 : End file list
19:46:08.214 : echo:Active Extruder: 0

Printer stands on idle, after sending movements on the axis. It “makes” the moves, but anything move.
At least today finished assembling my middle parts, and looks pretty rigid and square :smiley: Im so close that I can smell the wood cutting :stuck_out_tongue:

Thanks in advance

Looks like an opengl error. I think you can turn off opengl in the settings of repetier.

Finally I solved it. Tried with a different driver, and it was the problem. Chinese drivers can give you a big headache sometimes :S

Wired the motors, finished assembling all the machine, trimed them with enough voltage, and everything seemed to work smoothly, when I made a short circuit on my board with a wire that I was moving above it :frowning: Another arduino and ramps are on the way, and now im printing the case to prevent this from happening again XD

Thank for the help, next problems will come when calibrating the machine :slight_smile: