Help with full graphic display

Hey guys, I’m new to the MPCNC, yet to build my own, I just got some electronics delivered to me today
Namely the
Bigtreetech SKR PRO V1.2
And
Full graphic display
I flashed the dual end stop firmware onto the board
But the full graphic display isnt working right
The images are attached can someone help me out please.

This looks like there is a problem with the screen timing delays.

ST7920_DELAY_2 and ST7920_DELAY_3.

I haven’t messed with them myself, but they are tuned for the marlin mode in the tft screen on the skr pro.

Here is a recent topic that may have the right values:

1 Like

Thank you, I’ll try this, can you maybe give a guide as to how I can build the firmware? In visual studio? I tried looking for the build function in my visual studio, cant find it.

Visual Studio or Visual Studio Code?

Visual studio code with platform io, we made some instructions.

Hey, I tried building the .bin, for some reason visual studio code is giving file not found errors, can someone please make a build for this setup and post it here or mail it to stefarddsouza@gmail.com.
Please.

Restart vsc and see if it asks to install any extra packages, and say yes. If you still get errors please show more of the error most importantly the first one (scroll up).

PS D:\COMPUTER\Desktop\firmware\Marlin> platformio run -e BIGTREE_SKR_PRO
Processing BIGTREE_SKR_PRO (platform: ststm32@~8.0; board: BigTree_SKR_Pro; framework: arduino)
--------------------------------------------------------------------------------------------------------------------------------------------------Verbose mode can be enabled via -v, --verbose option
FileNotFoundError: [WinError 3] The system cannot find the path specified: ‘C:\Users\USER\.platformio\packages\framework-arduinoststm32\variants\BIGTREE_SKR_PRO_1v1’:
File “C:\Users\USER.platformio\penv\Lib\site-packages\platformio\builder\main.py”, line 175:
env.SConscript(item, exports=“env”)
File “C:\Users\USER.platformio\packages\tool-scons\scons-local-4.1.0\SCons\Script\SConscript.py”, line 591:
File “C:\Users\USER.platformio\packages\tool-scons\scons-local-4.1.0\SCons\Script\SConscript.py”, line 280:
exec(compile(scriptdata, scriptname, ‘exec’), call_stack[-1].globals)
File “D:\COMPUTER\Desktop\firmware\Marlin\buildroot\share\PlatformIO\scripts\generic_create_variant.py”, line 22:
os.mkdir(variant_dir)
=========================================================== [FAILED] Took 1.40 seconds ===========================================================
Environment Status Duration


BIGTREE_SKR_PRO FAILED 00:00:01.403

is the entire error message

The screenshot you are showing has marlin builder or something involved. We don’t use that. Try following our instructions and use our files exactly. When that works, then trying to make an edit.

1 Like

Hey, thanks for being so patient with this, but I’ve tried it only with platform.io as mentioned in the link you gave me, it’s still the same result.

I managed to to fix it,
It was not compiling because of missing files
I deleted everything in
C/users/user/ .platformio/packages
And
C/users/user/ .platformio/platforms

Vs code reinstalled everything and it build the firmware
Changed the timing parameters to 400 and it all is working fine

I’ll attach the gdrive link to the firmware for SKR PRO V1.2 DUAL END STOPS here.

https://drive.google.com/file/d/1r-4Kcxg9sOl_cdzSV9WlzPWcPhgqJzhW/view?usp=drivesdk

3 Likes

Thank you for giving a detailed solution. That should come in handy if we ever see that again!

(and I am so glad you got it going!)