Help with Ramps 1.4, steppers not working

I am sure this has been covered a dozen times, but I have yet to find an answer.

I am attempting to test my controller setup before wiring it in completely. I downloaded and installed the Marlin software from this site, and it seems to be working on the Ramps. I attached one stepper motor to the z controller and nothing happened. The motor hummed and was frozen, but did not move when I tried to do so from the controller. I tried each of the other x and y controllers with the same results. I also hooked up a second motor which was known to be good, with pre-configured wiring, and the results were the same. I believe the problem has damaged two of the stepper controllers, because they no longer do anything. I am wondering if the problem might be in the software configuration? Or if I have overlooked something or assumed my test would work as I am attempting? I tried running it on both Arduino and Repetier, Arduino loads no problem… and Repetier connects and seems to think things are moving, but they do not. Sorry this is long winded, I am just looking for things to check first, because I really don’t know the inner workings of the software and may have overlooked something. Thanks

Just a guess, but check that your drivers are not plugged into the ramps board backward. Also make sure you don’t plug or unplug any drivers or steppers if USB or power is plugged into the stack.


from what I have read so far… it sounds a lot like the Mega board is junk… the Ramps board seems to self check ok… although I am not really sure…


My single biggest question, is there anything in the Marlin software that needs to be changed that could be causing this issue when I only hook up the one motor? Or is the process of only testing with one motor flawed in itself… Thanks again

I originally tested with one stepper motor on the three different drivers for X Y & Z because I only had one motor at the time, and I did not have a problem. That was with the non-dual endstop version however. If you are using the dual endstop you might have to hook up the endstops to their respective pins on the ramps board so that it sees the connection as closed before it will move the motors but I think that is only for the X & Y axis. I don’t think it would have affected the Z.

Also I would recommend you post all your hardware info per the “Best way to get help…” sticky so that everybody knows what parts you are using.

1 Like

You can also see similar symptoms if the jumpers are not installed under the drivers or the drivers are set to the wrong voltage. Dis you buy pre-configured drivers from here or are yours from somewhere else?

Sounds like it’s not getting enough current. Have you made the current adjustment yet?