Help with uploading

Can someone help me with this. I’m trying to upload to rambo 1.4. This is the message its giving me.

What have you got in your platformio.ini under default_env ?

You need to look at the first error, not the last. If you scroll that terminal window up, you should be able to find it.

Are you editing the firmware from MarlinBuilder releases?

If you are trying to use it as is, then you can use the included firmware.hex and upload it using xloader.

If you are trying to edit it, start with the source at MarlinBuilder releases and build it without changing anything first. If that builds, change one thing at a time and build when you can. That will help you narrow down where the problems are.

Did you tried to do it through VS Code plateformIO plugin (the Alien head and the mid-left ribbon) just by selecting Build the Upload submenu of your board model or have you tried to do it by yourself directly in terminal ?

You might also look at that thread, it appears that board needs a 12v external power supply for flashing: