Hitting a few snags.

Ill start with this one…

Using windows 10- While configuring aurduino after setting additional board manager URL’s, I go to tools/board/board manager but I get the error: “error downloading https://raw.githubusercontent.com/ultimachine/ArduinoAddons/master/package_ultimachine_index.json” So when I type Rambo I get nothing.

I’m connected to the internet (obviously since I’m posting this).

Other details- I finished my build. I initially used my mac, went through the aurduino setup with no issues. uploaded the latest dual endstop firmware with no issues.

From the LCD I can move my x and y axis, and the dual endstops are working, but I although I could connect with repetier host, it wasn’t talking to the board.

next I followed the directions for the Crown and saved it to an SD and loaded it up on the machine. But all my MPCNC does is draw 6 minutes of pretty circles of varying sizes- kind of neat, all the circles start at a single point like a that Spirograph thing I had as a kid. But no crown.

Next I tried to download the known good gcode of the crown, but it saves as an HTML file instead of gcode.

(At this point you are probably laughing at me for my ineptness…)

Next I tried to start over except using a windows machine instead of Mac to see if that made a difference…

Repetier host is partially talking to the board- I can send a G28 and it homes. M119 and I see the status of the endstops. BUT- I cant manually move any axis.

I decided to go back to aurduino in Windows and reflash to see if maybe the flash from the mac was the cause of my problems. And now I’m at the problem in the beginning of this post.

I bought my electronics from V1.

Thanks in advance for any ideas where to start…

 

Some MAC’s require slower baudrates. There is a link on the firmware page describing the fix.

The boards come pre flashed from me, you do not need to flash them. as for the error, the file is there and works so maybe a few screenshots would help us see any obvious errors.

The crown gcode should just be a regular click and a save window should pop up.

The problem with your post not showing up was the spam filter. It was your first post with an external link so it held it for a bit, then you reposted it a few times and that locked it into spam. I cleared it.

I went back to Mac. No issues with Aurduino. Must be an issue on my end with the windows computer.

Here is a screen shot of repetier host. Once connected, if I try to home any single axis, it homes all. (thats what I mean by its communicating some things…) If I try to enter a gcode, nothing happens.

Great. Now Im having issues uploading screenshots too.

If I go back to the original firmware I will have to rewire my steppers Im assuming since that firmware was not dual end stop?

Sorry to be a pain and thanks for sticking with me here.

I just finished rewiring the steppers in series and flashing the non-endstop software and it works amazing. Printed the same crown I made last night and it came out perfect.

Lesson learned for anyone else new to this. Rig the machine the simple way first. Don’t jump in to dual end stops until you know what you are doing. :slight_smile:

If I can figure out to post a picture Id love to show it off!

1 Like