'Home All' strangely off


Odd one with ‘Home All’ button in Repetier. First things first:

  1. Bought everything from V1
  2. Using endstops, wired as per instructions (not sure if that's NC or NO)
  3. Mac
  4. Pic attached

Working dimensions are about 450mm x 450mm, I’ve been testing out movement and dimensions and all ok.

When the spindle is 300mm from origin on either axis, it homes itself ok. When it is 400mm or 450mm away from origin, it homes itself about 100mm away from origin. Consistently.

Printer settings are set to right dimensions.

I messed with the firmware when setting up, tried loading grbl onto it, changed gcode as per Graz instructions, tried to clear EEPROM, found the whole thing was a pain and didnt work, loaded Marlin again. Hoping my stupidity isn’t the problem.



Sounds like you have a offset stored somehow. Are you running dual endstops?

No that is normal. The “home all” or G28 will only go 200mm. You can change this by matching your build size in the firmware.