How to activate dual endstops and xy steppers

Rambo 1.4 from V1 only y1 and x1 move. I assume that the dual end stop will also not work. I thought that the latest firmware was loaded by V1. I have seen no instructions except loading the latest firmware? So what is the advantage of the Rambo 1.4 over the Duet 2 and buying from V1???

The version isn’t what matters, it’s the configuration. It needs to be flashed with the dual endstop firmware, not the series firmware.

I think he writes a D or an S on the box.

You can follow the furmware flashing guide, and pick the dual endstop for the rambo configuration. That will do it.

If you just bought a board from me and no wires it comes flashed with The Series firmware unless you specified otherwise. I do specify the Dual is for advanced users as you will always need to set things in the firmware yourself.

If you want to change it I have a pretty solid step by step on the firmware page.


I don’t understand this, What instructions are you looking for there are dozens of pages of instructions and videos, What specifically do you want instructions for? There are 4 machines we support here, plus lots of other random contraptions. Mpcnc specifically, there is a main menu drop down home/Mpcnc/steps 1-6.


You have also sent me an email about this? Both boards will take work on your end if you want Dual, The rambo most everyone here can help you, the duet you are in a much smaller user base on an MPCNC.

Arduino: 1.8.9 (Windows Store (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

Build options changed, rebuilding all
sketch\src\HAL\HAL_AVR\u8g_com_HAL_AVR_sw_spi.cpp:65:20: fatal error: U8glib.h: No such file or directory

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

Arduino says U8glib.h installed

In Ryan’s instructions, he shows how to install u8glib. There is more than one of similar names, so make sure you have the right one.

Also, the Windows store version of Arduino is, well, broken (so I hear). You’re much better off either downloading it separately, or better still, using PlatformIO with VisualStudio or Atom.

I deleted the windows version and reinstalled it from Arduino. I went to manage LIbrary and add U8glib latest version 2.35 say installed and will not allow me to reinstall. Checked other settings as per instructions and selected firmware from the expanded download file. I still get the same error. U8glib.h: No such file or directory

[attachment file=“Annotation 2019-11-05 082402.jpg”]
Not sure what you installed but that is not the right thing.

Found what was wrong from an older post on Arduino Board Library files were being saved to one drive. Redirected to another location on the hard drive and was able to upload a compiled file. I searched for and installed the latest version of U8glib per your directions which was 2.35.

Used: Marlin-MPCNC_T8_16T_LCD_Dualendstop

Now the LCD is unresponsive

Can you send a screenshot, jut like the one I did. Manage libraries, installed, all the way at the bottom.

1.19.1 is the latest on my windows 10 full arduino ide install. 1.18 is also an option.

[attachment file=120085]

You have not installed it.

From the screen you are showing click on it and select install.

Lcd is still light but blank

[attachment file=120091]

Swap the wires port one to port one port two to prt two from there there are only two options.

Results in a blank screen. No back light

The thing is the screen and selector were working before the flash


The plugs only work one way.

Are you flashing the file I just linked a few posts back? Any arduino errors?

Yes, U8glib 1.19.1 by Oliver and there were no errors when uploading

Do a fresh download and install this version.