ID10T Error with Mini Rambo

a few years ago I decided to get into the cnc mill/laser hobby. I bought a MPCNC kit with the mini Rambo board. Then I found out I had to learn how to cad/cam and had a kid. so things sat for a while. I decided to pick it back up and had a true idiot error with Estlcam. Since the board came preflashed it worked great but then, for reasons no one can explain, decided to press this button:
Then I tried “restore controller” from the same page. Nope.
Since my board was non responsive, I thought “OK there are great instructions on V1 to re-flash the board”. No dice.
Repiter and Estlcam cannot talk to the board. I have verified the driver is installed and the com port is correct, including the baud rates and other settings, but I am at my wits end with it.
I am reaching out with hope that the community here can help me resolve my issue or tell me that I can replace the board with a slk mini 1.2/tft35 I have laying around or an new control board I was gifted from a 3018 pro that runs grbl. I prefer to resolve but am wiling to do what I must to get my mill operational so I can start making chips.

Thanks in advance for any and all messages.

The Mini RAMBo isn’t too difficult to manage.

You can get the pre-built software from the Marlinbuilder github repository – You want the release.

The documentation to flash it to your board is here for Platformio

1 Like

When you pressed the “Program Controller” button, Estlcam overwrote your board’s firmware with a proprietary version. Unfortunately “Restore Controller” just puts a plain vanilla version of grbl back on, not whatever was on it before. Like Dan said, you will need to reflash the V1 firmware back on your board.

1 Like

I will try to reflash it with Platformio. I did try to reflash it with Arduino 1.8.13. the package verified and it said it loaded. That is why I don’t understand why it is not connecting.

Don’t use platformio. Use the firmware.hex from MarlinBuilder releases and flash it with Xloader. So much simpler.

So I finally got the firmware loaded via Xloader with the help of another thread.
When I open Repiter, and connect, I am getting this error now:

I have no movement and I get command waiting form Repiter. Any suggestions? I have verified the com port and Xloader commed on this port. The baud rate matches.

Note that the XLoader upload and the Marlin firmware run at two different baud rates. The baud rate in Repetier-Host should be set to 250,000.

1 Like

I’ll try this tomorrow. It has always functioned at a 9600 baud rate, so that is what I set them both to.


The COM port may be different, but the XLoader settings should look like this:
So the baud rate should be 115200 for uploading the firmware. But once the firmware is updated, g-code sending programs like Repetier-Host use 250000.

1 Like

We have a winner! I set repetier to 250000 but the comm port only went up to 192000. I tested it and it worked! Thanks everyone for the great support.