I'm at my wits end trying to get my mini-Rambo 1.3a to communicate

I have checked all 3 fuses for continuity, no problem there
I have checked voltage and it is reading 12.55v at the connection, there is a green light on the board that is lit up and stays lit up when plugged in. I have tried uploading the firmware with Arduino IDE, Visual studio code, and Xloader. It freezes when uploading on marlin and xloader, and gives me this error on visual studio code –
Uploading .pio\build\rambo\firmware.hex
avrdude: stk500v2_ReceiveMessage(): timeout

I have no motors plugged into the board, only the 12v power supply and the usb cable. I have tried different computers as well as known good usb cables.

When trying the serial monitor there is an orange light that blinks on the board when pressing send, but it shows blank. I have scoured this website as well as others and have had no luck. I bought this board from here.

This means it can’t talk to the mini Rambo. The program doesn’t matter at that point. If it can’t talk to the mini, it can’t flash it.

Just to be sure, can you share a picture of the setup?

Any ideas?

It looks like you are closing in on a bad board as the problem. One thing you could check is to make absolutely sure you are getting 5V to the logic side of things. Looking at the schematic, pins 9 and 10 of P1 (Exp 1) are 5V and ground:



With the USB cable disconnected, check to make sure you are getting 5V at these pins when 12V power is applied to the board. Use care to make sure you don’t short these pins when checking.

1 Like

Also make sure that foam it is sitting on isn’t conductive.

Foam is non conductive.

@vicious1 , any ideas?

Did you get it from here?

If not occasionally they come with no bootloader, and it acts like that. If you got it here though, I have tested and flashed all of them so that can not (should not) be it.

Does windows show a valid COM port?

Yes I did get it from here a few years ago. When I plugged it into my laptop it would not show as rambo though until I downloaded the driver from here

It shows up in com3

I can only figure it must have got zapped with some static or something? I have not heard of anything like this too often. If Arduino, p io, and the x loader are not working I think it might need to get the bootloader re-flashed, I have not tried it on a Mini or full sized Rambo though. I can try to look into it and see what it takes, I have only ever sent them in to have it done.