img2gcode issues

I generated a file to do a raster engrave but it does not work and continuous errors in the console log.

error.jpg are the errors generated in the console.

anyone have any ideas what is wrong here.

I also tried piclaser trial and generated the same errors.

It will run a vector engrave no problem.

The screenshot you posted has no useful troubleshooting information. How about posting some gcode? I don’t recognize that host interface. What is it?

That interface is repetier server. Issues also happen in repetier host. I post the gcode shortly

The attached file is what I was trying to run

dragon-2.rar (1.94 MB)

Looks like you’re using a version with the experimental decimal power values option. Marlin and repetitive can only accept 8bit integers for power values so try again with decimal option off. This feature was removed later on. The linked version below should be the most stable and bug-free.

Thanks Leo I will give this version a shot tonight. I tried Version 1 and 0.5 last night.

The weird thing is PicLaser was doing the exact same thing.

Interesting… i ran the same file through version 0.4 , 1.0 and 1.1. The version 0.4 file was considerably smaller and less job time then 1.0 or 1.1 according to Repetier.

Did some googling and found this on the Repetier forums…

To quote Repetier’s Response:

"It is a communication error.

checksum mismatch => The given checksum could not be verified.
Error:No Line Number with checksum => If we send a checksum we need also a line number. So the command got split on transfer in 2 halfes as it seems. One with line number and no checksum and the othe rhalf.
Host fixes these error automatically. I expect there is a Resend somewhere near the messages."

If its a communication error why does it only occur when I am trying to run raster engraving jobs. All my other vector jobs have run smoothly.

I am running this on a Dell Optiplex 790 with Win 10, 8 Gigs of ram. They hardware should be plenty powerful enough. Also going to try switching out the USB cable and move it to the rear USB ports.

You should produce gcode without the decimal power values since they’re just wasting critical bandwidth anyway. Also, make sure baud rate is 250k. Laser raster engraving will definitely tax the system since each pixel requires a move command. I run jobs like this from Sd card myself and not familiar with repetier. If you can’t get this to work then try print from Sd if you have that option.

I do not have an SD card right now… But might have to then.

I think vicious uses repetier. Maybe he can chime in with his set up for raster engraving.

Leo are you using Arduino 2560 and Ramps 1.4 with Marlin firmware?

When talking to the PicLaser guys they suggest and UNO and grbl… Its cheap enough to by the hardware but I know nothing of grbl.

Yeah. I’ve done a few firmware mods but the original guide and videos were done with vicious’ vanilla Marlin firmware. No issues. Maybe others will chime in on their laser setups.

I think for the $20 it will cost to pick up and UNO and CNC shield I might give grbl a test. It allows the cnc milling and laser shading of a 3d relief using PicEngraver Pro. But I am still hoping to get Raster engraving working with my current mega 2560/Ramps/marlin setup

@Vicious1 help pleeeease LOL. I am really hoping this is not a 3rd bad Mega…

Leo knows more about this than me. Did you try the non decimal version?

I am going to this evening… But its sound more and more like a USB connection issue. That error show up all over the place as connection issue. Recommendations are new cable, different port, change the baud speed. Might try my old mega with the fried 5 volt regulator to see if the code runs on that one.

Nope, your file does not work in repetier or from an SD card.

Screen shot of your settings?

I do not have an SD slot… Yet. Which settings are you referring to?