Inconsistent height during cut

Attached is a photo showing how the height of my lowrider changes during a cut. The x-axis is to the left of the “G”; the y-axis is at the top of the letter.

I use Fusion 360 on a MacBook Pro to design with an add-on to generate the gcode for Marlin-based machines. Repetier Host sends the program to my lowrider Rambo 1.4 (no end stops). Z-steppers are set up in parallel.

In the past, the gcode generated by the Fusion 360 add-on contained a command to move the z-axis at the rate of 2000 mm/min. This would cause the gantry to become crooked because one z stepper would lurch upward before the other could respond. I manually reduce those commands to 200 mm/min plus I change all other z commands so they are less than 300 mm/min.

For the situation I’m presenting, I tried the following troubleshooting ideas:

I measured the distance between table top and the lowrider at various points along the x-axis, but the measurements did not vary.

I used the LCD control to run the spindle along the x-axis and the height never varied from one side to the other.

I ran the z motion up and down several times with the LCD control and the height stayed the same on both ends of the gantry.

I simulated a cut with a design built to run the spindle along the x-axis at slow speed so I could verify there were no height differences occurring anywhere along the path. The x and y movements in the gcode are set to 1800 mm/min; anything less and the end mill will melt portions of the foam (Dewalt 611 at lowest speed)

For the “G” that I picture, the only z-axis commands are at the beginning of the cut (to drop into the cut) and the end (to lift out and return home).

I need help with identifying additional troubleshooting steps I should undertake. I’m confused about the variance in cutting height when there are no z commands in the program during those variances. Could I have a loose wire or some other mechanical/electrical anomaly such as cross-talk? How would I determine such?

Thanks for your advice. For all my past problems the response time has been amazing - usually the same day…not that the pressure is on…


So if you are sure that the table is flat and parallel to the lowrider gantry, then the reason must be that the foam is not flat, at least not parallel to the gantry and table.

First, is your workpiece consistent thickness? Second, is it secure to the table?

How far is it off end to end? How deep is the deepest cut? 3mm?

Sorry, I didn’t want to bore you with too many details!

The XPS foam is 14.3 mm thick (9/16"). I have three layers of it on my table. The bottom most layer is secured to the table with double-sided tape. The second layer floats on top until the third layer is added and secured by driving drywall screws through all three layers - recessed enough to slightly dimple the surface so they will not collide with the 611 base, but not so deep they distort the foam. I added the middle layer because it seemed my lowrider was awfully close to bottoming out with only two layers of foam. The foam height is consistent with the table height across the workpiece. I also placed a straight edge across the foam to verify it didn’t deviate in thickness.

The letter “G” is approximately five inches tall. The stock foam is 4’X8’.

My initial plan was to use tabs to hold the cut pieces in place so that I could perform through cuts in one pass. That failed because the machine would drop down as far as possible (past the 14.3mm stock thickness indicated in Fusion 360) on most of the letters, obliterating any tabs in the process and releasing the letters to vibrate into the spindle and get gouged. Oddly, not all letters cut completely through. As the machine moved toward the Rambo side, the cuts became more shallow. At about two feet across the width of the foam, the cuts began onion-skinning on the bottom.

Hence, my initial troubleshooting was to determine where my stock height or table height was off or how my gantry might be getting skewed. My measurements didn’t show any variation and my checks of the machine using the LCD didn’t show any difference in height across the table or the stock.

Since those experiments proved unenlightening, I thought I could simply “trace” the letters onto the foam with a 1mm cut depth. I planned on driving straight pins into the foam using the outline for pin placement. Then, even if the machine was aggressive in its cut depth, I would be confident the letters would stay put and not get damaged from flying into the rotating end mill.

The picture is of my first experiment using this straight pin technique. Unfortunately, I can’t tell where the letter margins are at the bottom left. I was going to simply set my cut depth deeper, but thought I should ask for advice first since something is obviously amiss. Plus, I have a lot of letters to cut out - half a sheet worth - so I expect as the machine works its way across the foam, the cut heights will get shallower until the spindle no longer leaves any reference marks.

The pattern during these cuts is always the same – deeper cuts near the origin (lower left corner of the stock as I look up the y-axis); shallower cuts as the machine moves to the right across the stock (x-axis). My measurements of table/stock/gantry, however, don’t support what is happening during the cut. It’s only when cutting that these height variations occur. I even tried generating a new design with new gcode, but still get the same accursed height variation when it cuts.

It’s possible I may have something set wrong in Fusion 360 (hence the nickname Confusion 360). I continue to double check my settings and compare them to earlier projects. Unfortunately, those projects weren’t so cut-depth dependent so it’s a bit of apples-to-oranges. It’s also possible there is something mechanically incorrect. I would expect such a problem to manifest itself during my measurement tests…but I’m beginning to think I live in a different plane of reality since nothing is making any sense to me.

Oh…I also thought the vacuum might be too strong and was sucking the foam closer to the end mill. I turned the vacuum off, but left the hoses in place. Didn’t want to introduce too many variables. No change.

Please don’t fall into my abyss of despair. Keep those ideas and suggestions coming. I have faith you’ll figure it out (or I’ll find something simple I overlooked and become highly embarrassed). One way or t’other, we’ll figure it out.

Z stepper slipping? Or it could be starting out crooked.

It really doesn’t look like electronics or gcode ptoblems to me. It looks like your gantry isn’t square or the top of the foam isn’t parallel to the gantry.

  1. The first thing you had to check is that when you start the machine, both ends of Z are bottomed out, totally flat to the carriages. Then you only lift them with the motors and you keep them engaged. I reach the leadscrew underneath and turn it so they move up and then drop down before doing this to remove tension in the couplers.

Assuming that G is 125mm long and the deepest part is 1mm, that’s maybe 2mm error over 125mm. Over the whole span that would be 20mm of error. I don’t think that’s happening. You would be able to measure 20mm

I think that right at the ends. The gantry is closer to the top of the foam. It might get worse in the middle and it probably goes back to zero on the far side.

I have a torsion box top, and I did experiements to measure the flatness and it was really flat, but still it was off by 2-4mm across the table. This is foam. Which is even harder to get flat, so 10mm of inconsistency wouldn’t surprise me.

One thing to point out, it doesn’t matter if your table is actually flat, what matters is that it is parallel to the gantry.

  1. Another thing you can try is to just cut straight lines in the foam. You can measure the depth of cut in different places and get a better measurement of what it’s doing than you can with a ruler. From what you’re desceibing it should be consistent in X and a slope in Y. But I think it will help you look for where your setup is unflat.

  2. One way to do this is to run the bit over the entire surface and remove some material everywhere at the same height. That’s called “surfacing the spoil board”. It takes a while and in foam, you should be able to use a big bit but don’t leave it alone in case it wants to swan dive or hit a screw. Also, don’t do that until you’re sure about your setup. You don’t want to suface your spoil board with a 20mm slope in Y.

  3. If, for example, you’re doing through cuts and you have 3mm of error in Z across the area you’re cutting out. Then make sure your tabs are at least 6mm tall, and your clearance plane is 6mm high and you are cutting 4-5mm deeper than your material thickness.

You can split your jobs into smaller jobs. If you do just one 5" letter, you can set the Z in the middle of the letter and your error will be closer to 1mm. If you group them along X, you might be able to get several letters with 1mm error. Each time you start a new group, set the Z=0 in the area you will cut.

There’s 4 suggestions. I’m curious to see what’s going on. These types of problems are very interesting and you get an advantage being there. You’ll figure it out, or at least understand it enough to work around it.

Thanks for the replies - I’ve been doing some additional sleuthing.

Barry, my method for leveling the gantry is to place two identical 2X6 pieces under it before disconnecting the power. When the gantry falls, I can press on each end to verify the tubes are resting on the 2X6s. Once the z-steppers have been activated, I can raise the gantry and remove the wood blocks. My measurements at each end of the gantry show it is level in that respect, plus the front and rear tubes are level to each other, as well. Not the sexiest method, but it’s cheap and seems to work. If the gantry becomes crooked, such as from skipped steps, I have to replace the blocks before cutting power and verifying everything is level once more. In Fusion 360, I discovered a little check box hiding under the Linking tab labeled “Allow Rapid Retract”. That has to be unselected. Otherwise, the z raises too quickly when retracting and one of the steppers will lose steps.

Jeff - I was trying to create a series of test cuts in Fusion 360 (not an easy program for beginners, imo). This is going to sound corny…but that night I dreamed I was ranting to someone about this very problem. The individual said it sounded like signals from the y steppers were causing one of the z steppers to move. It made sense. The tests I performed previously were all done by moving the spindle along the x-axis; I never tested it in the y direction. When I returned to my CNC, I found the wires for my y-stepper and z-stepper were sharing the same tube. I separated the z wires into the second tube and re-ran my “G” test. Attached is a photo of the results.

It’s not perfect; the top of the G is cut a bit deeper than the bottom. That may be due to a slight upturn in the foam along that upper edge. But this cut is vastly improved over the previous test. It could be the connection to the z-stepper was a bit loose and was tightened when I moved the wires to their new location. Or maybe there truly was some weird interference going on. I prefer the latter explanation; it seems more mystical and esoteric than “the dufus didn’t have it hooked up right in the first place”.

I will continue to perform more test cuts before I jump into my bigger project. I’ll be back if I encounter more issues. Otherwise, no news is good news.

Again, thanks for your responses. You guys always have great insight and advice.


I hate to burst your bubble, but if there was inteference, or skipped steps, it wouldn’t look nearly that clean.

Interference is definitely not the culprit. The intensity of the Y steppers doesn’t increase with distance. Either one pair of wires has a lot of current or the other does and they switch every fraction of a mm. Additionally, the current going through the Z is so much stronger than the emi from the Y that it would be negligible. Interference from steppers comes when you have a low current signal next to a high current power system (like a stepper next to a digital circuit with a floating input).

If it was your Z wiring, you’re going to see skipped steps, and since it came back around the Z at the same height… It seems impossible to me. Unless you lost a step on one side before starting this job.

More likely, your startup sequence or checklist changed a little amd you got a better result the second time because your Z started square again.

Happy it’s working for you, but just keep an eye out for anything that would cause the two Zs to start at different heights, or lose a couple of steps during setup. Don’t get frustrated if it happens again. You can solve this.

FWIW, Ryan, myself, and a lot of people on the forums recommend using EstlCAM because it is much easier than fusion to learn. I bet you can learn it faster, even though you’ve already sunk time in fusion. You can even still do your CAD in fusion if you want.

I agree. I still just export the faces as DXF’s and do the CAM somewhere else, unless it’s a brass or aluminum piece and I really need to take advantage of the toolpath strategies, but even then, estlcam has trochoidal.

Is the foam actually flat? Sometimes you get not flat foam. You can surface off the face of the foam, then try again.

Bubble burst; tears of disappointment streaming down my face.

I’m on a MacBook Pro and, as far as I can tell, Estlcam doesn’t have a Mac version. I use Inkscape to capture images and create the svg paths that I export to Fusion for further manipulation. Got that part finally figured out after much research and experimentation…and plain old stubbornness.

Yes, foam can be warped. The 1/2" thick XPS comes with plastic film on both sides that must be removed prior to cutting (otherwise, ragged plastic edges). Once the plastic is off, it’s more pliable and exhibits it’s own character. I use drywall screws to hold it down to the spoil board which, in turn, is firmly adhered to the table with double-sided tape.

I don’t own a resurfacing bit at this time so I can’t make the foam any more flat. I think such a bit is too far ahead of me at this point. I need to get whatever is out of level detected and corrected before I move up a step.

Back out to the garage for now. I’ll report back regardless of the results.

Thanks again!!