Issue with Mini Rambo

Built the table and Lowrider2 assembly. Finished mechanical components, all that was left was wiring up the board (Mini Rambo) that came with the kit and testing it out. Once everything was connected I plugged the power adapter in and listed the menu options. I try to select anything but moving the potentiometer or clicking it only showed a V1 engineering logo, then briefly showed ‘‘Bugfix 2.0.x and’’. The things typed above are all I can do, nothing else. Now I know the board comes pre-flashed when bought through shop website. So I searched the forums on here and on Marlin, read and re-read the information that i could find. Not finding anything relating to this same problem I decided the only thing I can do is flash it using Arduino following the steps listed here.

So I do this and now I have a red LED on the board and a blue screen with with nothing to display. What do I do now ? Spent several hours on this one problem and I have no clue what else to try.


Arduino finished uploading without a problem.

Sketch uses 52498 bytes (20%) of program storage space. Maximum is 253952 bytes.
Global variables use 2478 bytes (30%) of dynamic memory, leaving 5714 bytes for local variables. Maximum is 8192 bytes.

Same results were obtained when trying to do it under option Configuration.h and Configuration_adv.h

The first issue seems like a problem with the lcd or the wiring. The little black button is a reset button and the logo will only display at reset. You push the lcd knob in to click. If you were seeing reset when you messed with the knob, then there is a wire crossed between the knob and the switch.

Now, you’ve just got the wrong firmware version installed. Try the instructions again, but use this software:

You shouldn’t need any modifications.

1 Like

If you get it back to the starting situation, we can help you debug from there.


That firmware made it back to operational. Haven’t tried to put the LCD back on. Not in a hurry to. I am liking the controls via laptop (Repitier-host) for now. I did test small steps and everything works as it should. I did have a couple steppers backwards but simply flipped those around. Super happy thank you very much.

Wanted to post quick update… I connected the LCD to the board and would just remain blue. Verified cable connections. Flashed it again with the version you linked and now it works. Even the potentiometer actually lets me go through the menu. Not sure why it wouldn’t do this right out of the box. But thanks again.