Jagged Diagonals?

So, laser is on and running. Just dialing in various laser settings and trying to get a handle on Repetier…

On one hand, things are going smooth. I did a square at 25mm, and a quick ruler test shows very square, right on the money.

However, on diagonals, I’m getting a jagged “stair steps” effect. Any ideas on things to look at, machine wise?

Anyone with ideas on checking out the laser as the culprit, I’m all ears.

What program did you use to generate your gcode?

Inkscape, and the JTECH photonics plugin.

Did you check it with a visualizer, are the lines straight or jagged? Trying to determine if it’s the g code or the machine. It can’t really be the machine unless you were using full steps on your drivers, but it could be loose pulleys.

If not zip it up and upload it here and I will take a look.

I didn’t see anything odd, but…I’m kinda new to this.

Circle is a random circle drawn in Inkscape, and used the plugin.

The roundness in this is very jagged.

Reminds me of looking at 1000x magnification on a bitmap, no real curves just individual pixels close to each other to simulate a circle when it’s zoomed out to normal size.

That circle looks fine, a bit small to really tell. It is using the arc commands.

If you are not using the ramps board I am not sure what other boards can handle them. I don’t think the uno based cnc boards handle arcs but I am not positive.

Did you get it the kit from me?

Yeah, everything here.

Not sure if it’s a missing steps issue, off square issue, or what really to check.

I did a 25x25mm square, and without high end tools, it was pretty square and of the right size. So nothing skipped there.

Can you send me some sort of small file with a circle or triangle with a diagonal that you’re 100% sure would be straight on a well-set-up machine? I’ll try and run it.

So I’ve now noticed (with some fans off that weren’t off before) that I get a distinct “tick” sound every time it moves X (positive and negative).

I can also feel that ever so slightly while placing a finger on the pulleys as it turns.

Is this a pot setting on the Ramps board? Maybe too low?

What I don’t see is this issue on the Y direction. Smooth and very quiet.

Also having some laser trouble, but this probably isn’t quite the forum for that. :stuck_out_tongue:

It could be a loose connection or driver set wrong. If one wire is loose you will get that bad stepping. If you want to check the pot, If you are using my board, my driver, my power supply, my steppers, the voltage for the x and y should read about .7V.

I had some issues with one of my MPCNC’s last night and it turned out I dropped a spool on it and it yanked the wires and made a bad connection on the far Y axis motor. reconnected it and working great. I was getting layers randomly shifting on my printers and you could hear the motor kind of grinding randomly.

Are all your bolts loose, this could also be everything over tight, putting too much drag on the steppers? It should be much more loose than most people expect. I have people trying to return printed parts because they literally crush them with the bolts.

I can try loosening some of them. Are you recommending the ones that hold the belt idler bearings on the rollers? If I am testing trying to roll just a bearing by finger, should it spin a little/at all without moving the roller?

My issue with loosening them somewhat is that they’re just naturally kinda tight. Like, I had to thread the bolts through them, so even without a nut on them…they wouldn’t come loose if it wasn’t for needing to hold on the belt idlers.

I’m concerned about one of the bolts from the inner assembly that isn’t reachable by any sort of wrench just due to small spaces after it’s assembled and one of the cross bars being kinda in the way.

Going to double check all the wiring again too. I bought the wiring kit which was a lifesaver as far as time goes. And will check pot voltage too once I get another multi tester tool.

I may undo the belting and see if I hear the same noises with no load on the motors.

Without seeing it it could be so many things.
The belt could also be too tight. 2 days ago in the forum a user was having the same issue it was because his belts were too tight.
I think I have it in the directions as don’t actually tighten any of the bolts until you run it a bit.

I was also just looking through thingiverse and the 5th set of belt tightening parts just popped up using 8mm bolts. I can promise you right now those are a bad option. But if you read the comments it is from a person that hasn’t actually used his machine yet.

So many “improved” parts are form people that have not even run there machine 1 time. Tons of builds are getting made with lots of extra parts and add ons it is getting hard to trouble shoot.

Please post a picture of your machine so I know what we are working with here.


There’s a good straight line, that’s a Z axis cut, then the diagonals coming out of it (and the circle) are where all the mess is.

I’ve done a “box” that is all straight lines down the rails, and those cut great. It’s only when trying to do a diagonal cut.

Everything is stock MPCNC, bought from here, except the laser tool and mount.

Belts come off tomorrow. Thankfully they’re pretty easy to redo thanks to the zip tie idea. Will see if they still tick and stutter without having to move.

no picture

It’s there now. Typed faster than it could upload…heh

To get a sense of scale how big is that circle?
Are you always using the same spot or is that a different area of the build? maybe you have a rough rail?

At this point I am shooting in the dark and I feel making my machine look bad. I’ll let you give all the other suggestions a try, and wait for a full machine picture.

The straight line is like 75mm so circle diameter is close. I have tried a few spots. Will try different ones with my tests tomorrow.

Not trying to make it look bad. Just trying to get it dialed in before trying some big cuts.

What kind of machine pic(s) would help?

I’d say just check out all the earlier suggestions and see if that fixes anything. Looks like your machine is really close, so it might be hard to find. Hopefully one of the drivers is just set a little low.

Today’s progress…

I took off the belts and loosened everything on the 4 outside rollers. Things slide pretty well without belts on, so I’m going to leave it like that for a bit.

I put the belts back on a little looser, and tried some jogging from Repetier, and slowly tightened up to where I think things are ok from a belt perspective.

However, I’m able to visibly watch the center assembly shudder while at slow lasing speeds (Under ~150mm/min).

I just took the whole center assembly off and did some temp wiring to see if I can get the rollers to run ok without the weight of the inner conduit and Z assembly. If things go smooth, I’m going to put just the rails on, and see how it moves from there.

I need to get a better multi test meter before I can check any of the pots values at this point, so I’m just doing basic mechanicals.

Will see how it goes.

Are you absolutely sure that all 4 four of the XY steppers are connected? When the belts were off did you make sure all four pulleys were moving in the correct direction and none were “stuttering”? This sounds like it could be a symptom of one open wire to one of the steppers. An open wire will cause one side to randomly step back and forth with the other side dragging it along in the right direction.

Short answer…no. :slight_smile:

Long answer…I think you may be right. One of my stepper plugs is kinda fubar. It looks like the underside panel fell off or something, and one of the little connectors in the plug SEEMS to be slid down a little. I was hoping the fingers on the wiring kit from here were long enough to make contact.

I think I’m going to rewire via the solderless connection on all motors to see if that changes anything.