Jerky movement on x and y axis

So I have everything moving and I did the crown print with a sharpy, but the movement is very jerky. I’m assuming I have the gantry bolts too tight, but I wanted to double check and see if there are any other common reasons for this happening. The motors are smooth as butter so they aren’t the issue. I also loosened the bolts on the perimeter to rule them out. About the only thing left is the gantry bearings being too tight.

What hardware are you using, what plastic, what surface, what kind of pen, how much pressure was on the pen tip, what speeds were you running at. I think the very last thing I would suspect is tight bolts.

Been through this just recently. If your motors are smooth, make sure you have super clean rails and bearings. Seriously clean…

Is the gantry square at rest? Remove the belts and see if it moves smooth and freely by hand.

Are you using ESTLCAM or Fusion 360?

What hardware are you using, what plastic, what surface, what kind of pen, how much pressure was on the pen tip, what speeds were you running at. I think the very last thing I would suspect is tight bolts.

Hardware is the standard kit 23.5mm. I’m not sure what you mean what plastic. The surface is mdf. The pen is just a normal black sharpy. The pen tip was just barely touching. Speeds are whatever the defaults in Estlcam spit out. I was doing the beginner tutorial.

The motors spin freely. I’ll double check the rails and bearings for cleanliness. The gantry was square last I checked, but I’ll check again. I’m using Estlcam. It’s like it gets stuck then breaks free over and over and it ends up looking like a jerking motion.

On mine, if the rails or bearings have buildup on them, you can clearly see that where the motors are mounted it’s smooth but the gantry (where the tool get’s mounted) jerks around.

This effect was more pronounced when my gantry needed to be twisted 5/8" to get it squared, putting more pressure on those dirty bearings, causing it to catch and release like you say.

Does it happen more on diagonals or moves requiring both X and Y, rather then when only going in a straight line (just X or just Y) ?

Can you take a picture? Is it jerky like these pictures?


Very interesting. I bet if you slow it way way way down, you will hear it (and see it) alternating the X and Y steppers rather than moving them both at the same time for anything that requires both an X and Y component for the move…try it.

I had this issue (I’m using Fusion 360) with the V9 and V10 post processor. Then I switched to MartinDB’s post processor which uses arcs for corners and the issue is gone.

If you can, just to compare, try the super slow speed and also try Fusion 360 with MartinDB’s post processor and compare. I’m pretty sure that’s where the issue lies…

How well do the axis move by hand (x and y) when belts are off? That almost looks like some kind of odd binding somewhere as it is not uniform. It is almost like one of the four motors is struggling causing the other motor on the same axis whether it be x or y to somewhat help it along until it catches back up. I hope that makes sense but just a thought.


Try having it draw a square (something without an arc in it). It looks like your Y axis is the issue (as your left and right lines look straight - top of letters). While your up and down looks somewhat concave/convex leading me to believe that one is struggling a bit.

Another thought is how tight are you running your belt? You may be a bit out of square to start off with and its having trouble moving at diagonals as its out of square.



Post your gcode file and one of us can try the same gcode and see if it’s the same. Meaning it’s the gcode being produced.

Thank you all for your assistance I’ve made big improvements. I loosened pretty much every bolt I could see and re-squared it. I like the idea of printing out a square so I’ll be doing that as well.

As far as arcs go, I turned them off in EstlCam following the Basic instructions. I’ll try turning them back on. My test drawing tonight looks similar to Zeenon’s minus minor leveling I need to do so I think I’m on the right track.

Post another pic showing how things have improved ok?

This is the improvement, but it’s still not good enough. I took the x axis motors off and tried running the x axis through the gantry just to test and it feels just like it does when fully assembled. When I move it through fairly quickly it feels smooth, but when I move it slowly through it’s almost like the 3/4 emt tubing isn’t smooth. It’s almost like it has little divots and every time it goes over one it gets stuck on it until it gets forced over even though it feels smooth to me. I’ll take the gantry apart this weekend and see if that reveals any clues.

Maybe your tension bolts are just to tight.

Are the belts still attached when you move it around? When you push it by hand even while not powered on you will cause the motors to act as generators and generate a little current which in turn powers the coils a little and gives a bit of a rough sensation.

How tight are your belts? I found when mine were too tight it bounced a little. Backed off a bit and now its all smooth.

I had the same issue whether the belts were attached or not. Even just slowly sliding the x or y through the gantry without being hooked up to the frame resulted in the jerky movement through the gantry.

I loosened the bolts up tonight and it’s made a night and day difference. I feel like it’s good enough to try with the router once I get the minor leveling issue resolved.

The newest print is on the bottom of the attached picture.