Kit questions

I’m building from a kit I got from vicious. I got the extruder and full graphics display. I have everything hooked up the controller is just a blue screen and the only move ment I get from the steppers are when I home them. When I try to jog the machine I get the error" printer stopped due to errors. Fix the error and use m999 to restart.(tempature is reset. Set it after restarting)"
Thanks for any help you guys can give this is my fist build and has went great so far

This error means that either the thermistor is not connected, or there is a short. If this is for a cnc, without a thermistor, then I believe you need to have a 100k resistor where the thermistor would go to fool the firmware. As for the blue screen, this may just be due to not configuring it correctly in the firmware. In the configuration file of Marlin, there is a subsection where you can select which LCD you are using. You will have to enable to correct LCD.

Also appears we have the same username. This might get confusing! I’ll change it.

Thank you !!! I seem to have misplaced the thermosistor is this something I can pick up at radio shack? For a quick replacement. I do have the extruder from here but havnt hooked it up yet because I believe I forgot to order the stepper driver(newb)

If you bought the extruder kit from here, then the thermistor would be included. I highly doubt they would have this at radio shack honestly. The extruder assembly will have two sets of wires, one for the heater and the other is the thermistor. You will probably have to source a replacement online. I do not have this extruder and I can’t say for sure which one you would need. Maybe somebody else will comment on an exact replacement for this extruder.

I actually ment to say resistor sorry I’m new at this I keep getting all kinds of compiling errors? “Expected primary-expression before ‘.’ Token”

Its a 100kohm resistor, very common if you have a radio shack or a fry’s around.

Or in the firmware you can change the themistor value to 0 and not need the resistor. What ever is easier for you.

Firmware change to 0 takes 15 seconds to do and doesnt require any hardware, jumpers, thermistors etc. just do that. Super easy .

And were could I find that setting? I have gone through config h. File can’t find anything like that … Thank you all for your help I really do appreciate it!!

Config.h, on mine it is line 122
#define TEMP_SENSOR_0 11

to #define TEMP_SENSOR_0 0

I done exactly that and I got “#error TEMP_SENSOR_0 is required”

In arduino or repetier?

Arduino worked fine for me, I even tried different things to make it error out and the only way I got an error was with nothing there.

Yes in arduino…not sure what I have done I used to be able to hit home on either x or y axis and it would move now when I try to connect to repetier it says "no signal detected - forcing start " I have googled and tried everything really and keep getting the same error log… I have ZERO complaints on the kit it’s self, this is all operator error but I’m eager to learn! Can’t seem to get the screen to connect either it’s just blue but not so much worried about that at the moment

Alright well, I guess try flashing the other firmware, the screen will not work with this one but see if the 0 for thermistor works. We’ll come back to the screen after we verify the rest.

Yes that fixed it!!! Thank you for taking the time to help me out on that part!!!

Cool, glad to hear it.

So for the controller do I just need to take the // out from in front ?

On the marlin page i have it preconfigured. If you are using the full graphic (big screen), use the “fullg” one,

Still not having any luck… I’m really not sure why it won’t work but it’s just a constant blue screen

switch the ribbon cable plugs on the lcd end. I bet they are backwards.