Large MPCNC - Germany, Mainz


So I finally managed to put everything together and start the first test-plots.

As I have to work with Alu-Dibond panels as well as some hard-foam panels for sign-making, the MPCNC turned out to be an affordable cutting machine for those plates. Of course, other things are also planned :)
We work with DIN formats with DIN A0 being 1189 x 840 mm, so a working area with 1250 x 1000x100 was planned. Huge machine.
I printed all parts on the tiny DICE 3D Printer. They turned out awesome and accurate. But sadly, the whole middle part didn't fit on there. Had to print it on my Delta printer. That had issues with accuracy... +/- 0.2mm especially in the outer part.
This results in some really weird behaving on the middle part. Can't really get it perpendicular. Even the dual-endstop firmware couldn't solve this. It homes fine, but the issue is so big that one side just stutters back in a less "tensioned" position. This is just the case for the Y-Axis. The X-Axis works fine as it seems. This makes me believe it is not such a huge Part-issue with the middle-assembly but more some perpendicularity issues with the whole frame.
Another issue is that I measured everything before screwing the feet down. My stainless-steel rails are cut +/- 1mm, but on the front-right side, the Y-Rail stands out more than 4mm (can be seen on the photo, left side is just 1mm). I am not sure what happened here. Guess I'll have to unscrew the feet here and pull them about 1cm more towards the edge. I don't want to put so many holes in that wooden board, so I definitely want to be safe. Some other YT guy said: "Measure the diagonal from one feet to the other" - as far as I remember, Ryans assembly manual just says: "Measure dimensions, be as accurate as possible" and the picture shows a linear measurement from one end to the other.
Another, definitely a part, issue - the coupling on the Z-Motor is already bended in standard-position. Seems like the issue here has to do with the parts... :(
And last: As I wanted to install mid-span supports, I designed my own little add-ons for the feet. I was wondering about the following: Moving this foot (seen on the picture, middle part) towards the edge, I got real tension on it. Going to the middle, there was a gap between the support and the rail. Further to the other side - again tension on the whole thing. This made me wondering: are my stainless steel rods "bend"? As soon as the machine travels to the middle, the rail is almost touching the support. Moving along to the edge, the rail rises again.
But back to the results:
Drawing a rectangle with the display (Z = 0, moving X/Y with the display, 50mm and 300mm) resulted in the perpendicularity issue as well as the outcome that the axis are pretty precise. 50x50 measured with a ruler seemed fine, the 300x300 was 300x299.x - pretty good for no calibration so far.
I then loaded up the crown file. Damn. That thing surely shows issues.
First - Circles are no circles. They're everything, but no circle.
Second - the whole machine is vibrating, which of course can be seen on the crown. I'm eager to see how to fix that.
Third - It seems to have issues on the circular parts on the outer side. They often are not as round as they should be. Also - Start-End points don't connect to one another. Especially the starting point is not accurately placed - it could also be an issue with the rolling ball pen.
[attachment file=96351] [attachment file=96353]
Youtube Video
So... Hope that you might have some solutions for me. I'm really happy so far with the outcome of the machine. The measure-tape trick with cable sleeves is GOLD. Doubling the measure tapes really puts on some stiffness in this size.
Thanks in advance guys :)

It looks awesome what color is that

Did you check all the voltage because my steppers did the same thing till I adjusted them

Hi Jason,

the color is "Burned Copper" from German Seller "DasFilament" - really like that color and it prints fantastic.
The Voltage on Z was checked because of the bent coupling. Didn't check the other axis. But this kind of tension will definitely have a negative impact on the precision of the machine. Because of that I want to get rid of the cause and don't want to treat the symptoms. :)

The first thing you need to solve is the frame being square. Make sure both sides of each axis are as close in length as you can get them, then you check diagonals. The feet have room to move the screws have slots. Make sure each corner is at the same height.

As for the center make sure none of your bolt heads are interfering in the very center, some hardware can hit the bearings. If that is not the case take it apart and put it back together flip a few parts and very carefully step through the instructions. If it will not go square either your rails are the wrong sizer or your prints are too far off. I suggest a 100x100x100 calibration print.

Hi Ryan, thanks for your answer :slight_smile:

I disassembled the whole machine two days ago. Remembered my mistake: I placed the middle assembly already on the machine before screwing the feet down. This already made a mess in the square.
This time everything worked out fine. First test plots are square. I also reprinted the Z_Lower_Burly and the Z_Motor_Burly parts after measuring them and scaling the file up. The Coupling is straight now, the lead-screw fits nicely into the middle assembly. Problem - solved.
First crown test plot worked okay, but the circle still had issues. I then made a new test file with 10 circles in 10 rectangles.
Placement of the tangents is pretty accurate. Rectancle lines are nice, measurement was not that far off and the angles are 90° :)
So going for the circles now. Guess what - its a circle now. So why didnt the crown one work? After watching a few plots I realised, the axis stutter while moving both. So every quarter movement, there is a slight vibration in the movement, resulting in lines that are not clean.
. Belts are not too tight (Short side has tension, long side swings like it should without giving a tone / note when touched) - carriages are not tightened. Those where the bearings did not touch the rail, those were tightened until they did. But its just a half turn over the initial touch of the nut/part.
So I was wondering: How can I get rid of this "circle" problem? Can't be an issue with the Arduino. I know from 3D Printing and Delta-kinematics that those start to stutter on high speeds with 8bit firmware.
I started to feel some vibrations on the moving rails (where the middle-assembly is placed). But I don't know why its doing that :/
The Dual Firmware version is gold. I love it. As soon as everything worked, I glued the endstops to their holders. Homing is flawless and accurate - every time. :)
Thanks in advance for any ideas regarding that circle-problem.
See video here ( sorry for bad focus in the beginning)
Click Me
[attachment file=96680] [attachment file=96681]

Not sure about the issue you are having but the “circle” in the crown is not a circle.

You have calibrated it enough, get it dirty make some stuff, see if it even matters to what you are doing.

Thanks Ryan. My brain saved that “circle” in the crown as a circle and not an oval. Now it makes sense. Just hope those curved won’t affect my milling products :confused:

Next week I should be able to start my first test. Sacrifice Plate is on its way.

But I have another issue to look in to. Maybe someone here can help me.

I have a 4channel relay module from MakerFactory. Compatible with Arduino. Works with +5-+12V and has following pins:
VCC, GND, IN1, IN2, IN3, IN4, COM, GND. There is a Jumper from COM to GND. Sadly I can't link to the board as the forum does reject my link.


So... I connected the board to +12V on VCC and GND. Then hooked IN1 to D9+. Result: Relay is instantly ON on Bootup. Turning FAN to 255, Relay is ON.
Shutdown, switching IN1 to D9- (Remembered one of my printers controls PWM with D10- on SSR) - Bootup, Relay is ON. Turning FAN to 255, Relay is OFF.
I'm wondering if the COM Port has something to do with it. On the other hand, I measured D9 while being at 0 and 255. 0 has 7.71V on it, 255 has 12.2V on it. As the board works with 5-12V, no wonder why the relay is ON on Bootup.
The relay board controls two sockets on IN1 and IN2, one for Vac and one for spindle. Just turning on. Regulation will be done by hand.

Maybe someone has any idea how to solve this or if I have to switch to Servo ports for my intention.

Thanks in advance! :slight_smile:

As I had a little time, I made some tests with the Servo Pins… activating them in configuration.h being the first step.

I then hooked up IN1 and IN2 to the first two SIG-Pins from the Servos.

Issuing M280 P0 S255 resulted in the Relay always turning ON/OFF in µs steps. Same for P1. M280 P0 S0 resulted in a relay-shutdown. I then read about M42 command to use a Digital HIGH/LOW Signal on Servo Ports. Well, of course my Repetier-Host says: “Error:Protected Pin”

Googling for about an hour I found many different solutions, from “sensitive_pins.h” to all other stuff. But… there are no servos in sensitive_pins.h. Even tried deleting the extra-fan section there (which is normally used for Fan Extenders on printers) without any effect.

So… I’m wondering - How can I control that relay? I just need a digital Pin spitting HIGH/LOW Signals. Best two of them.

Appreciate any ideas and thanks in advance :slight_smile:



After about 30 tabs in my browser reading through everything I found… I just hit a simple test of desperation.

M42 P11 S255 => Resulting in Pin 11 (which is the Servo Pin) being constantly HIGH. Without any stuttering. Same goes for P6. Now I’m happy. :smiley:

So… I got it dirty.

Tried milling some hard wood first. First try, the mill got out of the router somehow. Emergency Stop and tightened it again. Luckily nothing broke.

After that, I started the program again. Everything worked out really good! :slight_smile:

Sadly, I seem to have a hand for frying 5v regulators on Arduinos. After 15 minutes in the program (out of 20), the mill stopped. Everything shut down on its own. Display went dim (while backlight being still on). Connection lost said the PC.

Seems like the Relay board I got drew too much current, resulting in frying the 5V Regulator. I will put some mosfets together with low current requirement and hook them up… Very sad :frowning:


I’m three tests in - First test stopped as stated. But - This also fried my Y-Axis stepper driver. Dunno if the 5V Regulator got damaged because of that. The driver chip has a nice little bubble on the edge where it fried.

Second test was aborted on its own after about 10 minutes - this time the machine restarted on its own. Okay, send the data again via Repetierhost. But whats that? Z-Axis is not moving. Ah… again, fried driver. Nice.

Exchanged that and voila… it finished its turns and I got what I want.

The repeatability in itself is <1mm off. The edges are kinda clean. Will upload pictures later on. :slight_smile:

1 Like