Laser Engraver Driver Current Unadjustable

@leo69 or others. I have followed the instructions in Leo’s amazing tutorial, Everything works except for the last step where I need to increase the current to 1.7amps. Despite numerous turns on the current adjuster screw, the amps will not exceed 1.1amps. When trying to engrave the laser moves and flashes as expected, but does not actually burn/engrave. I am assuming it is because there is not enough amperage. Note, make sure NOT to buy the driver on Amazon from Sococo, as there others that have complained about the same problem…

[attachment file=35870]

[attachment file=35871]

Does anyone know of a way to adjust this current besides turning the screw? Or do I need to buy another one? If anyone has recommended sellers for the proper driver please let me know. I have purchased 2 and both have been defective for different reasons.

Thank you.

I’m not clear on what your asking. You have a bad power supply? The laser does come on though? Is the ttl pin running at 255? How fast are you moving it? You don’t have a fan connected to that port do you, it is labeled wrong, if you do that is probably the issues, running a fan off that backwards will smoke your fan and power supply.

For mine it doesn’t burn when set at the lowest setting that it comes on, but it quickly burns at much past idle.

Hi Ryan,

Following, steps 29-31 state to increase the current, using the screw head on top of the current adjuster (blue box in pic above). However, my driver’s voltage does not move from 1.1. The picture on the instructions states 1.7 volts. I’m assuming this is why my laser is firing and moving normally, but i am not actually getting burns on the test piece of wood.

I have verified that all other voltages are to instructions specifications, configured marlin to run pin 44 instead of pin 9, etc. Again, the laser is firing, it simply isn’t actually burning anything. The fan values do range from 0-255 when watching the print on repetier.

My question is do I need to buy another laser module driver, since the current doesn’t seem to adjust, or is there a way to adjust the current besides the screw head? If the answer is ‘No, you need another driver’, I’d appreciate it if people provide a seller name or something that I could seek, since I’ve purchased 2 of these, and both times they’ve been defective.

To answer your questions:

Power supply works fine
I have tried numerous settings, including speed ranges between 500-1000mm /min. They do not seem to make a difference. I have also used MAX settings, again, no burns result.

However, if I manually set the laser to 255 and let it sit, it will burn a mark into the wood after about 3-5 seconds of holding at the 255 level. Additional tests suggest that anything below 180 and a second or 2 of being stationary doesn’t seem to really burn. Hope this helps clarify.



I bought my driver before that pdf was out, I can’t help with a vendor.

I actually don’t know much about those drivers, that is why I don’t sell them.

Do you have a fan plugged into the fan port, you should not?
Does turning the screw do anything, or is it always at 1.1?
What diode did you buy, what are its ratings?

No fan in the ‘proper’ fan port. The only one is directly wired into the power supply per instructions. The current only changes about .05 V, but the max I’ve been able to get it is 1.1V, despite many repeated screw turns.

Diode purchased:

NDB7875 445nm 9mm Diode In 12mm Copper Module W/Leads
Lens Options: Three Element Glass Lens add

Driver Purchased:12V TTL 1W/1.6W/2W/445nm/450nm Laser Diode

I also have purchased from Ebay, but was sent the wrong driver than was displayed, which is why I’m trying to find a reputable seller.

Any guidance would be appreciated.

Thank you for your assistance,


Those drivers require a test load if I am not mistaken, did you set it that way?

Honestly I’m not sure what to say, I only set mine up one and never had to touch it since. There are a few other threads with some driver issues, but they all just seem to be the reverse polarity issue, If you tried that I am out of ideas.

Hopefully someone that has some more experience jumps in here.

Hi Ryan,

Thanks for the help…Yeah, I’ve tested the in the way you describe with a test load. Again, the laser doesn’t appear to be fried. It fires as I would expect, I simply cannot get it to actually engrave anything, except for a large hole when I manually set it to 255 and let it sit for about 3-5 seconds. I am only guessing that this is related to the driver not being able to be set to the required 1.7V. I have only been able to adjust mine up to 1.1. It will not increase beyond that using the current screw head adjuster.

I welcome others’ thoughts as well.



Well if it is working a bit, just slow down your gcode and make sure the power is as high as it will go. Slow will give nicer results, it will just take longer. Make sure it is properly focused as well. 3-5 seconds doesn’t actually sound too bad, this laser is not really for cutting wood, it will with several passes but it is more of an etching/engraver. 60-80 watt laser are built for cutting.

Sure, I’m not trying to cut with it, but I don’t get any burn marks when trying to run at 500mm/min and haivng a min of 180-255 when generating Gcode.

Dumb question, how does one focus the laser? I may not have done that, which may be the cause of this. Do you have a resource that you might link to about calibrating that?


You only have about a ±5mm window of focus. It is extremely important.

You set it on the lowest power you can that makes it turn on, set it at about 50-60mm from the surface, and adjust the lens by hand to get the smallest point you possibly can. Then you can automate the rest shown here,

1 Like


Thank you for the information. I was able to focus the laser properly using your instructions and script.

Despite the driver not getting enough power, it appears to be working properly. It looks like it was a focus issue, not a lack power iaaje.

Thank you for the assistance.

Awesome, you’re welcome.