Laser engraving - not really getting great results

It was so obvious I don’t know how I didn’t see it. It’s not like the loose one on the MP3DP that was spotted by Dui by some miracle. And so now I’m back to the discussion from a week or two ago - how tight should I have the belts. I remember a “sound” discussion but mine are not that tight. Should I snug them up? I can see how a fraction of a millimeter could make a world of difference in the case of the laser engravings.

I’m reprinting the flipped Garfield to compare and there’s improvement for sure. But a long long way to go.

I’m thrilled you’re on to something here, with the loose pulleys, etc. Regarding the belts, they really don’t have to be too tight… I go by the cable tie loops holding the ends of the belt. If they exhibit any “springiness”, allowing to belt to move along its length when gently tugged… they are too loose. Tighten them until there is no perceptible springiness in the cable tie loop when tugged… and you should be good to go.


1 Like

I’m thrilled you’re all helping out. I’ve got big plans for this thing but it’ll only work if I can dial it in.

Heres the flex on my zip ties. Should I snug them down? I see a bit of snugging needed on the front x axis zip tie. Perhaps they all need a notch or three on the zip tie?

Kelly, I believe your corner pieces are on backwards… though I’m not sure what the effect might be. The tie points for the cable ties should look like this

[attachment file=87472]


[attachment file=87473]

Ryan makes a point of this ( in the assembly instructions… so, Ryan, if you’re watching this thread at the moment, what are your thoughts?

As far as the belt tension, it looks like they could be snugged up another notch or two IMO…

– David



Agh! My secret is out! Hahaha. I forgot about that. I HAD them the right way, then second guessed myself and swapped them and by the time I realized I was right in the first place I deduced it wouldn’t matter. Could it be enough to be the culprit you think?

hahaha. Too funny. I’d completely forgotten about that.

Feeling a bit more energetic than normal, I decided to drag my scope out and verify just what’s going on pin 44 of my RAMPS board. With so many laser threads going, I really didn’t know where to put this… so here’s as good a place as any, I suppose.

[attachment file=87481]


Pin 44 is the D9 fan output, remapped and controlled with M106 Sxxx gcode commands. Pin 44 outputs a signal between 0v and +5v, whereas the D9 fan port outputs the same signal, ranging from 0v to +12v.

So, here the isolated green wire is pin 44 and the blue is GND. I’ve put the scope probe on the green wire…

[attachment file=87480]

Using RepetierHost…

M106 S127 is half-power and, as expected, pin 44 shows 50% duty cycle, and Vavg = ~ 2.5v

[attachment file=87482]

M106 S64 is quarter-power, 25% duty cycle, and Vavg = ~ 1.25v

[attachment file=87483]

M106 S0 turns the laser off, 0% duty cycle, and Vavg = ~ 0v

[attachment file=87484]

M106 S192 is three-quarters power, 75% duty cycle, and Vavg = ~ 3.75v

[attachment file=87485]

and, finally, M106 S255 is full-power, 100% duty cycle, and Vavg = ~ 5v

[attachment file=87486]

Given this variable duty cycle signal, the laser TTL input “sees” the Vavg level, ranging from 0v to +5v, and adjusts the laser power accordingly. The D9 fan output, unmapped, puts out the same variable duty cycle signal… but it ranges from 0v to +12v.

Hope this helps somebody, somewhere.

– David




…and then I see things that make me think I’m so under qualified to have toys like these in my shop…

Okay. I was sealing some carvings so I tightened the belts and let it run again while I was painting. I now have a repeatable result on both axis. The X Y flipped was y-axis heavy and printed after I tightened up the pulleys. The “David’s File” one was printed normal (x-axis dependent) after snugging down the belts.

Still not great but at least it’s the same on both axis now so one part of this mystery has been solved. [attachment file=87496]
[attachment file=87497]

Still find it funny how the X / Y find & replace flipped the artwork…one day when I understand gcode better I’ll go back and educate myself on ‘why’ it did that.

Are you sure your laser is supposed to have a 12 volt signal?

I can’t say I know. I was going on the “plug and play” rumour that’s out there with the JTech kits and the miniRambo’s fan port?

I’m thinking no? And I’m assuming by you checking that the fan port is spitting out 12v?[attachment file=“Screen Shot 2019-02-04 at 10.41.17 PM.png”]

Driver specs…am I reading wrong - it sounds like it’s good with signal voltages from 2.8 to 36 volts?

[attachment file=“Screen Shot 2019-02-04 at 10.43.06 PM.png”]

Kelly, I apologize. I’ve confused your setup with someone else’s here, I guess. I thought you had a RAMPS board and Banggood laser similar to mine. My previous post with the scope photos and RAMPS pin remapping were not intended to confuse you, or anyone else.

It is my understanding that the JTech laser’s control input works fine with the +12 volt D9 fan control output directly. So you can ignore all the pin remapping information above. But the M106/M107 control commands work the same, remapped or not, so controlling the laser’s power with the duty cycle and voltage averaging info should still be good… only ranging between 0v and +12v, instead of 0v and +5v.

My bad… :frowning:

– David

Nope. No apologies required. I’m grateful for the aid. I reached out to JTech last night and will see if they come back with any pearls of wisdom particular to the laser and board. That is assuming I have the machine specific issues sorted. Which I’m sure I do now? There’s just not so many things that the machine could be responsible for. It must be something between the software and the laser. And your gcode files should take the software out of the equation.

They have an account here and have been very helpful in the past. If you have not already you might want to link this thread in your future communications.

I really have no idea how this is happening. Can you add a common ground between your power supplies or control signals? It really is starting to look like you have a dirty signal to me. You are using a proven machine, and a proven file. So either the lens is super loose and wobbling around or you have a signal that is messed up somehow. It is starting early and ending late randomly.

1 Like

I did indeed include a link to this thread. I thought I’d seen them on here in the past answering questions but couldn’t recall exactly. I definitely had heard through this forum the their customer service was great so I’m feeling confident. With all of you supporting me and the knowledge that they will too I know I’ll figure this out. And at the end of the day it’s likely some oddball thing like the fluorescent light tubes being too close to the controller or the laser just scared I’m gonna toss a chunk of ice under it so it doesn’t want to play nice ; )

(Ryan, I’ll delete this and start a new thread if you think I should.)

I ran my own gcode for a focusing script, separating the lines by 2mm rather than 1mm so I could see them. I really couldn’t tell much difference between most of them.

[attachment file=“IMG_05022019_212502_(1080_x_2222_pixel).jpg”]
[attachment file=“IMG_05022019_212523_(1080_x_2222_pixel).jpg”]

But I lowered it down to the “52” line and then ran David’s two gcode files for the shades of gray and Garfield. My results were kind of similar to Kelly D’s.

[attachment file=“IMG_05022019_212540_(1080_x_2222_pixel).jpg”]
[attachment file=“IMG_05022019_212636_(1080_x_525_pixel).jpg”]
[attachment file=“IMG_05022019_212656_(1080_x_525_pixel).jpg”]

This was all on MDF. Using the Banggood 3.5w laser, 2hich I think is the same one David uses.


Arrgh! Based on what you guys are getting… maybe my machine is the one that is broken!


Does your machine (or the workpiece?) vibrate/shake excessively while you are engraving Garfield?

Is your machine/workpiece fastened securely down to the table top and not “walking” around while engraving?

Can you reduce the laser power to, say half-power, and slow way down and engrave again?

Pictures of your machines might help. Here’s mine for reference… smaller form-factor MPCNC (24" x 24" footprint), relatively heavy laminated 1"x4" base, feet solidly fastened, and even the workpiece is weighted down with a couple of little BB bean-bags

[attachment file=87633]

Otherwise, I’m stumped. – David

1 Like

I did not notice any shaking, vibrating, or moving of the machine during the operation. The machine is very secure to the table and very solid. I haven’t had any problems when using the spindle or a pen. The table is built from 2x4 lumber and 3/4" plywood and is very solid, but it is on casters. The MDF was not fastened down, but I did not visually notice it moving at all. I recorded some video while it was lazing but I’ll have to upload them tomorrow when I have access to better internet. My home internet is dreadful.

[attachment file=“IMG_05022019_225259_(1080_x_2222_pixel).jpg”]
[attachment file=“IMG_05022019_225316_(1080_x_2222_pixel).jpg”]
[attachment file=“IMG_05022019_225349_(1080_x_2222_pixel).jpg”]
[attachment file=“IMG_05022019_225406_(1080_x_2222_pixel).jpg”]

Heath…I’ve felt so alone for so, so long…hahahah Are you running the miniRambo as well or have you got a different setup?

My build is pretty solid other than that pulley thing we found. The table surface is stud-mounted 3/4" ply with a 3/4" ply build surface. I can’t remember the dimensions off the top of my head - it may be in the build thread here: The Carver’s Frickin’ Laser Build

I haven’t been securing anything other than weighing it down but I’m pretty certain it’s not moving about. I’ll cut the power and speed and see what happens. I think I’ll also revisit the crown file but speed it up to see if it starts to fall apart or not. That’ll be project for tomorrow. I’ve got fresh sealer curing in there right now and it made some funny smells yesterday when I was running the laser while sealing. The VOCs get everywhere - even into the laser beam I think. Reminds me why I wear the respirator…

No word back from JTech yet either but I’m not sure, they may be embroiled in the New Year festivities if they are based out of China. Not sure where they are based out of actually.

(Pictures added to my previous post.)

David, if your machine is broke, I want to break mine the same way!

Kelly D, I’m using a MKS Gen L board (it’s a Ramps 1.4 and Arduino Mega on a single board) with DVR8825 stepper drivers at 1/32 microstepping. I’m using dual endstop firmware and Ryan’s default acceleration, jerk, etc. We’re running different boards and different lasers.

Maybe tomorrow night I can try some things like use cereal box cardboard to make it a more accurate comparison David, play with speed and power and so forth.