Laser engraving - not really getting great results

I have a question David. When you used Vistor’s ImageToGcode for the Shades of grey was the Travel and Work speeds the same? I have a note from victor to test that. He said it should effectively get rid of the acceleration since it wouldn’t have to accelerate from work speed to travel speed and back again. But in this case it looks like it would still be a problem. Since I think the program will work on one box for a few layers then jump to the next box etc…

It is kinda cool how the laser seems to have bleached those really light boxes like David pointed out.

I did indeed set them to the same 50 mm/s setting. I did notice – when the Garfield image was first started – the first few raster lines at the bottom of the image are “blank” (all at the same intensity) and the scanning motion was very smooth… IIRC the laser was firing dimly. As soon as the laser started firing in earnest, however, there is a distinct, abrupt start and stop action taking place… you can see that in the video where Garfield is being engraved.

It is my very limited understanding that Grbl’s “laser mode” does indeed vary the laser power with the current feed rate. That might be a fun thing to play with… for some of you younger, more adventurous, guys. Right now, I need a nap… :wink:

1 Like

I concur. The second video running David’s file clearly shows this.

Running my file:

Running David’s file:

End result? Nothing like what David got. But a close match to what I got.

[attachment file=87418]

I unscrewed the lens and learned a whole lot about refocusing laser lenses in a hurry. This spring popped out and I thought I was done for. Put it all back in and turned things on only to see a giant football shaped light on my work surface! Egad! I got it all sorted out though. However, yes, the threaded insert does “wiggle” a bit but I don’t think it’s loose enough that the gantry moves would shake it? Maybe it does just enough to mea all this up…I’ll try a bit of thread tape in there now that I’m so good at manually focusing the damn thing (or maybe just a drop of hot glue)…the lens itself seems to be solidly attached to the inside end of that threaded tube. That collar on the threaded tube has a flange on it preventing the collar from threading all the way onto the tube (which would then lock it to the heatsink body and hold the tube steady).

Running David’s “Square” gcode file now and on the same boxboard as he used this time (the above was corrugated). It’s looking clear to me that there’s an issue with my machine.

Dumb question…could I flip the gcode to try running things on the y-axis instead of the X? Would Find & replace be safe to use? (Replace all X’s with U’s, then all Y’s with X and all U’s with Y?)

Here’s the grid test from David’s file:[attachment file=87425]

I feel like if I can get the “scribbly” bit tackled I’ll have it.

The Find and replace for X and Y should work. That would be really interesting to see. It would give us a clue to know if the problem it hardware or something with the TTL.

To me the scribbles look like the laser is having a hard time knowing when it should turn on and off. As if the Control board sends a signal for full power so the laser kicks on at full almost instantly. (good so far) Then the control board sends the off signal and the laser takes a few milliseconds before it turns off. I could be wrong I am new to this. But that is what it looks like to me.

If I am right then I would guess the control board and the Laser driver (TTL) are not communicating well. I wouldn’t know where to begin to debug that.

The control board to miniRambo connection should be pretty trustworthy as far as my soldering/connector building skills go. I did have to extend the leads from the laser to the control board but used over gauge wires for the extensions so that shouldn’t be an issue?

Interestingly though there’s no real scribble issues when I run the crown file…there’s also no rapid on/off/modulation.

I’ll try the flip and see if it pinpoints anything.

It looks like laser saturates too fast. Like it connected to 12v pwm and it 12v resistant, but after 5v average pwm level it saturates to 100% output power and in range 5-12v fires at full power.

In the Marlin firmware, if you turn on (uncomment) “SPINDLE_LASER_ENABLE” in Configuration_adv.h, there are setting options for POWERUP_DELAY and POWERDOWN_DELAY. But, you said you were using M106 and not M03, so I don’t know if that even comes into play here.


Here are those exact same two files engraved onto 3mm birch plywood…

[attachment file=87448]

[attachment file=87449]

[attachment file=87450]

The shades_of_gray image is a bit light on the light colored wood… should darken if I slow the feed rate. May try that later. Garfield doesn’t look too bad.

Definitely seems to be something with your machine… maybe just X. It looks to me as though the shades/grays might be close already and all the difficulty possibly mechanical jitter/overshoot in X associated with all the start/stop action going on. Have you checked the pulleys on both motors in the X-axis? What are your acceleration and jerk settings in firmware?

– David




Well, that’s all way above my pay scale and skill set so I’ll wait to see if consensus develops before I go unscrewing things I shouldn’t be touching! haha!

I have discovered something here though. Definitely part of the equation - just not sure how much of the equation. My y-axis steppers are not moving in unison. The one on the left moves before the one on the right so the entire axis is forever swinging. You can clearly make it out here: (well, mostly clearly - just watch closely you’ll see what I mean). I bet if I tried a print at the far right of the machine I’d have a bit better result.

What’s that about? Any ideas?

And the roller assemblies under the steppers - I had noticed that the inner bearings weren’t touching a while back but since the crown went well assumed it was no big deal. I tightened up the pinch bolts there (the big ones right under the steppers on top of the rail) and it closed up the gap for me.

There were a few loose bolts in the middle assembly where the x and y rails enter the top and bottom pieces so I snugged those up - machine ran good after doing so - without binding I mean. I suspect these were lots that were supposed to be “just engage the nylock loose”. They’re tight now.

Oh, and I also discovered another thing…my find and replace on the Garfield file curiously mirrored the image as well as rotating it to print on the Y axis…neato.[attachment file=87454]

See post above about the y-axis. I’ll check to be sure the pulleys are all tight. That swing could mean that the right pulley is loose on the Y. The x-axis tracks dead even.

Can you tell me how to check the accel and jerk settings? I’ll have a look. The board is untouched from Ryan so it’s set to whatever it came with.



[Edit] Yup. The right stepper was loose and only catching as the axle rolled around to the flat spot. All right now all around and moving square. Still looking yucky though. Pics forthcoming.

Those motors on each axis MUST move in unison… it really doesn’t matter what the acceleration and jerk settings are if they are not. The motor pulleys and belts would be my first suspects… grub screws tight and belts similarly tensioned.

It was so obvious I don’t know how I didn’t see it. It’s not like the loose one on the MP3DP that was spotted by Dui by some miracle. And so now I’m back to the discussion from a week or two ago - how tight should I have the belts. I remember a “sound” discussion but mine are not that tight. Should I snug them up? I can see how a fraction of a millimeter could make a world of difference in the case of the laser engravings.

I’m reprinting the flipped Garfield to compare and there’s improvement for sure. But a long long way to go.

I’m thrilled you’re on to something here, with the loose pulleys, etc. Regarding the belts, they really don’t have to be too tight… I go by the cable tie loops holding the ends of the belt. If they exhibit any “springiness”, allowing to belt to move along its length when gently tugged… they are too loose. Tighten them until there is no perceptible springiness in the cable tie loop when tugged… and you should be good to go.


1 Like

I’m thrilled you’re all helping out. I’ve got big plans for this thing but it’ll only work if I can dial it in.

Heres the flex on my zip ties. Should I snug them down? I see a bit of snugging needed on the front x axis zip tie. Perhaps they all need a notch or three on the zip tie?

Kelly, I believe your corner pieces are on backwards… though I’m not sure what the effect might be. The tie points for the cable ties should look like this

[attachment file=87472]


[attachment file=87473]

Ryan makes a point of this ( in the assembly instructions… so, Ryan, if you’re watching this thread at the moment, what are your thoughts?

As far as the belt tension, it looks like they could be snugged up another notch or two IMO…

– David



Agh! My secret is out! Hahaha. I forgot about that. I HAD them the right way, then second guessed myself and swapped them and by the time I realized I was right in the first place I deduced it wouldn’t matter. Could it be enough to be the culprit you think?

hahaha. Too funny. I’d completely forgotten about that.

Feeling a bit more energetic than normal, I decided to drag my scope out and verify just what’s going on pin 44 of my RAMPS board. With so many laser threads going, I really didn’t know where to put this… so here’s as good a place as any, I suppose.

[attachment file=87481]


Pin 44 is the D9 fan output, remapped and controlled with M106 Sxxx gcode commands. Pin 44 outputs a signal between 0v and +5v, whereas the D9 fan port outputs the same signal, ranging from 0v to +12v.

So, here the isolated green wire is pin 44 and the blue is GND. I’ve put the scope probe on the green wire…

[attachment file=87480]

Using RepetierHost…

M106 S127 is half-power and, as expected, pin 44 shows 50% duty cycle, and Vavg = ~ 2.5v

[attachment file=87482]

M106 S64 is quarter-power, 25% duty cycle, and Vavg = ~ 1.25v

[attachment file=87483]

M106 S0 turns the laser off, 0% duty cycle, and Vavg = ~ 0v

[attachment file=87484]

M106 S192 is three-quarters power, 75% duty cycle, and Vavg = ~ 3.75v

[attachment file=87485]

and, finally, M106 S255 is full-power, 100% duty cycle, and Vavg = ~ 5v

[attachment file=87486]

Given this variable duty cycle signal, the laser TTL input “sees” the Vavg level, ranging from 0v to +5v, and adjusts the laser power accordingly. The D9 fan output, unmapped, puts out the same variable duty cycle signal… but it ranges from 0v to +12v.

Hope this helps somebody, somewhere.

– David