Laser engraving - not really getting great results

…and then I see things that make me think I’m so under qualified to have toys like these in my shop…

Okay. I was sealing some carvings so I tightened the belts and let it run again while I was painting. I now have a repeatable result on both axis. The X Y flipped was y-axis heavy and printed after I tightened up the pulleys. The “David’s File” one was printed normal (x-axis dependent) after snugging down the belts.

Still not great but at least it’s the same on both axis now so one part of this mystery has been solved. [attachment file=87496]
[attachment file=87497]

Still find it funny how the X / Y find & replace flipped the artwork…one day when I understand gcode better I’ll go back and educate myself on ‘why’ it did that.

Are you sure your laser is supposed to have a 12 volt signal?

I can’t say I know. I was going on the “plug and play” rumour that’s out there with the JTech kits and the miniRambo’s fan port?

I’m thinking no? And I’m assuming by you checking that the fan port is spitting out 12v?[attachment file=“Screen Shot 2019-02-04 at 10.41.17 PM.png”]

Driver specs…am I reading wrong - it sounds like it’s good with signal voltages from 2.8 to 36 volts?

[attachment file=“Screen Shot 2019-02-04 at 10.43.06 PM.png”]

Kelly, I apologize. I’ve confused your setup with someone else’s here, I guess. I thought you had a RAMPS board and Banggood laser similar to mine. My previous post with the scope photos and RAMPS pin remapping were not intended to confuse you, or anyone else.

It is my understanding that the JTech laser’s control input works fine with the +12 volt D9 fan control output directly. So you can ignore all the pin remapping information above. But the M106/M107 control commands work the same, remapped or not, so controlling the laser’s power with the duty cycle and voltage averaging info should still be good… only ranging between 0v and +12v, instead of 0v and +5v.

My bad… :frowning:

– David

Nope. No apologies required. I’m grateful for the aid. I reached out to JTech last night and will see if they come back with any pearls of wisdom particular to the laser and board. That is assuming I have the machine specific issues sorted. Which I’m sure I do now? There’s just not so many things that the machine could be responsible for. It must be something between the software and the laser. And your gcode files should take the software out of the equation.

They have an account here and have been very helpful in the past. If you have not already you might want to link this thread in your future communications.

I really have no idea how this is happening. Can you add a common ground between your power supplies or control signals? It really is starting to look like you have a dirty signal to me. You are using a proven machine, and a proven file. So either the lens is super loose and wobbling around or you have a signal that is messed up somehow. It is starting early and ending late randomly.

1 Like

I did indeed include a link to this thread. I thought I’d seen them on here in the past answering questions but couldn’t recall exactly. I definitely had heard through this forum the their customer service was great so I’m feeling confident. With all of you supporting me and the knowledge that they will too I know I’ll figure this out. And at the end of the day it’s likely some oddball thing like the fluorescent light tubes being too close to the controller or the laser just scared I’m gonna toss a chunk of ice under it so it doesn’t want to play nice ; )

(Ryan, I’ll delete this and start a new thread if you think I should.)

I ran my own gcode for a focusing script, separating the lines by 2mm rather than 1mm so I could see them. I really couldn’t tell much difference between most of them.

[attachment file=“IMG_05022019_212502_(1080_x_2222_pixel).jpg”]
[attachment file=“IMG_05022019_212523_(1080_x_2222_pixel).jpg”]

But I lowered it down to the “52” line and then ran David’s two gcode files for the shades of gray and Garfield. My results were kind of similar to Kelly D’s.

[attachment file=“IMG_05022019_212540_(1080_x_2222_pixel).jpg”]
[attachment file=“IMG_05022019_212636_(1080_x_525_pixel).jpg”]
[attachment file=“IMG_05022019_212656_(1080_x_525_pixel).jpg”]

This was all on MDF. Using the Banggood 3.5w laser, 2hich I think is the same one David uses.

 

Arrgh! Based on what you guys are getting… maybe my machine is the one that is broken!

Questions:

Does your machine (or the workpiece?) vibrate/shake excessively while you are engraving Garfield?

Is your machine/workpiece fastened securely down to the table top and not “walking” around while engraving?

Can you reduce the laser power to, say half-power, and slow way down and engrave again?

Pictures of your machines might help. Here’s mine for reference… smaller form-factor MPCNC (24" x 24" footprint), relatively heavy laminated 1"x4" base, feet solidly fastened, and even the workpiece is weighted down with a couple of little BB bean-bags

[attachment file=87633]

Otherwise, I’m stumped. – David

1 Like

I did not notice any shaking, vibrating, or moving of the machine during the operation. The machine is very secure to the table and very solid. I haven’t had any problems when using the spindle or a pen. The table is built from 2x4 lumber and 3/4" plywood and is very solid, but it is on casters. The MDF was not fastened down, but I did not visually notice it moving at all. I recorded some video while it was lazing but I’ll have to upload them tomorrow when I have access to better internet. My home internet is dreadful.

[attachment file=“IMG_05022019_225259_(1080_x_2222_pixel).jpg”]
[attachment file=“IMG_05022019_225316_(1080_x_2222_pixel).jpg”]
[attachment file=“IMG_05022019_225349_(1080_x_2222_pixel).jpg”]
[attachment file=“IMG_05022019_225406_(1080_x_2222_pixel).jpg”]

Heath…I’ve felt so alone for so, so long…hahahah Are you running the miniRambo as well or have you got a different setup?

My build is pretty solid other than that pulley thing we found. The table surface is stud-mounted 3/4" ply with a 3/4" ply build surface. I can’t remember the dimensions off the top of my head - it may be in the build thread here: The Carver’s Frickin’ Laser Build

I haven’t been securing anything other than weighing it down but I’m pretty certain it’s not moving about. I’ll cut the power and speed and see what happens. I think I’ll also revisit the crown file but speed it up to see if it starts to fall apart or not. That’ll be project for tomorrow. I’ve got fresh sealer curing in there right now and it made some funny smells yesterday when I was running the laser while sealing. The VOCs get everywhere - even into the laser beam I think. Reminds me why I wear the respirator…

No word back from JTech yet either but I’m not sure, they may be embroiled in the New Year festivities if they are based out of China. Not sure where they are based out of actually.

(Pictures added to my previous post.)

David, if your machine is broke, I want to break mine the same way!

Kelly D, I’m using a MKS Gen L board (it’s a Ramps 1.4 and Arduino Mega on a single board) with DVR8825 stepper drivers at 1/32 microstepping. I’m using dual endstop firmware and Ryan’s default acceleration, jerk, etc. We’re running different boards and different lasers.

Maybe tomorrow night I can try some things like use cereal box cardboard to make it a more accurate comparison David, play with speed and power and so forth.

A couple videos of the Garfield engraving. I thought I had a video of the gray blocks too, but I don’t. On the subject of speeds, I think the Garfield was running slower than the shades of gray or the leveling script.

Another question… I enabled the laser/spindle control in firmware. But the M03, M04, and M05 commands didn’t seem to do anything. Is that a known issue? David and Kelly, do you have that enabled in your firmware? I’m just hoping to find something common between mine and Kelly’s setup that is different from David’s.

My firmware is untouched “from the factory” as it were and I’m using M106/M107 for control. I was hoping it was a simple matter of switching to a different pin or something.

Hi Kelly,

Sorry for the delay in getting to this thread yesterday, we had a couple employees out and had to catch up their jobs as well.

I think your problem lies in the firmware on the miniRambo. In a lot of cases, they use the FAST_PWM_FAN option in the firmware, which will cause the PWM signal to be very bad in terms of the ability for the laser driver to see it and react accordingly. It is important to make sure this signal has the correct PWM frequency (under 5KHz) as well as not have tons of noise on it. The signal should look like David’s post from above. The RAMPs board with Marlin seems to have less problems than the miniRambo in these issues.

There is a post here on how to update the firmware for the miniRambo.

I suggest using the firmware you have and not the Lulzbot version, but it should have some reference to the “fan” in it. It should be easy to see if it has the same problem as the #define FAST_PWM_FAN in the config.h file. If you have a link to your firmware, I can take a look at it as well and see if I can deduce something. I think this is going to be the main issue.

Also, if there is a lot of noise on the signal then it could have problems. Make sure your ground is very good on your connection.

If you don’t want to mess with firmware, then possibly switch to a Ramps board with a known good firmware like on Davids machine. I know the Ramps board is very good for the laser.

Hope this helps!

Jay

4 Likes

I ran the same Garfield Gcode on my rig this morning for about 10 minutes before work. This is how it turned out. It looks pretty crisp. It burned too deep into the corrugated cardboard I used but there isn’t any fuzziness. I am running a cheap 15 Watt laser from Wish.com controlled by a MKS Base V1.2 board on the Negative Fan pin with a the TTL + connected to some random +5 volt pin on my board.

[attachment file=87701]

Based on what JTech suggested it sounds like both Kelly and Heath need to try to move off of the Fan pins and use the Laser Enable pins instead.

Heath, You said M03 doesn’t work for you. That is because M03 will control a different pin than the Fan pin. You will need to figure out what pin your firmware is controlling then find that pin on your board. I am not sure if this will help you but here is a link to the pin layout for your board.

Kelly, I know Ryan has links for the Laser pin on the Mini Rambo but I couldn’t find it with a quick search.

2 Likes

as far as i know, marlin uses 500Hz PWM without FAST_PWM_FAN (and this proved by pictures of David’s post where single period is 4*500 microsecs).

With FAST_PWM_FAN marlin produces 31KHz PWM signal. (measured with oscilloscope http://3dtoday.ru/blogs/rsergio/struggle-with-cooling-fan/)
or “When FAST_PWM_FAN is enabled, 7.8KHz is the PWM frequency.” (Marlin’s developer said https://github.com/MarlinFirmware/Marlin/issues/10682)
and “I just realized, pin 4 is associated with the timer we use for the temperature ISR, and it is configured to always run at ~1kHz, so it cannot be used as a PWM pin at any other frequency.” (same link)
from your description it look like laser board directly uses PWM signal to drive the diode?

I don’t think that FAST_PWM_FAN is specific to particular AVR based board

1 Like

I agree, the FAST_PWM_FAN is not specific to an AVR based board, but in my experience with Marlin on the mini Rambos a lot of the config.h files for the firmware have this enabled. The miniRambo I have found as well produces quite a bit of noise on the fan output, only if you also have a fan attached to it. In this case, it probably is not the issue with noise, but rather the 31KHz if it is using the fast pwm option.

The laser driver board has a digitally isolated input that has a cutoff frequency of 5KHz. So, anything above this frequency will get wonky with the laser output. The digital input will then be feed into the constant current loop of the board to control the laser output. In a sense it controls it directly as the laser will follow this signal up to 5KHz. After 5KHz it doesn’t control it directly.

-Jay

3 Likes