Laser engraving quality issues

I have a burly version and recently added a JTech 4.2W laser. I have been using lightburn software with max overscan enabled, but I’m having issues with extra burning on the edges. If the extra burn was just on the ends of the horizontal passes, I would think it was due to play in the Z. But it happens in areas that are within the horizontal movement too, but not every row. Any suggestions?

I am worried it isn’t turning the laser off at the right time. Are you using the fan gcode to control the laser?

1 Like

Yes. Hooked up to Fan 0 on RAMBo v1.4 purchased from the shop and using M106/107

In the other instances where similar issues were posted to the forum, the problem was mitigated by moving to Marlin’s inline laser support. For the Rambo board, V1 enabled laser support around version 508, so if your firmware is older than 508, you will have to update. Pin 45 is the laser pin (a 5V pin). You will have to check to make sure a 5V PWM pin can drive your specific laser. My theory is that Marlin modulates the laser output based on acceleration/speed when using inline laser commands. but you won’t see that modulation using fan pins and M106/M107 commands.

Rambo1_4_ExtraPins

2 Likes

Yeah. That’s what I was getting at. Thanks Robert.

Very helpful info, thanks! I used the Fan0 based on the laser page saying it was the simple way to hook up a JTech laser. All the reading I’ve done and I hadn’t seen any differences between using Fan0 and pin 45. Makes sense though. 5V should work with no problems, so I’ll give it a shot!

It isn’t so much the pin. The fan logic is just sloppier in Marlin that the laser mode. (A fan can be turned on a few mm earlier or later, but a laser needs to be precise).

A lot of the docs and advice was created before laser mode and it is easier to just use the fan as is.

But the right way to do it is to use laser mode on any pin. Which pin you choose is more about the electronic comparability with your laser.

2 Likes

Yeah the fan/laser precision completely makes sense, I just hadn’t considered it. I (finally!!) got the firmware updated today and switched the laser signal to pin 45. I can get the laser to fire through the lcd controller, but it’s not firing with the gcode I originally used to make the example I posted. More troubleshooting underway!

1 Like

Did you move to inline commands in LightBurn? You are looking for this in device settings:

image

1 Like

No I was still using M106/107. I’ll try switching to inline

Meant to report back that everything worked great. Figured I still would for future searches. Switched from Fan0 to Pin 45 and using inline setting in Lightburn fixed it.

As a bonus, updating the firmware to the current 513 gave me all kinds of features I had been wishing mine could do but didn’t know had changed.

Thanks again for your alls help!

4 Likes

In the process of laser engraving, water cooling or air cooling device is required for cooling treatment