Laser Etching Aluminum

So I have the 40W due to show up tomorrow, and wanted to dust off my laser skills (skillz?).

I Have had this boring old keychain in my pocket for a few weeks and had to make in mine. This is the leo laser, ~2.8W ish, [topic][/topic] full power 50mm/min (.83mm/s). In the video the larger etch was done at 25mm/s so I doubled it and made the smaller one at 50mm/s no difference, I have no idea how fast I should have been going but I am fresh out of keychains to test on.

Diameter is about 27mm so these are pretty tiny lines.

Fun with lasers…

Fingers crossed for the big one tomorrow.

[attachment file=38346]

You’ll poke your eye out!

I am very scared of it…and I really want to try it as a light saber, just for a second. Fruit ninja?

And something is messed up with the inkscape jtech plugin. Exporting in inches seems to be fine but exporting in mm seems to be off by a factor of 3.55? Hence the crooked etch I got tired of adjusting it and re-exporting burning and centering.

Sure, blame the software. No way all your rulers and calipers and machines are off by 3.55 is there?

Maybe it is bed time…miller time, something. Gotta get the laser stank out of the office.

That would be the most insane prank ever, can you use your code skilzzz to reprogram a digi caliper with a bad calibration? Oh man that would be evil.

Not that I know of. But maybe you could just take out the battery and put one of those protective stickers from a new clock or something.

Lol reprogram someone’s hundred dollar micrometer. Or print all the mpcnc parts with ninjaflex filament.

One of the big XY pieces, just one, that flex would be nasty. I am feeling evil right now, glad I’m not the only one.

Ran into the same 3.55-thing when using Inkscape 0.92. THEY (Inkscape) changed the internal DPI or somesuch that I don’t remember and can’t explain but using an earlier Inkscape version – even 0.91 – and everything should be correct. Googled it and tried earlier versions… that fixed it for me.

Interesting, the plugin does a have a file that overwrites a stock one with DPI in the title. I wonder if I can edit it. I dug out this laser because of all the corexy prototype I have laying around now…I blame you 100%.

If you are still using yours I found out that none of the builds I see use a single belt they all have two, and belt tension needs to be very even or bad things happen. So if you allow the belt to continue across the center once and only have two connections instead of four it works so much better and does not affect the geometry (as far as I can tell). I almost gave up before I figured this out. Now I am remaking the parts again to facilitate this a little better. I am wondering if this is why it has been adopted by other companies or if I am missing some other bug yet to be discovered.

I see in one file it say assume 90dpi, than in the main program I see this

[attachment file=38380]

3.54…I was off by a little bit, my math is better than this I promise. Why the hell are they scaling it?

That is the culprit, that is the conversion fact they use from mm to px. I wonder if just setting the document to the right size and then switching the units to PX would work.



My CoreXY machine uses two belts… each about 7’ long for my 2’x2’ outside footprint machine. I did notice a sensitivity to belt tension differences… used zipties to connect so just tensioned each side until I saw it just start to pull it out of square. I never thought of using a single belt but does make sense that it would even things out. I may just take two ends loose at the X-carriage and connect them together to see what happens. Thanks for the idea…

– David

I removed the MM issue, but have not changed anything on the inch side.

Jay from jtech has seen the fix, not clear if an update will be made or not.

[attachment file=38399] (38.6 KB)

Are you etching directly into the aluminum? Or did you spray the keychain with something first?
I have an 2,5w laser, and i just dont seem to get a good hit on any metal at all.
Even if i just hit it at the same spot.

That is untreated anodized aluminum, it only works on anodized.