Layer shifting

I’m getting some slight shifting on my x axis. Here is a part I am printing for the ZenXY. The side is supposed to be flat, but as you can see it shifted about half a mm at one point, then later it randomly shifted back half a mm.

I’m running a DRV8825 on that axis, could the stepper driver be the culprit? Everything else seems solid on the printer.

The stepper motor itself is unlikely to be the culprit.

Grub screws are more likely, lol.

You might want to re-check the VRef on those DRV8825s and ensure that the current setting is appropriate. If there’s a mechanical jam, it’s more normal for it to keep skipping in the same direction, rather than skipping back, unless it’s something just in that one space where something goes out of alignment, then back in.

I might also run the Gcode through a viewer, and see if it wasn’t the slicer barfing. I’ve had that happen where a failed print came out exactly the same more than once, and it turned out to be bad gcode.

1 Like

I had the same issue printing one of the mpcnc parts. I moved the part on the print bed and resliced and the shift went away.

I increased the current on the DRV8825 from 1.2A, which was a but low, to 2A. It reduced the shifting, but it was still happening. I then replaced the driver with a TMC2225. We’ll see if that makes a difference.


For a printer, 1.2A is pretty high, I’d think. That’s more than I run the motors on my Primo at.

I’d start looking for mechanical binding. Does the layer shift happen at anythng that looks even close to the same heights?

The new drives made no difference. I figured out the problem though. It was catching on blobs. I’m printing PETG with a 0.6 mm nozzle and a 0.8 mm line width. The layer hight was 0.2mm and it was causing some bobbing. I increased the layer height to 0.3mm and the problem is solved.