LCD Setup


I started to flash Marlin (MPCNC813MRAmbo_GLCD_T8) on my mini Rambo. I bought the Rambo as a Kit from Amazon with a 2004A LCD screen ( But after flashing the LCD don’t show any information, just a blue screen.

I tried the following LDC´s to define:

// RepRapDiscount Smart Controller.
// Note: Usually sold with a white PCB.


and the default “full graphic LCD”.


Someone know this problem ?

Try adjusting the contrast via the potentiometer. It could be maxed out.

If you commented the default screen out the other thing could just be cable orientation, there are 4 options and only one works. One will give a blue screen and no text, two will give nothing.

Can´t change the contrast :(.


What do you mean with 4 options ? Because I have 2 cable, 2 port on the Rambo and 2 ports on the LCD. So all over I have 12 options, or?

Or do you mean just on the Rambo or just one cable. Sorry, I guess it’s a stupid question :/, but that´s all new for me.

Make sure port 1 is going to port one, then you only have 2 options. The two options are which way you plug it in. I have pictures on the electronics page.


I know it is a different screen but the plugs are exactly the same. see how teh wires are pointed up in this pic…they can also be pointed down on the board side.

Yes ok, i understand.

Did not work :(. I got two blue screens and two black screens.

Is it also constantly beeping a long steady tone? I know I have seen this before but can’t remember the cause. Then again I may be thinking about a solution that worked for repetier firmware. Could you upload a picture of your LCD front and back? I am curious to see if you might have the wrong LCD display type for this setting even though it sounds like you have the correct one. Just checking. But if my memory is correct then the last time I saw this it was caused by the wrong LCD type used in the firmware.

The 2004A display is different than the RepRapDiscount Full Graphic Smart Controller. You need to comment out the Full Graphic and remove the comment from the 2004A type.


No, there is beeping. I also think it is the wrong LCD type used in the firmware, but I don’t know which one is the right.


The following I have tried:

First with the "MPCNC813MRAmbo_GLCD_T8"configuration:


//#define ULTRA_LCD // Character based


//#define CARTESIO_UI






Inside the Basic Marlin are more LCD type´s. These I tried:

//#define ZONESTAR_LCD // Requires ADC_KEYPAD_PIN to be assigned to an analog pin.
// This LCD is known to be susceptible to electrical interference
// which scrambles the display. Pressing any button clears it up.
// This is a LCD2004 display with 5 analog buttons.


// Generic 16x2, 16x4, 20x2, or 20x4 character-based LCD.
//#define ULTRA_LCD


// These require F.Malpartida’s LiquidCrystal_I2C library
//#define LCD_SAINSMART_I2C_1602
#define LCD_SAINSMART_I2C_2004

But at the last config. i have the problem, that I don’t know the I2C-adresse from the lcd controller. My coding skills are not good enough to write a scanner for this specific setup :(


The pictures look exactly like one of the LCD’s that I am currently using on one of my devices. Here are the two lines in my configuration.h file that are uncommented.


This is the one that defines the LCD model. This next line I don’t really understand but I think it is telling the firmware that the LCD can only show characters not graphics. I could be wrong. But it works for me like this.

#define ULTRA_LCD // Character based

give that a try. And remember if it doesn’t work correctly at first. Power it all down then switch the cables. Don’t do that while it is powered up.



Don´t work for me :frowning:

Hhhhmmmmmm… ok then I would say the problem is most likely cable related. In this video his wires have the red pin pointing a different direction on one of the cables. It is also possible one of your cables are damaged but more likely a cable is just backwards. See if you can find pin 1 on each board and make sure pin 1 connects to pin 1 .

I will take a look at mine when I get home.

Ok. So the cables. Pin 1 to Pin 1 is important to make it work. How can you tell which pin is pin 1. Well I will show you. If you look in this photo you will see that one of the pins has a little square drawn around it on the red board. That is Pin 1.

[attachment file=73789]

In this next picture I took the plastic guide off so you can see the pins underneath. In this case Pin 1 has a square solder point on the black board.

[attachment file=73790]

It is possible that these plastic guides could be backwards preventing your pins from lining up. I have seen it happen once before. If you can’t tell which pin is pin 1 then just gently slide the plastic guides off of one of the two boards and try connecting the cables both directions. Like Ryan said you can’t [corrected typo] cook these things by making a mistake. (But I would still power down first before switching cables.)

In your 626.jpg picture your cables are wrong on the mini. Correct port, wrong direction.


I don’t have these square marks, but I connect it exactly like you.

I changed it, now it is like Aaryn said. This is what happened.

Could someone post a working configuration.h file?

That way Jan could just drop it in and see if it works.


The Prusa Mk2 uses that type LCD and mini rambo.

You could down load the Prusa firmware, flash, and see if the screen works. It might remove a trouble shooting variable.

This works.

Okay, it still won’t work. I think we should close this topic here. I guess the display is just damaged. I think I will buy a new one and test this. Anyways thanks a lot to all who supporting me, you are great ! I very like this community :D!