Losing steps big time.

Hey guys,

I’ve been having this issue from the beginning but didn’t think much of it until after I levelled my frame.

I have an 8 x 4 full sheet machine setup, and to put it simply, every time I go to run a job and cut something, it will most likely, at any random time lose steps and via off to a different direction, or start turning before it’s supposed to because it’s lost steps etc.

At the start I thought it was because my spoilboard was not level, so one side of the piece might have 2mm cut, and the other 4mm due to the uneven spoilboard. So I thought it was getting stuck at the 4mm (eg) side because it was digging in too deep.

This morning was the first time I tried the machine after levelling the frame to within 0.4mm (I think)., and it did the same thing. Two times, first time on the 3rd pass, and the second time on the 2nd pass, both at different places.

My configuration was: 3.175mm downcut bit, single flute, 2mm cut per pass. X & Y @ 15mm/s, Z @ 5mm/s. Brand new endmill.

Electronics wise, I’m running the miniRambo, all parts supplied by Ryan.

 

It almost seems there is not quite enough power to the motors. Maybe the drivers aren’t providing enough current to the steppers? There is not ‘pot’ on the board that I can see. Does that mean the VRef is adjustable in Marlin?

 

I’m not sure what else to do. I have checked and I can move all Axis to their limits without an issue, every time, but under load it’s a different story. The settings I used today, I would think they are very conservative.

 

Any help would be absolutely awesome. Thanks guys

  1. What are the speeds your using when cutting? Something around 10mm/s would be a good starting point.
  2. Can you upload the gcode so we can check to see if there's something squirrelly in it?
  3. Did you try Ryan's crown gcode? What does it do with Ryan's crown cutting in the air?

My configuration was: 3.175mm downcut bit, single flute, 2mm cut per pass. X & Y @ 15mm/s, Z @ 5mm/s. Brand new endmill.

I used Ryans crown with a pen, no problem at all.

I will go and run the same code in the air to see what happens but I doubt there’s an issue with the gcode. Both times it went off track at different spots with the same gcode. It has to be a torque issue. And at 2mm depth with a brand new bit really isn’t asking too much I would’ve thought

If it runs the code while air cutting, air cut again, but while it’s flying around, jiggle the power cable to the rambo. I had a similar issue a while back with the v1 lowrider and it ended up being a funky power supply connection. It would drop power just long enough to cause weird motion issues.

Tried that today mate, not power related.

After trying the same g-code the 3rd time, i noticed that during a short cut along the X axis, again it stuffed up so I cancelled the job. After looking things over I noticed the right side of my Z tube was lower than the left side. Before I start the job, I make sure they are perfectly level, so… at some stage within the 1 minute of cutting, the right side of Z dropped, probably about 1/2 inch, which made the DOC deeper, around 6mm deep is what I measured at the end of the cut, so that would be the reason why it’s losing steps

My thinking is that you either have the rapids set too high for z-axis motion or there’s binding when the z-axis moves. Ryan recommends limiting the z-axis motion to less than 8mm/s. How did you do your CAM? If you used EstlCAM, there’s a setting for rapid feed rate which should be set to 480 mm/min per https://www.v1engineering.com/estlcam-basics/

Yeah it’s set to 480 and X and Y 2100.

You’re right, it does sound like binding of the Z of some sort. I’ll have to do more investigation next weekend

1 Like

If you link your gcode we can tell instantly if you set your estlcam right, sounds like the issue. Even just cutting and pasting the first 20-30 lines is enough.

I’ve attached the file. Thanks for taking a look

Side_panel.gcode (7.04 KB)

How about wiring? I fought and fought with mine for the first six months and finally started checking the wiring. Jiggle the connectors one at a time while its running and keep an eye on that stepper motor.

Moving all axis including Z, they all seem to behave themselves. Definitely possible though

Is the right side dropping too far or is the left side not going down as it should? From your description and your gcode, it seems like something is going wrong with your stepper on the right side. I’m not an expert but your gcode looked ok at first glance. Your cutting parameters aren’t out of the realm of norm for the Lowrider. I routinely cut mdf much deeper for DOC then you are with the same travel speed and I don’t have these issues.

Some other questions - what material are you cutting?
Have you checked all the hardware on the right side and make sure the connections are secure and proper?
How are the grub screws on your coupler? Is the shaft of the TNut touching the top of the shaft of the stepper (like in the detailed picture Ryan gives)?
If you manually move the Z axis up and down (with the LCD) does the right side get out of sync?
I would check the wiring to the right sided stepper. It almost seems like it is loosing power at some point and dropping down (like the namesake “Lowrider” implies, when it looses power the Z axis “falls” down. Make sure the wiring going to the right sided Z stepper isn’t being pinched or kinked or anything like that.

The right side is dropping. If it was the other way around, the bit wouldn’t be digging in to the wood (MDF) twice the depth of what was set.

Moving ANY axis, including Z manually in the air it all stays in sync.

 

I will do a few more tests and take more notice at things while they’re moving and see how I go

I don’t really understand what you actually mean by “the right side being lower than the left side”, but if it’s a random Z related issue, my bet would be that the Z axis threaded rod is not tightened well enough to the motor shaft, so most of the time it would be fine, but sometimes it could slip while going up because of the vibrations and weight.

While you’re at it, check that the Z axis travel is smooth and that you don’t need too much force to move it up and down accross its lenght.

Some pictures or videos of your machine would definitely help a lot to troubleshoot.

SO I had a chance this morning to run another test. I checked all I could and everything seems in good order. Grub screws tight. Z moves up and down really smooth, and so does X and Y. The only thing I did do was to lubricate the Z screws with lithium grease spray. I run the file and it went through without a problem. Mind you this was still only at 2.1mm per pass and 15mm/s @ 2mm plunge rate on the Z. I previously had the plunge rate to 8mm/s. I have a feeling maybe this was my issue??

Tomorrow morning I will be going all out running a file for almost a whole sheet. Around 3.5 hours all up. The only difference with the test is that I will be going at 3.4mm per pass.

 

Sorry I forgot, using a 3.18mm downcut single flute endmill on 16mm MDF. My Makita lookalike router, I have the speed set to number 4 out of 6. Tempted to go to 6 but I get the feeling it’ll be a bad idea. I don’t yet have a digital tacho to measure the RPM of the spindle, but max is 30,000RPM. Any thoughts and advice?

You may have issues with the downcut bit not clearing chips out, which will lead to heating and dulling the bit. I’d recommend an upcut bit and trying your planned speed and depth of cut to make sure it will work. FWIW, I use 15mm/s and 3 mm/pass when cutting MDF.

1 Like

This reminds me of an problem that I had recently with Arduino running a WS2812 LED array. I can program it and get it to do everything, but it would randomly hang and stop responding. I noticed that every time it hung was with all 64 LEDs at full power. My theory is that my USB power supply was sufficient to drive everything when only some of the LEDs were running or when they were not running full power. But trying to drive all of them was too much.

The reason that your situation reminds me of it is that everything in your machine seems to work well in isolation (e.g. jogging a single axis, or run the crown with no resistance), but you’re having trouble when running a job. Like the saying goes, the whole system is constrained by the weakest link. You may have more than one, but my approach would be to try to find the weak link and go from there. Unfortunately, your problem is dynamic in behavior. Fortunately, you have a clue in that the problem is showing up in a single motor on the Z axis.

The first thing I’d do is to re-check the current limit on the stepper drivers. For min RAMBo, Ryan discusses it here under ‘Driver Math’:

https://www.v1engineering.com/mini-rambo-1-3/

Next, I would try bypassing the existing 4 wires for the problem motor with some 22AWG or larger wire. If this makes a difference, then this will confirm that the weak link is somewhere there, so this will narrow down your troubleshooting.

I’d also monitor the voltage on the input to the motors to see if you’re getting a drop there. It’s crude, but easy to check. Checking voltage of stepper motors is harder if you don’t have an oscilloscope. (If you don’t, then the JYETech is a great value for the basic tinkerer). Also, there are points on the board for each axis labeled XREF, YREF, ZREF that might tell you something.

I don’t know that either of the last two in isolation will point to the specific issue, but they’ll provide insight that should allow faster troubleshooting.

Are you running a spindle or router? What speed you running it at?

I’m using the DW611 on 3 or 4 IIRC.

What is the max setting on the DW611?