Loss of z axis control

I have been using the MPCNC to v-carve [ successfully ]. Now the Z axis is sinking into the workpiece B4 starting the carve. I am using my laptop to control the mpcnc . I just dont know where to start looking for the problem ---- Thanks , Joe

I was having the same issue with my v-carve files too today after it working before. Before I even started to cut the file (just loaded it), the Z axis would begin to drop down, super odd.

I used the LCD screen and went to the custom V1 menu and reset XYZ coordinates, which seemed to fix it. No idea why…

Thanks for the comeback. I am using my laptop to control the mpcnc , which means that I am setting the co-ordinates manually. So I am still stumped . Any one have any further ideas ???
Thanks again , Joe

Are you setting all 3? for example: G92 X0 Y0 Z0

Do you have an LCD? What does it say your starting coordinates are?

There are 2 way that this could be taken:

  1. You start the job and the machine plunges down into the work. This would typically be that the machine’s Z=0 is set wrong, since the job usually starts with going to what it thinks should be an appropriate Z coordinate. This is the one where resetting the coordinates will help.

  2. The Z axis is falling while the motors are unpowered. This is relatively normal. Generally, moving the machine so that the motors are powered up is all that is required. There is a timeout that can be set as to when the motors will be unpowered again, depending on your firmware. I’ve only run onto this with GRBL, but there are a few things that can cause it otherwose. Just the machine being well lubricated, the Z axis can (and probably will) fall while the Z motor is unpowered.

I just lost Z Axis control last night on my MPCNC while it was 21 holes into a 23 hole job. And I did what I know better than to do… left it unattended carving. It drove the Z axis into the work and tried to start a fire the old fashion way like they used to do with a wood drill… I was close enough to “hear” that it sounded funny and caught it before really bad things happened. It would only move Z axis one way… down…

First thought was one of my stepper drivers had fried. Using the TMC2209 drivers in an SKR board (great combo by the way). Started looking for replacements but then decided maybe I should actually diagnose this. Swapped an X axis driver into the Z axis and still it only went down. Huh? So I took a spare stepper motor and plugged it into Z axis (power off when swapping steppers or you CAN fry your drivers EASILY. Just unplugging when active can fry it in a microsecond). Hmmm, bad stepper? My stepper cables to Z had to be extended during the build and I had used the proper molex headers and pins and bought the proper crimp tool and was pretty proud of the clean wiring… and at the junction of the wires I could plug in my spare stepper and confirm it still worked there. It did. Plugged the original stepper back in and IT WORKED!? Huh? Then I examined my crimped molex connection I was so proud of and saw the molex was melted on one side. Obviously a poor crimp on my part that heated up and broke connection during flexing of the cable chain holding it.

Needless to say that connector junction has been replaced by soldered connections with nice heat shrink that I am really proud of. Yup I will post if that fails…

A long way of saying look for even a single wire break if you lose direction control on an axis…


Sorry you had that problem, but happy that you were able to track down the issue and resolve it. And very happy that you didn’t have a fire!

Thanks for the advice guys. Gives me something to work on . I’ll check in later when I get it figured out [ or not ] – Joe

I don’t remember seeing melted connectors on this forum in the past, but I’ve now seen them twice in just a couple of days.