Lowrider 2 journey

Today I wanted to order a router, but then I suddenly realized it would need some bits too.
However without any CNC experience this seems to be not so easy (to select a bit…).

So I came across a very interesting website: What the flute? And a nice youtube video: CNC Bits For Beginners

Thanks to this, I think I got the basic insights, and wanted to order some bits at the V1 shop, but then I got my calculator running…

And concluded I would be better to buy on a localized Amazon shop to begin with. So I can mess around before buying better tools :blush:

I would be milling the following

  • Acrylic
  • Poplar wood
  • Paulownia wood
  • Layered Maple veneer
  • Engraving text and logos on Acrylic

I think I understood that Acrylic would benefit from 1 or 2 flute bits. But I am still not sure if I would need a V bit for engraving logos instead of a “normal” bit with small diameter like 1.8mm :blush:

So I wonder if anyone has some experience on buying bits from Amazon?

I came across this kit, and for a newbie, it looks interesting as it is a mix of bits: Genmitsu End mill set with a total of 40 CNC router bits but it lacks some details like if they are up or down cut bits.

Obviously I have no idea if it would be a good starter kit, nor what a blue or titanium coat would do :smiley: Some advice would be appreciated​:blush:

Start with a good set of uncut carbide bits 1/8 or 1/4 with 1-2 flutes.

There are enough things that could go wrong with a new build so take the bits out of the equation. Upcuts aren’t as clean cutting as Down cuts or combo bits but they dont jam up either when doing deep cuts.

If you aren’t buying from the V1 store I’ve had some good luck with the speed tiger bits on Amazon. I think Ryan sells Kyocera bits which are also good.

So, last week I received some goodies :slight_smile:

I ordered some wiring, end stop sensors, etc. The basic stuff to make my build complete.

I also received the router, I decided to go with Katsu as it will probably be attached permanently. So it wouldn´t have made sense to order all the additional parts. It was a pleasant unpacking up until the moment I noticed the rust on one of the screws.
Let´s hope that´s the only thing wrong with it:)

This damn thing makes a lot of noise, so it will be replaced in the future for sure.
Otherwise my wife will kick me out the house :smiley:

After reclaiming my workspace I set up the sawhorses, but I´ll need to make an adjustment later as there´s a gap between the beams and the spoilboard. That makes the workspace uneven for now. But it´s a start :wink:

I went to the metal shop this week too, but I was unable to get RVS steel in 25mm. They only stock it in Alu but read in the forum somewhere that would be a bad idea. So I took the welded steel tubes instead. The downside is that they already show some minor corrosion after cleaning the lubes from them. Let`s see how this continues.

During assembling I noticed that something big is missing in the instructions. It did not tell about the many swearing involved. :slight_smile:
I accidentally dropped one of the heavy steel tubes directly on my weak ankly. Not fun!
That was caused because I needed to use pliers instead of the right tools. It felt like mission impossible.

In the end I managed to get them installed but one side of the XZ main doesn´t sit completely flat on the YZ rollers. Because of the little accident I dediced to ignore it for now.

When installing one of the steppers, a screw broke because it didn´t allign perfectly. I was lucky it already fitted in far enough so it´s more like an optical issue. I should have threated it before installing, but was in a hurry.

Next stop was extending the stepper wiring, and installing the correct connectors.
It was a bit confusing because 2 wires had to be swapped (red is blue, blue is red).

I could´t wait any longer to power the device, so I lifted the Z axis. Yes, I am sure it is way to long (40cm) but that´s something you conclude after assembling, specifically if you have zero CNC and lowrider experience :slight_smile: So next time I would use shorter tubes.

For me it was funny to see that, without lubrication, the Z remained its position once unpowered. The moment I added a lubricant, the Z dropped down immediately after powering down. The momentum creates enough power to repower the CNC based on current the steppers generate. So I might experiment with a solution to avoid power to flow back in the system. It could damage things.

So I kept building,…

And finally I downloaded the test crown, installed a pen, and watched the magic happen…

During the first run, the pen pivoted all directions, so I made a sturdier connection, but when the pen did not touch the paper, i pushed it a bit to hard so it misalligned.
Third run was great, as it´s a perfect drawing, except for the place where my spoilboard isnt´level…

Now I need to figure out what would be the best endstop solution. If anyone has an opinion about this, please share! I found some info on the forum but it´s hard to compare the solutions and figure out the best way. Some people seem to add a stop on the upper part of the Z, other on the bottom side.

I also wonder if it is normal that I cant use the “baby step” during runtime. When using the menu it throws an error. That´s to bad because it would have been a good solution to fix my pen height.

Anyways, next on the list is printing the TFT housing, install the endstops, mounting the SKR and power supply (I´ll be using Dan´s solution probably). And when that´s done it will be time to install the Katsu router too.


Wipe the tubes down with some paste wax.

1 Like

That’s a good idea, will see if I can find it in a local shop.

1 Like

use bees wax

1 Like

So, life got in the way and had to put this project on hold for some time :frowning:

use bees wax

I didn´t wipe down the tubes just yet, it is still on the “to do” list. However I noticed the corrosion is there, but very limited, so will dee how this evolves.

Few weeks ago I parked the Lowrider 2 in his corner so I could continue when time was right. Last week I tried to boot the LR2 but one of the Z motors refused to work. :roll_eyes:
So I returned the faulty stepper motor and installed a brand new one.
When ready to boot, I noticed some other stepper motor wires broke down. So I soldered it again, and this time I used audio wires. Looks like a much more solid connection then those thin stepper motor wires.

Not wanting to loose more time I decided to cut open an electrical box, to fit the SKR Pro and display. That was a job done in few minutes by just using a knife and a pen to make the markings where to cut.

The end result isn´t too bad, at least not for now. When I´ve used the machine some time I´ll upgrade it to a better solution.

Reading that some users had heat problems, I made sure there´s a way for the air to flow, and to fit cables at the same time.

As I couldn´t find a properly sized alu profile for the Z cables, I used a profile for plaster boards. Again a cheap and quick solution to keep going.
The only issue I noticed this far, is that the wires can get stuck behind the stepper motor.
So either I have to properly strap the wires, but can´t seem to find how to do this, or I´ll need to get an other solution.

An issue I´ve came across are those steel tubes for the Z axis. Somehow I am unable to get them square. I’ve loosened the screws, tightened them… none of the adjustments seem to do the trick. So I might need to invest in the Alu XZ main, so that they are always square.

When making the drawing of the test crown, all looks good, however when running a longer distance on the table, I notice the wheels go sideways and get close to the edges. I hope/think that´s caused because the tubes aren´t square.

I still need to come up with a way to fit the End Stops, so decided that -for now- I could attach the power supply and SKR control box to the side quickly using some straps.
This way I could finally try to cut something.

So after multiple simulations, I decided to cut the crown test image 5mm into a piece of scrap. Well that didn´t work out like I hoped…

The LR2 skipped steps and twisted all directions. So I tried once more, to get the same result. When measuring the depth of the cut, its ±13mm deep although I´ve set up estlcam for only 5mm.

I suspect that the piece of code (z-probe) I grabbed from the FAQ contains an error. I modified this to respect the heigth of my Z-probe (14mm).
If someone see the reason why this happes, pleas let me know!

To me it looks like it plunges directly to 14mm to cut, instead of doing layer after layer.

And it also looks like it doesn´t respond to my Z-Probe.
When lifting the Z to the max, and running the code with the probe attached, it looks to ignore this. It just goes down for some end, no matter if I touch the probe to the bit or not :frowning:

If you run your probe code and then send z to 0 does it stop right on top of the workpiece or try to drive itself through the work piece?

strange thing is, it lowers like may 3 to 5mm, that´s it.

I optimized my code a bit, to make more sense;
from this

G91 ; Relative positioning, just in case
G92 X0 Y0 Z0 ; Set Current position to 0, all axes
G00 Z5.0000 F500 ; Raise Z 5mm at 8.3mm/s to clear clamps and screws
G28 X Y Z ; Home in order, w/zprobe
G92 Z14 ; Account for probe thickness (set your thickness)
G00 Z5.000 F500 ; Raise Z probe off of surface
M00 ; pause for LCD button press
M03 S24000 ; PID, set spindle speed
G90 ; Absolute positioning, just in case
G00 Z10.0000 F480

to this

G90 ; Absolute positioning
G92 X0 Y0 Z0 ; Set Current position to 0, all axes
G00 Z20.0000 F500 ; Raise Z 20mm at 8.3mm/s to clear clamps and screws
G28 Z ; Home with z-probe, no xy probe just yet
G92 Z14.0000 ; probe thickness
G00 Z19.000 F500 ; Raise Z 5mm higher then probe to remove probe
M00 ; pause for LCD button press to remove probe
G00 Z5.0000 F500 ; After touch plate removal, lower to 5mm above workpiece

As I do not have X/Y sensors in place just yet, I removed their homing request.
I also raised the height from 5mm to 20mm to have a good understanding what happens.
Changed the probe height from Z14 to Z14.000 just to be sure this isn´t the issue.

What happens now, when I simulate, is that Z first raises 20mm, then lowers like 3-5mm, and raises back up. So it totally ignores the probing itself.

So opened my SKR box and measured the wires, they are good. I double checked that I am using the correct connector, and that´s the case.

I lowered the Z to barely touch the probe, and issued the M119 command, and that´s looking good:

So cabling is not to blame here.

I do not understand the M666 command completely just yet, but I suspect this isn´t an issue neither.

So I thought, ok let´s try Marlin mode instead of the touchscreen;
And probing Z trough the menu works like a charm!

But when moving the Z to an other height, and homing it back, it just lowers back 3 or 5mm and that´s it. It refuses to go to “0”.

Maybe I am completely misunderstanding how homing works?

I don’t have a LowRider, but based on what I’ve read on the Forum, in the V1 published firmware, Home Z will home upward and use the limit switches to square the Z axis. Probe Z will probe downwards and use the touch plate. The behavior you see will happen if 1) you don’t have endstops on the Z axis, or 2) you wired your Z endstops as normally open instead of normally closed. When you trigger the command, the machine thinks it is already at the endstop (since it is triggered), and the 5mm of downward movement is the part of the retest sequence. An M119 should never report that the Z probe is triggered and the Z max triggered at the same time.

If you want to return Z to 0, you can just send a G0:

G0 Z0 F400

Are you running dual endstop firmware without having dual endstops?

Also I’m pretty sure that G28 z only works with standard firmware because that sends z home. If you are in fact using dual endstop firmware you need to use G38.2 as that is to prove target. G28 would wait until your z height switches are triggered which would already be the case since you don’t have switches connected.

I would:

A) switch to standard firmware and then use g28
B) add your dual endstop switches and use G38.2

1 Like


This makes sense! I have no idea just yet what Gcodes actually do. Reading the FAQ I was under the impression “G28 Z” would probe down. However, you’re right homing Z on LR2 goes up, probing goes down, so when it goes up it triggers automatically depending on the NO/ NC settings…

I got the code from here , maybe it should be added so that noobs like me don’t make stupid mistakes :smiley:

That’s very helpful, thanks! Just in case someone else stumbles onto this problem too, I found a great place explaining the Gcode’s:

G38.n Straight Probe

G38.n axes
  • G38.2 - probe toward workpiece, stop on contact, signal error if failure
  • G38.3 - probe toward workpiece, stop on contact
  • G38.4 - probe away from workpiece, stop on loss of contact, signal error if failure
  • G38.5 - probe away from workpiece, stop on loss of contact

I will try using G38.2, although I can’t add the other switches just yet, as I still need to figure out where to install them. And then print the parts.

Will report back tomorrow!
Thanks for the help guys.

1 Like

Not all version of gcode are interchangeable, so while that LinuxCNC resource looks good for g38.2, the options may not line up for other commands. The V1 maintained firmware is all based on Marlin, so here’s a link to the Marlin-supported gcode documentation.

1 Like

There’s no need to flash firmware. You can continue to run the Dual-Endstop firmware, just don’t use any homing or auto-squaring commands until you get the switches in place.

Before you start a job, manually move the tool to the desired origin location and execute a g92 X0 Y0 Z0 to let the machine know where it is. Then the job can run as designed by the CAM software.


Thanks for mentioning this!
I was browsing through the codes and I could indeed find some different commands.

Tuned my script again, but still no luck.

G90 ; Absolute positioning, just in case
G92 X0 Y0 Z0 ; Set Current position to 0, all axes
G00 Z20.0000 F500 ; Raise Z 20mm at 8.3mm/s to clear clamps and screws before homing
G38.2 Z Probe Z axis toward workpiece, stop on contact, signal error if failure
G92 Z14.0000 ; Account for probe thickness (set your thickness)
G00 Z24.000 F500 ; Raise Z probe off of surface by putting it 10mm higher then probe
M00 ; pause for LCD button press to remove probe

using G38.2, probing got ignored once more.
The Z lifts 20mm, stops very briefly and raises again 10mm before prompting pause.

Using the Marlin docs I found the code G30, single Z probe on X/Y axes. So modified once more;

G90 ; Absolute positioning, just in case
G92 X0 Y0 Z0 ; Set Current position to 0, all axes
G00 Z20.0000 F500 ; Raise Z 20mm at 8.3mm/s to clear clamps and screws before homing
M00 ; pause for LCD button press to remove probe
G30; Probe Z axis default X Y axis
G92 Z14.0000 ; Account for probe thickness (set your thickness)
M00 ; pause for LCD button press to remove probe
G00 Z24.000 F500 ; Raise Z probe off of surface by putting it 10mm higher then probe
M00 ; pause for LCD button press to remove probe

This time the Z lifst 20mm, prompts pause, before starting to lower towards the probe…
but it keeps on droping until I need to reboot (or it crashes on workpiece). So once again the probe got ignored :frowning:

I´v shorted the Z probe sensors as quick test, to see if this makes a difference, but that´s not the case at all. I once again tested the Z probe and it functions properly using M119.

Yes, I thought the same, if I am not using it, it shouldn´t matter since I could draw the test crown with a pen.

Well, that was something I was considering. But then why do I have a probe :smiley:
I could go to Marlin mode, probe, and switch back to TFT mode. But it makes no sense working this way…

I think I´ll reflash the SKR and TFT, to see if it makes a difference. I notice 2 other bugs at the moment too: it takes like 1- 2 minutes before the message “no printer connected” goes away after booting, and for some reason Marlin mode keeps saying that there is no media although it´s connected in TFT.

You’d still want the G92 X0 Y0 (unless you’re doing 3-axis probing).

Marlin mode may expect the SD to be on a different controller pin than the SD card that’s built into the TFT. But, I’m running a completely different stack (grbl, CNC Shield, Ardiuino Uno), so I can’t be of any assistance sorting those issues out.

1 Like

Marlin mode should use the sd card reader in the tft.

Dual LR is an advanced firmware, milling basics is for the middle of the road. But I suppose a comment for dual lr there wouldn’t hurt. There is a little pencil in the top right of the page if you want to suggest an edit.

I am seeing a few lowercase g’s and m’s. Be aware that Marlin only likes ALL CAPS.

G38.2 Z0 is the command to probe on the low rider.

1 Like

damn, I was hoping on using USB trough the TFT.

Will do once I understand how the things work, as there is no point in confusing others with my limited CNC knowledge:)

So this morning I wanted to update the SKR board, but the supplied SD card seems to be dead for some reason. Maybe it didn´t like the cold. So was trying to update from USB but that seems not possible.

Found another SD card and updated to “[v513]” V1CNC_SkrPro_DualLR_2209- and now the error “no printer attached” goes away after 10-20 seconds. So that´s nice.

However my Z axis is reversed, if I push up only one side goes up, if I push down the other side goes up and the one that was up goes down. So I gues some configuration should be changed in the source software, but reading the release note I think @jeffeb3 is aware of it.

I´m going to resolder the wire for now, as I used the JST connectors and cant just turn the connector.

So, little progress.
I rewired one of the steppers on the Z axis. I took the closest one as that seemed to be the easiest way. Unfortunately, that´s causing more issues due to the firmware bug.

By rewiring I had to reverse the direction of the motors. So far so good…
But that´s causing a new issue

The icons are correct, but the text below are totally wrong on the reversed axis. So tried to reflash the display, but that didn´t make any difference.

Ignoring this, I went on testing the Marlin commands provided by Tom.
It seems that the probe only reacts to G30. So that´s good to know.

But… because of reversing the Z axis -because of the FW bug- I have a new problem :@
When I run this:

G90 ; Absolute positioning, just in case
G92 X0 Y0 Z0 ; Set Current position to 0, all axes
G00 Z20.0000 F500 ; Raise Z 20mm at 8.3mm/s to clear clamps and screws before homing
G30; Probe Z axis default X Y axis
G92 Z14.0000 ; Account for probe thickness
G00 Z24.000 F500 ; Raise Z probe off of surface by putting it 10mm higher then probe
M00 ; pause for LCD button press to remove probe

Instead of going up on command G00 Z20 it goes down for 20mm.
On command G30 the Z axis goes up until I close the probe. and then it continues the script in reversed logic…

So I will need to disable the reversed axis setting, resolder the stepper motor to it´s original pinout, and then resolder the other Z stepper motor. A bit frustrating as my wires are getting short and it´s like the 5th time I am soldering them, and will need to do once more when the FW bug is fixed in future releases :slight_smile: but hey, there´s little progress made.

I also have another issue to deal with, when I have resoldered the wires. It seems that G30 has a limited timewindow. If it takes too long it goes into error.

Something I need to figure out, because when I install my Z endstop, the current timing will not cover the total distance.

So, I had to try once more, as I overlooked this command. I tested without “Z0” as I thought it was optional. Seems not.
Using G38.2 Z0 also seems to work, but has a shorter probing time then G30.

Since I will need to extend the duration of probing, is this something to be set during compilation, or rather an option in the menu settings?