Lowrider 2 mit Bigtreetech SKR V1.3 Probleme

Hallo zusammen

Ich bin gerade dabei mir eine Lowrider 2 CNC Fräse zu bauen. Es ist auch alles soweit fertig bis auf die Software.
Verbaut habe ich folgendes:

  • Bigtreetech SKR V1.3 Board
  • Bigtreetech TMC 5160 5x
  • Bigtreetech TFT35 V2.0
  • Dual Endstops

Ich habe versucht die Firmware mit Visual Studio Code und PlatformIO zu erstellen. Leider kommt immer folgender Fehler:

Konnte das Paket mit den Anforderungen von ‘framework-arduino-lpc176x @ 0.1.3’ für Ihr System ‘windows_amd64’ nicht finden.

Kennt vielleicht von euch jemand das Problem oder hat jemand die Fräse auch mit dem Bigtreetech Board gebaut ? Schon mal vielen Dank für eure Hilfe !

Gruß Florian

Hallo Florian,

hatte das gleiche Problem. Es lag an der “alten” fertigen Firmware die hinterlegt ist. Mit der Version kommt das neue Platformio 5.x nicht klar. Habe lange herumgebastelt und letztendlich ein aktuelle Marlin 2.0 Version heruntergeladen und dann modifiziert. Danach konnte ich sie auch kompilieren und auf das SKR1.3 packen.

Gruß Peik