Lowrider SKR 1.4 Turbo 2209 build with laser

First of all thanks to Ryan and everybody else making this seem possible :raised_hands:

I am almost there, it has been a challenging journey, hours of googling and assembly…

I went for the dual endstop, i hope it is worth the extra hassle…

Electronics and programming is always a challenge for me, i need full guidance :grinning_face_with_smiling_eyes:

Hardware:

SKR 1.4 Turbo with 2209 drivers and TFT 35
NEMA 17 from stepperonline, bipolar 1.8°
12V PC PSU
Neje 30W (4W) laser module
Makita knock off China router

Firmware choosen was Marlin_V1CNC_SkrPro_DualLR_2209_2.0.7.2_510-src, have no idea if this board is different from the turbo?

For the TFT i think i used this BIGTREE_TFT35_V3.0_E3.26.x.bin will check…

I 3D printed my own box, very bad design, it is horrible to wire the board in the box.

Working area is 3000x1300x200mm. I reused some old tables, it is kind of a proto to learn what i need to do with vac table and so on. I used some alu 30x30x2mm angle profile for rails, it is to flimsy since i have it sticking out 400mm, maybe with some support it is ok.

So issues encountered and word of advise:

Searching for answers is an horrible task since there are many versions of everything, sometimes the answere can be found in a 3D printing forum, take a moment to think if other platforms could be worth seeking knowledge in, or maybe just ask here in the forum…

SD card: some of my SD cards dos not work for firmware upgrade. I you are having troubles try another one, FAT32 formatted and smaller cards usually better.

TFT reads “No printer attached” be patient you need to wait quite a while sometimes before it disappears.

Laser TTL, you think it is all good you have 12V TTL so you are fit to just put in on F0. Dos not work, the modulation is done on the gnd, so there is always 12V on the signal pin. Cant help you yet, need to find out how to fix that…

I am missing Z1 endstop ( see picture), so i am unsure is it because of i have skr pro firmware (and not Turbo) or is this just the way it is? and what to do about it? where do i wire Z1, an can i keep the Zprobe?

Stepper wiring or steps/mm? I have done no adjusting what so ever, used all recomended GT fittings, when i make x move 10mm it moves 47mm, so did i wire the stepper wrong or i just need to change steps pr mm like when you calibrate a 3D printer?






Again, thank you for making this possible, you are legends in my world :muscle:

Best regards

from Denmark

Jan A

1 Like

The Pro is a different board from the Turbo. The Pro has 6 drivers on it for starters, but is also a different CPU and requires different firmware.

The Turbo has community supported firmware, but the firmware on the Pro is V1 supported.
Edit: The Dual endstop firmware on the Pro is also community support, Not V1.

1 Like

FAT32 formatted and smaller cards usually better.

What I’ve read is that you need FAT32 2Gb and smaller cards.

As for the SKR Pro firmware vs. the SKR Turbo, in your shoes I’d do a bit of research. While you probably already know this from your thrashing around, the primary three files that configure Marlin are:

  • configuration.h
  • configuration_adv.h
  • pins_ file

If it were me, I’d do a diff on these three files between the version of the firmware you are using and the V1CNC_SkrTurbo_DualLR_8825 version. For the pins files you will have to drill down a bit. I think you need to compare these two:

  • pins_BTT_SKR_V1_4.h
  • pins_BTT_SKR_PRO_common

I’m currently using Meld to do my diffs.

I also wonder if there are any compiler setting differences since the two boards run different microprocessors. Probably not, but it might be worth checking out.

As for the laser, things I’ve read on the forum indicate that you want inline laser commands. Even when people get the fan pins working, sometimes there are quality issues with the laser cutting. Laser support is enabled by V1 in the MPCNC version of the SKR Pro firmware, and I assume it is enabled in the LowRider version as well.

The laser pins for the SKR Pro builds are defined at the top of configuration.h:

#define SPINDLE_LASER_PWM_PIN PC9
#define SPINDLE_LASER_ENA_PIN PB0 

The PWM pin should be a 3.3V pin and therefore won’t suffer from the ground-side-switching issue. And according to the spec for the Neje 30W, it can use 3.3V PWM.

when i make x move 10mm it moves 47mm

Being off by this amount is strange. Is this true for all axes including Z? Is this amount consistent no matter where the router is position relative to the origin? The V1 maintained firmware is setup for the spec’d hardware, so before changing steps per mm, I’d check the following:

  • Do you have the right pulleys on the steppers?
  • Do you have the microsteps set correctly for the steppers? I believe for the 2209, it should be set to 32.

With being off by this strange amount, I’m thinking you have a combination of issues. Perhaps check the grub screws on the pulleys as well.

1 Like

Thanks, i need to look into this…

From what you are saying, there is no way around it, down the compiler hole i most go. Have not done this for years, and always mostly copy paste in the past…never got good at it…

so a SKR 1.4 Turbo 2209 firmware should be possible to cook up from the available LR PRO and Turbo version. The laser part should be easy if i can get around the other issues.

I have not set microsteps…dont get why i have to? Is it not set the right way when it is a 2209 firmware?

I only measured the X axis… I will get back to that when i have new firmware…

Thanks for your time and effort, much appreciated.

We try to make it as easy as possible and keep people from getting lost in the firmware. But it really isn’t very hard. The marlin configuration is almost completely in 2 files (configuration.h a d configuration_adv.h) and it is just commenting out options, or removing comment characters to enable options.

The tools can be a bit fickle. And of course, they dont give you any partial credit. Check out Ryans quick guide at platformio

1 Like

I am so rusty with this…

I open V1CNC_SkrTurbo_DualLR_8825 and the V1CNC_SkrPro_DualLR_2209, both library folders are empty?

The Turbo version is not prepared for laser, why was it the Pro version would be a problem on a Turbo board?

So much wrong knowledge on the internet makes it hard for clueless people like me…

Not sure what you mean by “library folder.” When you open the ZIP file, inside you will find a compiled binary file plus a nested ZIP file. You have to unzip the nested ZIP file in order to access the Marlin source files. As for laser support, V1 only enabled lasers in the firmware for boards where they tested the laser support. There is no explicit problem with lasers on the Turbo. You will have to do the work. Using Meld to compare the configuration files, you can identify what lines need to change, plus you have to identify what pin to assign for laser support. I don’t know enough about the boards to say whether the pin used for the Pro will work for the Turbo.

1 Like

I finally got some time and energy for this again…

"Not sure what you mean by “library folder.”
I used the arduino app, it has a library folder, when i open the Marlin sketches that was empty…

I have now switched to Platformio now, and tried to convert SKRTurbo DualLR8825 to a 2209 version…

My Skr 1.4 Turbo board is hooked up to steppers, endstops, TFT35 and so on …I can not use the Marlin Builder to upload to the board…On my PC the board just shows up as Marlin USB device…
I then tried the FIRMWARE.bin file on a micro SD card, and start up the the board, nothing happens and it just seems to load the old firmware…

So any advice on firmware update?
Where in Platformio do i rename the firmware so it is not the same name?

Forget about above, apparently the card had updated :slightly_smiling_face:

Almost succes, i fired up the laser…

now just need to get the endstop working and installed a safety stop :stuck_out_tongue_winking_eye: