Lowrider Z-Probe

Good day,

I would need your help with the Lowrider and the Endstops

As a board I use the Arduino Mega 2560 with a Ramps 1.4 with the dual-Firmware

The endstops dual X and dual Z and simple Y_min are connected and work wonderfully.

Is there a solution to use Y_max as Z_probe? What do I have to change the firmware so I succeed.

Mfg Steve

I’ve wanted to know this myself. I have never tried it. I’m not sure it’s possible.

Thanks for your reply

But, if you do not know that :slight_smile:

I am a beginner :stuck_out_tongue:

https://www.youtube.com/watch?v=HqCZmVg4dT0&fbclid=IwAR2hepexqoLoWLsTW7lJG7AwsVk6qcWjcjlYgoOdOneWj5G-_khKts1ytdU

I think this guy has the same board.

I haven’t seen it done. We’ve talked about it once or twice before. That does not mean it’s not possible. Maybe since you are a beginner, you’ll more easily find the way to get it done.

When I’ve used probes in 3D printing, it’s always been the same as the zmin endstop. I’m not sure how you would send a gcode to probe instead of home. You can’t do (for example): G28 -Z or G28 +Z. So is there some G38 command to probe, and somehow use that for your Z=0? I’m pretty sure there is a way to make the endstops different than the probe, but I would have to do some reading to find out what that would give you.

Please, don’t be discouraged. You probably won’t break anything for trying. If you get it, you’ll be a hero (for at least a few of us).

1 Like

Have been trying for some time, but unfortunately I can not find a solution.

I have not tried it but this is what I would try first:

Within Configuration.h:

Make sure this is enabled:
#define USE_YMAX_PLUG

Make sure this is disabled:
//#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN

Define assign the probe to use the Y_MAX_PIN:
#define Z_MIN_PROBE_PIN Y_MAX_PIN

Configure probe for normally open (true) or normally closed (false) according to your preference:
#define Z_MIN_PROBE_ENDSTOP_INVERTING true

Within Configuration_adv.h, enable G38.2 and G38.3:
#define G38_PROBE_TARGET

And for added fun, enable G38.4 and G38.5:
#define G38_PROBE_AWAY

After setting/checking these things, try M119 and see if it reports the probe state at all, and press/release the probe to see if it reports the probe state correctly. If it does, try G38.2 Z0 to see if it works. If not, report back what you find and maybe we can fix it from there.

2 Likes

Oh and about probing vs. homing, I think you would do G38.2 Z-100 to find the position and then G92 Z0 to set that as the zero point, similar to manual ‘homing’ using a sheet of paper under a printer nozzle for instance. You can also probe X and Y if you have the right kind of touch probe, so then you have the best of both where you can home (G28) to machine coordinates and you can also zero relative to your workpiece with G38.2 and G92, even using workspace coordinates if you’re into that sort of thing.

 

2 Likes

Hi

Sorry, there was no time at the weekend to check this.

But unfortunately I get error messages when compiling

error.txt (3.11 KB)

Error message:

sketch\src\inc/SanityCheck.h:1819:6: error: #error “G38_PROBE_TARGET requires a bed probe.”

 #error "G38_PROBE_TARGET requires a bed probe."

  ^~~~~

Looks like something is wrong with the config and it doesn’t think you’ve defined a probe.

Looks like it’s looking for FIX_MOUNTED_PROBE or others:

2 Likes

Hi

Thank you very very very very very very much, Jamie and Jeffeb3 for your help.

It works wonderfully.

Now only change the cncjs-Software that everything works fine :slight_smile:

Does anyone have macros for the MPCNC and CNCJS?

Thanks

Steve