Lowrider2 from Minnesota

Thanks Ryan! Big props on the design of the parts and the ease of the kit.

My goals for this is something that could do signs and some woodworking projects I have in mind including some cribbage boards and doing some end milling/pockets for mortise and tendons. A working area of 24" x 48".

I have my table mostly done. The top is an only office table that is 1 1/4" thick particle board. It is really flat and thanks to some good guides for my circler saw is very exact (I am within 1/32" on all dimensions and corner to corner). The bottom is another old office table someone built as a utility table for setting computers (old tower servers). It is really dense particle board. Both are heavy and sold. The bottle table is going to get a vise mounted in the wings of the top so the router can run over the top of the vise for end milling. For now the top is just sitting on the table until I get the vise mounted.

I did .085" wall tubes since I am planning running some higher z heights with long bits to do the end milling and I wanted it STIFF. I figured with the smaller size the extra weight of the tubes would not be an issue.

I have it up and running after some wiring brain farts and got the gcode crown printed (sloppiness is from the pen holder I used, not the machine - https://www.thingiverse.com/thing:3541574). I cracked a couple of the XZ’s so I am reprinting them (they had some printing issues that lead to the crack, slicer was not liking me). My next big task is to get the wires cleaned and sleeved. I have a couple of Ikea tape measures waiting for cable guides.

My z is binding a bit and will not drop completely on its own when I power down. I have loosened and retightened most of the bolts and screws, so I am guessing it is sloppiness in the cutting of my Y plates. I used https://www.thingiverse.com/thing:3364669 and cut it out with a templating bit on my router table and drilled the holes with my drill press and it flexed a few times. I also printed a template for the router plate on my Ender 3 (printed in 2 pieces that I glued back together, I will throw the files on Thingiverse sometime). Once I have it ready to run one of its first jobs will be cutting new y plates.

Let me know any thoughts. It will be an adventure and that is my main goal.


One quick question, the smart controller case (https://www.thingiverse.com/thing:1562144) didn’t allow the knob to click down. See attached photo. I ended up just cutting out the material around the know to make it work for tonight, but I am doing something wrong or is my controller knob shorter than normal?

[attachment file=103603]

I want to build a way to do end milling in my LR too. I’m jealous. That table looks good and stout too. Milling a tenon will be easy, as long as you can set up the job precisely. I would try to find a good way to make sure the stock is square to the gantry and it will save some time if you have something to register it against for zero (although not critical). I have dreams of making pantarouter quality joints with it.

The strength of the Z decreases exponentially with height, so the lower you can mount the stuff, the better.

If you have any trouble with the wheels tracking straight, then put some strips on the inside to keep them from driving side to side.

Regarding Z binding, did you grease your leadscrews? Are the Z pipes parallel to each other in both directions? Are the leadscrews going straight into the nuts? Ryan can also find errors from photos from all sides of the gantry. He has spent enough time looking at it, I guess.

I think I remember someone else having that knob issue. I made (frankensteined, really) this case from a lot of other good cases. Maybe the knob can help you?

1 Like

Looks good. I wouldn’t worry about it dropping under it’s own weight, never something I would call important. The knob, some are tighter than others, someone came up with a cool trick to put a tiny piece of ziptie in the knob slit to keep it up 1/8". Can wait to see how the fancy joints come out.


I printed a couple of replacement parts and was going to get it finished up…Instead I made dust!

[attachment file=103787]

1 Like

i put some tape under the board for the knob to work as it was flexing the PCB too much. Works good so far?

1 Like

I’ve been having the same issue with the knob and my printed case. My solution was to pull the knob off and shove something up in there so when I slide it back on it sits higher. Has been working great so far.

1 Like

I got it moved into my basement and got a v1pi setup (love it). I am trying to cut a new Y plate since I think my 1 side that will not drop is binding with my holes out of alignment. I have tried cutting it 3 times with issues. In my first cut, I ran from cnc.js and noticed that the holes were shifted from the outline. I assumed that there was an issue with the signal from the pi and missed moves, so my next attempt I ran from the card, with the pi still connected so I could watch the terminal. I noticed partway through the holes that the lowrider was running croaked on the table, so I stopped the cut and reset the lowrider to the belt belts and started again. Again, partway into the cut it was running croaked on the table. I was going to let it finish to see how my cuts went and if I could see any missed steps. Instead, I saw an error come up in the terminal about unable to read from the card and the lowrider went on an adventure (see photos).

Any help on what to check would be great. I was running a 1/8" 2 flute endmill, ~3.5 on the DWP611, 30 mm/sec feed rate.

If it was missing moves, it would have details missing, but the coordinates are absolute, so it wouldn’t have any offset. Also, I have seen a bad usb connection cause pauses, but never skipped instructions, so I don’t think that is the problem.

My guess is you skipped steps. What controller are you using and are you wired in series? What speed and depth of cut are you using?

Before you move the machine, make sure the gantry is square. If you’re already doing that, then one side is skipping steps. That crooked toolpath is caused by one side being farther ahead than the other.

You might find it interesting and helpful to try either use a pen to draw a test pattern, or to mill in the pink HD foam. Getting the setup, including the squaring, figured out first. Then add in the trouble of getting doc and speeds right for the mdf.

Thanks Jeffeb3. I have done a crown test and it was good. I was cutting at 30 mm/sec and 1.5mm depth per cut. 2 flute up cut 1/8" endmill. Was I pushing too hard?

Mini Rambo wired in series.

Everything is square to start and a test cut of a 10 cm square was perfect.

You’d do better to go slower. I wouldn’t cut full width 1/8" any faster than 15 or even 10mm/s. You can probably go deeper though. I wouldn’t be surprised if 10mm/s and 4.5mm doc was a lot better, because the steppers lose torque when they go faster. But if you skip steps again, go 10/3.

1 Like

I’ve played around with some feed rates too but pushing the feed rate never got me anywhere good. The speed/time savings for me have come from doc like Jeff is saying.

I just finished cutting a bunch of maple, I had it set for a 1/8" single flute uncut at 5mm doc, 8mm/sec and it was very happy, cuts were great.

False starts and crashed programs never saved me time in the big picture so I kept pulling back on the speed and deepening the cut. Also for finishing passes, you can do single full depth passes for your finishing bit as you’re only taking a tiny slice so I go 15mm/s and 20mm doc for my finish bit. Works great and is a big time saver.


So when I jog it 600 mm on my X (the length of the table, I guess most people call that the y since it is the long way) it is off by 16 mm from side to side. It is as if the 2 steppers are geared differently. I wired them in series per the basic lowrider build instructions. The more I move it on the further it gets off.

1 Like

Did you get the belts from the same place? Are they both taught? We had a case of a weird belt pitch a while ago that was off by about 2%.

The other thing to check is to make sure the set screws on the pulleys are tight. What happens if you move it 600mm in one direction and then 600mm back. Do the wheels end up in the same starting place?


Everything is from a V1 kit. Belts off of the same roll. The one side is always short of the other, in either direction. Screws are tight.

The description and your video are very helpful. But it’s a mysterious behavior. I don’t know what it is but I think there are many things that can be ruled out:

  • Backlash from loose pulley set screw or other loose assembly, unlikely because you checked, and you said it gets worse the further it moves, which would not occur from backlash
  • Dual endstop or independent motors are not in play because you are wired in series
  • Skipping steps or insufficient current or excessive current and thermal shutdown are not occurring because you see the same effect with no load and nothing unusual is audible
  • Incorrect belts are not the issue because the belts are from the same stock.
  • Belt tension could in theory have one belt stretched relative to the other but at 2.5% length difference the tension would have to be insane and you would know

What is left? Firmware seems really really unlikely. Even though the steppers are driven in series, the firmware could in theory apply some sort of skew correction… really going out on a limb here. If you were to swap the X1 and X2 motors, or if you swap the wiring and leave the motors in place (not sure if that’s possible) you can see if the short side switches sides or not.

If the short side changes sides with either experiment then it rules out anything in firmware and of course points to what you swapped. I don’t know how a motor can be off by 2.5%; it should be “impossible” and consistent skipping steps should also be impossible but it would at least suggest where to examine more closely.

If the short side does not change sides then it could in theory be firmware, but if you have not messed with the firmware then that would be really, really unlikely. You could re-flash back to stock if you have made changes, and if you haven’t, then just M502 would be enough.

I agree. It should be easy to swap the Y and Z wiring. See if the issue follows the wires or the steppers.

Also you can try upping the Y current in the Lcd advanced menu drive strength to 1200.

They are wired in series. The firmware and the driver don’t have the ability to move one motor without moving the other.

Oh, right, I was thinking something different, (if the X motion of the tool were different when the Y position of the tool was at Y min vs. Y max, I can’t prove it’s not software doing some weird thing). But with a single movement only in X and the two ends of the gantry move different distances, that can’t be software compensation.

1 Like