Lowrider2 movement issue

Hello all!! I have finally wired my setup (all but the dual end stops) and flashed both the board and the screen. Whenever I attempt to move any of the motors, they nudge and then freeze. Is there a setting that I am overlooking?

I would post pictures in this post, but I am limited since I am an new user…

That sort of sounds like the screen is sending absolute commands when it should be sending relative ones. Have you tried marlin mode (push the knob in for 10s).

I did and got the same result.

Pretty strange. Can you connect a computer and send M115 (to see that it shows v510D) and M122 (after a move, to see if there is any error flags shown).

Does it move freely by hand when the motors are off? Does it hold its position after a move (for at least a minute)?

Jeff, sorry for the delayed response. I am still having the same issue. Below is what i received after doing what you asked:



X Y Y2 Z Z2
Address 0 00 0 0
Enabled true false false false false
Set current 900 900 900 900 900
RMS current 887 887 887 887 887
MAX current 1251 1251 1251 1251 1251
Run current 28/31 28/3128/31 28/31 28/31
Hold current 22/31 22/31 22/31 22/31 22/31
CS actual 22/31 22/31 22/31 22/31 22/31
PWM scale
vsense 1=.18 1=.18 1=.18 1=.18 1=.18
stealthChop falsefalse false false false
msteps 16 16 16 16 16
tstep max max max max max
PWM thresh.
OT prewarn false falsefalse false false
OTP false false false false false
pwm scale sum 25 25 25 25 25
pwm scale auto 0 0 0 0 0
pwm offset auto 36 36 36 36 36
pwm grad auto 14 14 14 14 14
off time 3 3 3 3 3
blank time 24 24 24 24 24
-end -1 -1 -1 -1 -1
-start 1 1 1 11
Stallguard thrs 0 0 0 0 0
uStep count 920 56 56 56 88
sg_result 0 0 0 0 0
olb ** * *
ola * * * * *
Driver registers:
Y 0x80:16:00:C0
Y2 0x80:16:00:C0
Z 0x80:16:00:C0
Z2 0x80:16:00:C0

This stands for “open loop on coil a” and then for b. So something is funky with the wiring. It looks like only the X is enabled, so I can only trust the X result. But definitely look closely at the wiring.

It does move freely when off (I made sure to disconnect the motors from the board before hand).

I will look at the wiring again and let you know.

I have checked and triple checked the wiring and it all looks good. The only piece of wiring not covered anywhere I have seen is the power. I have the power supply that came with the parts kit. I have it going to the power port on the board and also have a jumper from that port to the motors port. Could this somehow be the problem?

The wiring issue would have to be between the motor driver and motors, not the power supply.

Try looking at that M122 output after doing some movements. See if you can figure out a pattern.

I have tried multiple tests and cannot seem to see anything changing in a pattern except for the lack of movement. I have checked and and rechecked the wiring, compared the results of M122 issued before and after a move command, re-flashed the screen and the board, and even checked the configuration.h (in the Marlin_V1CNC_SkrPro_DualLR_2209_2.0.7.2_510-src from V1) and config.ini for the baud rates. I simply cannot seem to find anything. There may be something that I am over looking, but could it be the board itself? someone said to try the potentiometers, but according to the documentation that should not be necessary.

1 Like

STAND DOWN!!! The only issue is me… It seems to have been working properly all along. I am sorry to have been waisting your time Jeff.

1 Like

Well, that is weird. I guess the M122 was a false alarm.

Do you mind sharing what was wrong, so we can help others in the future?

Yeah, I gotta know what was the issue?

Sounds like an ID/10-T or PEBCAK issue. I’m very familiar with those… :wink:

1 Like

So, I was the issue. I have a 3D printer utilizing the NEMA stepper motors, but I have never heard them “hum”. When I would press the movement button, it would move, but the motors would “hum” so I thought that they were not engaging properly or were meeting resistance. With that in mind, I would quickly pull the plug because I didn’t want to risk burning it out. This “issue” went on for weeks as I stripped and re-wired the board, and re-flashed the board and screen, the issue remained.

Yesterday I brought in the Command Officer (the wife and yes I am in the military) she said, “I don’t see what the problem is. Press the button again”. Boy did I feel stupid!!

I want to say thank you and sorry to Jeff. I appreciate all your time and effort helping me TS a non-issue.

Ryan, your product is AMAZING! I cannot wait to get to creating!!


No worries. I am glad your wife figured it out :slight_smile: . That story is completely relatable.